summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-Mail_mimeDecode
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-php/PEAR-Mail_mimeDecode
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-php/PEAR-Mail_mimeDecode')
-rw-r--r--dev-php/PEAR-Mail_mimeDecode/Manifest2
-rw-r--r--dev-php/PEAR-Mail_mimeDecode/PEAR-Mail_mimeDecode-1.5.6-r3.ebuild24
-rw-r--r--dev-php/PEAR-Mail_mimeDecode/files/PEAR-Mail_mimeDecode-1.5.6-r3-php8_compat.patch12
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-php/PEAR-Mail_mimeDecode/Manifest b/dev-php/PEAR-Mail_mimeDecode/Manifest
index 8096d31ca3d6..90d12d5c3504 100644
--- a/dev-php/PEAR-Mail_mimeDecode/Manifest
+++ b/dev-php/PEAR-Mail_mimeDecode/Manifest
@@ -1,3 +1,5 @@
+AUX PEAR-Mail_mimeDecode-1.5.6-r3-php8_compat.patch 404 BLAKE2B 2bf9a4dd203f772988afcc74777e0bbdd2c945328846d83ff92d50982d51d8b10304deb9dc4105c0abdbcc26e10717cf41952f9131ae042b93db143711a64079 SHA512 4671c12d2579c72525c62aebfe2696e1af634340d02f8778e321a6eb01fa4866b922ccfa1dc60c40b5935a0c15654a05cebd5c85f211c9431bbf87c93a8523c7
DIST Mail_mimeDecode-1.5.6.tgz 13258 BLAKE2B 7e027cf9bf2a450bde639f8c530f216cc8dfd9eab719829dedad029d98fc5c4806279d13ec3ffb5191ba23edf64ae658ca0ec8d83f116da3fafbd23d758a9f00 SHA512 fe46ff2542acd3b180981c7dae41a1979b2edb3bfa5ad716a1ff39a255c2c04d92a7d770ae6531e38f3b869173f576fba44410c8e03269510d71dce5fa345bd1
EBUILD PEAR-Mail_mimeDecode-1.5.6-r2.ebuild 480 BLAKE2B 227f83adfd1585ab08f1b42dd86722d2bd428ebf320044654da037d98c1bd5b964b96086697555c0e4a721eedbfcec5f9b1d8b5ea0cb4cf3bbbfeb444c8e2427 SHA512 18ddcd6f6201484794d380533546fb352871f3d683bc7773c7665902e8a31d3ac7685aca5c27cb28edaacca2ec35462a2ad72252a89ae3aa1fdef3eb06ec258c
+EBUILD PEAR-Mail_mimeDecode-1.5.6-r3.ebuild 556 BLAKE2B 5832e3ed07c1c30d2a464be4b3cc84aad4663ec68d3803eb36845a7e2ae52c68b49edc3ba87044de9ff1b6cb27eae6200651966e0b2068b0e84299c8fd754527 SHA512 f926b88faf9e7d65d6e5ae8551632d2a611ca79f87f1aa25534a236864749ee57b6eca4996ce7b88eacdb1a6f111ab9c0eed38fbf5cff356b760dd8c576db8c9
MISC metadata.xml 318 BLAKE2B 1c42fc40996e9cbf8eedbe0db55a4fc9df55e1b75fd67154199f009839ca1a291cefd40608024b7e7caae4a694d27468907c673d87d4b470fb5b61657ace2032 SHA512 19ff2178e9febd85c0642452b052421a203d335dedb58accae0e89996f81b1e2420164c06e558600cca86378850b45f8854c88d72166fd5407712b86eee411a7
diff --git a/dev-php/PEAR-Mail_mimeDecode/PEAR-Mail_mimeDecode-1.5.6-r3.ebuild b/dev-php/PEAR-Mail_mimeDecode/PEAR-Mail_mimeDecode-1.5.6-r3.ebuild
new file mode 100644
index 000000000000..56773b569a82
--- /dev/null
+++ b/dev-php/PEAR-Mail_mimeDecode/PEAR-Mail_mimeDecode-1.5.6-r3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit php-pear-r2
+
+DESCRIPTION="Provides a class to decode mime messages (split from PEAR-Mail_Mime)"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ppc ppc64 ~s390 sparc x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-php/PEAR-Mail_Mime-1.5.2"
+DEPEND="test? ( ${RDEPEND} dev-php/PEAR-PEAR )"
+
+PATCHES=(
+ "${FILESDIR}/PEAR-Mail_mimeDecode-1.5.6-r3-php8_compat.patch"
+)
+
+src_test() {
+ pear run-tests tests || die
+}
diff --git a/dev-php/PEAR-Mail_mimeDecode/files/PEAR-Mail_mimeDecode-1.5.6-r3-php8_compat.patch b/dev-php/PEAR-Mail_mimeDecode/files/PEAR-Mail_mimeDecode-1.5.6-r3-php8_compat.patch
new file mode 100644
index 000000000000..e167af7f6a33
--- /dev/null
+++ b/dev-php/PEAR-Mail_mimeDecode/files/PEAR-Mail_mimeDecode-1.5.6-r3-php8_compat.patch
@@ -0,0 +1,12 @@
+https://pear.php.net/bugs/bug.php?id=23775
+--- a/Mail/mimeDecode.php
++++ b/Mail/mimeDecode.php
+@@ -834,7 +834,7 @@
+
+ // Replace encoded characters
+
+- $cb = create_function('$matches', ' return chr(hexdec($matches[0]));');
++ $cb = function($matches) { return chr(hexdec($matches[0])); };
+
+ $input = preg_replace_callback( '/=([a-f0-9]{2})/i', $cb, $input);
+