summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-Log
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/PEAR-Log
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/PEAR-Log')
-rw-r--r--dev-php/PEAR-Log/Manifest3
-rw-r--r--dev-php/PEAR-Log/PEAR-Log-1.13.1.ebuild47
-rw-r--r--dev-php/PEAR-Log/metadata.xml11
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-php/PEAR-Log/Manifest b/dev-php/PEAR-Log/Manifest
new file mode 100644
index 000000000000..5d1f7211a78c
--- /dev/null
+++ b/dev-php/PEAR-Log/Manifest
@@ -0,0 +1,3 @@
+DIST Log-1.13.1.tgz 46764 BLAKE2B dc0f4605ed801818ddf070ec3beb6818af1630d99bec721cd3f487e709f87bd4a1628a05854c48fe9775aab546bdce4618061ef37674aa9921f536deccc6a080 SHA512 246510b7dbff4dc9f9cdd951d76baf2dd377e30ffde6d38cadac10091dcb92f8095406edb6d8a87ebe2330d514ce99f355f84ebfe57cd8a3f3babc316995148a
+EBUILD PEAR-Log-1.13.1.ebuild 1330 BLAKE2B 7b1012d9ab49971d9aed4c9655781556c0c4617d12d2e9d18b5960287c9a4eec3dcff11334eeefb7f91d53a25f13620c78df7d53cc81b29ae05b4b7398c5dfab SHA512 c4af6ba4459f80e033fc6f3c85409b5ef65dc1a5de28ec9df29bf67d5b69625067f6255838bfccee524f1af2d8ea7cd20bae36bfa6e25f85091a1549b30d0787
+MISC metadata.xml 305 BLAKE2B 9ae588d4fa3e555b0362d0f9ba19dd3bfd459f1788fb047852f22cde3d2688e3807d4ad87247b9dd8759450af1c1ce55192b2e551a8337abd08fbc771f32cd36 SHA512 8540d045359dc2f4ed04bde79616f2ebe923a0d3a6e401788a37e3bfd973a9db33662f5c01326e0fe0198246dad290d8d3ec3d841394071c215f70a8ad4abf71
diff --git a/dev-php/PEAR-Log/PEAR-Log-1.13.1.ebuild b/dev-php/PEAR-Log/PEAR-Log-1.13.1.ebuild
new file mode 100644
index 000000000000..d6a41ea76d21
--- /dev/null
+++ b/dev-php/PEAR-Log/PEAR-Log-1.13.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="The Log framework provides an abstracted logging system"
+HOMEPAGE="http://pear.php.net/package/${MY_PN}"
+SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
+IUSE="examples test"
+
+# The DB, Mail, and MDB2 dependencies are technically optional, but
+# automagic. To avoid surprises, we require them unconditionally.
+RDEPEND="dev-lang/php:*
+ dev-php/PEAR-PEAR
+ dev-php/PEAR-DB
+ dev-php/PEAR-Mail
+ dev-php/PEAR-MDB2"
+DEPEND="test? ( ${RDEPEND} )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ dodoc docs/guide.txt misc/log.sql
+ use examples && dodoc -r examples
+
+ # I don't like installing "Log.php" right at the top-level, but any
+ # packages depending on us will expect to find it there and not as
+ # e.g. Log/Log.php.
+ insinto "/usr/share/php/"
+ doins Log.php
+ doins -r Log
+}
+
+src_test() {
+ # Requires the "pear" executable from dev-php/PEAR-PEAR.
+ pear run-tests tests || die
+
+ # The command succeeds regardless of whether or not the test suite
+ # passed, but this file is only written when there was a failure.
+ [[ -f run-tests.log ]] && die "test suite failed"
+}
diff --git a/dev-php/PEAR-Log/metadata.xml b/dev-php/PEAR-Log/metadata.xml
new file mode 100644
index 000000000000..509eaf73bd24
--- /dev/null
+++ b/dev-php/PEAR-Log/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pear">Log</remote-id>
+ </upstream>
+</pkgmetadata>