summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-Log
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-php/PEAR-Log
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-php/PEAR-Log')
-rw-r--r--dev-php/PEAR-Log/Manifest5
-rw-r--r--dev-php/PEAR-Log/PEAR-Log-1.13.1.ebuild47
-rw-r--r--dev-php/PEAR-Log/metadata.xml11
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-php/PEAR-Log/Manifest b/dev-php/PEAR-Log/Manifest
new file mode 100644
index 000000000000..69ece55d4f28
--- /dev/null
+++ b/dev-php/PEAR-Log/Manifest
@@ -0,0 +1,5 @@
+DIST Log-1.13.1.tgz 46764 SHA256 2206a34816dc6b800bdfeef1dbe4ee340067c6b12b035d19db777be9325765e0 SHA512 246510b7dbff4dc9f9cdd951d76baf2dd377e30ffde6d38cadac10091dcb92f8095406edb6d8a87ebe2330d514ce99f355f84ebfe57cd8a3f3babc316995148a WHIRLPOOL fe5ed54ca52e8e1fcad406067200c556ec8bfadf7c66eec352bd0d1af5637fecec06ee00c62c06afefaa0b8207f128b163af97ef07abd25b8c67799d67044158
+EBUILD PEAR-Log-1.13.1.ebuild 1330 SHA256 b525cdb44cea436e5a7ac2ffe4d1112520e196397552f5f7e0bb27b9f6b4fd4b SHA512 c4af6ba4459f80e033fc6f3c85409b5ef65dc1a5de28ec9df29bf67d5b69625067f6255838bfccee524f1af2d8ea7cd20bae36bfa6e25f85091a1549b30d0787 WHIRLPOOL c6b4f719e2caae207055c7091bb359889459180a282a8df6823450a5096efc0774ec8fdef1119cbb55092a4b0811b4c318ec833c697d5226dadb22f587207426
+MISC ChangeLog 2751 SHA256 104f4d33e16a00fbd29f3d22a758a154304af3cdc2002c52db1d63dcf73b6e86 SHA512 fc3f1040f9e909940aff61cba14205469dac15c1de4a2006bba034924ae5158f33b533c64c136ff3058e63bb6e56f9b42e483b5960f3fac61bacbf9b7c27f931 WHIRLPOOL c4c3897e582a63e0c29b11cde4c9aeb5d33150d7b0aa1bf39a61d3fc5e11c4ad611cc5ccb66fd71d452d6df4e72dda21637ef1199514f18bb022a77305277a41
+MISC ChangeLog-2015 13058 SHA256 7e66c8e5bb90e8f2f2443da8f4f1ee7d4dd9bb407d0e591ff0e3c7f05931b03d SHA512 fdc003907d436405df26cca5eac4de5c2bf338d038d183faaaab94e654bbf2da7c14ab2fbf767573c6e07d791f3cbf568872bf2ecbfca7367131ecc747461411 WHIRLPOOL 173956647c2a2e216c58ab3ef73779621790d5373f746b353e3a5554616b3424060289a0fba8132e11b88c881cec71aa3fd8a220824ca79299944a89b915e383
+MISC metadata.xml 305 SHA256 b6bd27aa2905a4af9025a7a3cb7e8bee905c95c85bcc6705f8fd766eed60f159 SHA512 8540d045359dc2f4ed04bde79616f2ebe923a0d3a6e401788a37e3bfd973a9db33662f5c01326e0fe0198246dad290d8d3ec3d841394071c215f70a8ad4abf71 WHIRLPOOL 4bfb40b25477948f4fa06b3f556670283990b4989b2b7698dfb37d981e4d44285cd4cbf5515dc55f8866f68aa4bf52f2d77c12f2b9aea7a88a54eb79011594c7
diff --git a/dev-php/PEAR-Log/PEAR-Log-1.13.1.ebuild b/dev-php/PEAR-Log/PEAR-Log-1.13.1.ebuild
new file mode 100644
index 000000000000..d6a41ea76d21
--- /dev/null
+++ b/dev-php/PEAR-Log/PEAR-Log-1.13.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="The Log framework provides an abstracted logging system"
+HOMEPAGE="http://pear.php.net/package/${MY_PN}"
+SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
+IUSE="examples test"
+
+# The DB, Mail, and MDB2 dependencies are technically optional, but
+# automagic. To avoid surprises, we require them unconditionally.
+RDEPEND="dev-lang/php:*
+ dev-php/PEAR-PEAR
+ dev-php/PEAR-DB
+ dev-php/PEAR-Mail
+ dev-php/PEAR-MDB2"
+DEPEND="test? ( ${RDEPEND} )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ dodoc docs/guide.txt misc/log.sql
+ use examples && dodoc -r examples
+
+ # I don't like installing "Log.php" right at the top-level, but any
+ # packages depending on us will expect to find it there and not as
+ # e.g. Log/Log.php.
+ insinto "/usr/share/php/"
+ doins Log.php
+ doins -r Log
+}
+
+src_test() {
+ # Requires the "pear" executable from dev-php/PEAR-PEAR.
+ pear run-tests tests || die
+
+ # The command succeeds regardless of whether or not the test suite
+ # passed, but this file is only written when there was a failure.
+ [[ -f run-tests.log ]] && die "test suite failed"
+}
diff --git a/dev-php/PEAR-Log/metadata.xml b/dev-php/PEAR-Log/metadata.xml
new file mode 100644
index 000000000000..509eaf73bd24
--- /dev/null
+++ b/dev-php/PEAR-Log/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pear">Log</remote-id>
+ </upstream>
+</pkgmetadata>