summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-Image_GraphViz
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/PEAR-Image_GraphViz
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/PEAR-Image_GraphViz')
-rw-r--r--dev-php/PEAR-Image_GraphViz/Manifest4
-rw-r--r--dev-php/PEAR-Image_GraphViz/PEAR-Image_GraphViz-1.3.0_p20151104.ebuild26
-rw-r--r--dev-php/PEAR-Image_GraphViz/files/Image_GraphViz-1.3.0-constructor.patch55
-rw-r--r--dev-php/PEAR-Image_GraphViz/metadata.xml8
4 files changed, 93 insertions, 0 deletions
diff --git a/dev-php/PEAR-Image_GraphViz/Manifest b/dev-php/PEAR-Image_GraphViz/Manifest
new file mode 100644
index 000000000000..42d5b8264588
--- /dev/null
+++ b/dev-php/PEAR-Image_GraphViz/Manifest
@@ -0,0 +1,4 @@
+AUX Image_GraphViz-1.3.0-constructor.patch 2237 BLAKE2B 5ba878e67e502d74876bcb8af4743035bd8288ef33d4a6e9aafddf7defdce520e85364503055e6442b230227db04fd044484037ea3c501ebb1fc48021476d0c6 SHA512 93f99e3e5c86e2b920a3c66511fd0b44f01747b947e04a69b0bec7256a958ec0a4e15ce81885b5117a941fd3d2a98ce4165d5a9b8e8b0650a9791807f0278964
+DIST Image_GraphViz-1.3.0_p20151104.tar.gz 18109 BLAKE2B 9a8c269a7f4eff787a67c84770c296d3e032a038cae04b888ea5ae26525b24a764ad01d6300d7e7a4c3cf78acb4e077b1f9091cced4ef57031f6ce3aaef2a8e3 SHA512 69e9117cff950a45d8f3cfd5759be8194f477b55c09ceb990707f3ad2de2500a570fa124b73b2c81cdd6ce20b6c11fc0532a0087a515cf3c7c9a5a8ed7b1c58f
+EBUILD PEAR-Image_GraphViz-1.3.0_p20151104.ebuild 697 BLAKE2B 210afe2e444b4e7c5a927b2245b67b7539f21efb918039b74aa921aba06cf6b11a1ecaebde3edfa8c3f9aef2d00d1f2b384aafcd288e42a905fa67b86b341459 SHA512 fd2883e4eb02cdd3b376b1d9babfbcbcb719c17fa1a54234c8fa46ba6e26a6715fe4a34c2dce09600a427ebc876cfd60bbaf600adb73a49ebf1976f1f6b80f1d
+MISC metadata.xml 239 BLAKE2B 9b7c5dcb74289073481cf07031b7a92f32496cc1097becb074d74a8fbb8133de429ce1baf284e446e44132943c8b32e6b824570f15828588e42ea49ef5661f00 SHA512 2181b874bfe8cd31e7730d8207e26cfd2f272eaf2d1b57ae0faff126347a5298fa1c506d9107e1da9736c8a0ed9c8c339e4d9509a8726b79dbe86e073c12dee0
diff --git a/dev-php/PEAR-Image_GraphViz/PEAR-Image_GraphViz-1.3.0_p20151104.ebuild b/dev-php/PEAR-Image_GraphViz/PEAR-Image_GraphViz-1.3.0_p20151104.ebuild
new file mode 100644
index 000000000000..6f780607fbde
--- /dev/null
+++ b/dev-php/PEAR-Image_GraphViz/PEAR-Image_GraphViz-1.3.0_p20151104.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2 vcs-snapshot
+
+DESCRIPTION="PHP interface to AT&T's GraphViz tools"
+SRC_URI="https://github.com/pear/Image_GraphViz/archive/3f8a01ae0597ca9d1d08a6e442cb0b153358fc0d.tar.gz -> ${PEAR_P}.tar.gz"
+LICENSE="PHP-3"
+SLOT="0"
+KEYWORDS="~alpha amd64 hppa ~ia64 ~sparc x86"
+IUSE="test"
+RDEPEND="media-gfx/graphviz"
+DEPEND="test? ( ${RDEPEND} dev-php/PEAR-PEAR )"
+PATCHES=( "${FILESDIR}/Image_GraphViz-1.3.0-constructor.patch" )
+S="${WORKDIR}/${PEAR_P}"
+
+src_prepare() {
+ mv "${S}/package.xml" "${WORKDIR}" || die
+ default
+}
+
+src_test() {
+ peardev run-tests tests || die
+}
diff --git a/dev-php/PEAR-Image_GraphViz/files/Image_GraphViz-1.3.0-constructor.patch b/dev-php/PEAR-Image_GraphViz/files/Image_GraphViz-1.3.0-constructor.patch
new file mode 100644
index 000000000000..da7dfd4724ca
--- /dev/null
+++ b/dev-php/PEAR-Image_GraphViz/files/Image_GraphViz-1.3.0-constructor.patch
@@ -0,0 +1,55 @@
+From 794fdf40ad944225854845a0ff32a5c56fb249d9 Mon Sep 17 00:00:00 2001
+From: Seb35 <seb35@seb35.fr>
+Date: Sun, 6 Nov 2016 22:42:46 +0100
+Subject: [PATCH] Added __construct constructor
+
+This removes deprecation warnings due to old constructor
+(method with the class name). Keep the old-style constructor
+for compatibility (like in the PEAR main class).
+---
+ Image/GraphViz.php | 25 ++++++++++++++++++++++++-
+ 1 file changed, 24 insertions(+), 1 deletion(-)
+
+diff --git a/Image/GraphViz.php b/Image/GraphViz.php
+index ee84ff2..92842da 100644
+--- a/Image/GraphViz.php
++++ b/Image/GraphViz.php
+@@ -181,7 +181,7 @@ class Image_GraphViz
+ *
+ * @access public
+ */
+- function Image_GraphViz($directed = true, $attributes = array(),
++ function __construct($directed = true, $attributes = array(),
+ $name = 'G', $strict = true, $returnError = false)
+ {
+ $this->setDirected($directed);
+@@ -192,6 +192,29 @@ function Image_GraphViz($directed = true, $attributes = array(),
+ $this->_returnFalseOnError = !$returnError;
+ }
+
++ /**
++ * Compatibility constructor.
++ *
++ * @param boolean $directed Directed (TRUE) or undirected (FALSE) graph.
++ * Note: You MUST pass a boolean, and not just
++ * an expression that evaluates to TRUE or
++ * FALSE (i.e. NULL, empty string, 0 will NOT
++ * work)
++ * @param array $attributes Attributes of the graph
++ * @param string $name Name of the Graph
++ * @param boolean $strict Whether to collapse multiple edges between
++ * same nodes
++ * @param boolean $returnError Set to TRUE to return PEAR_Error instances
++ * on failures instead of FALSE
++ *
++ * @access public
++ */
++ function Image_GraphViz($directed = true, $attributes = array(),
++ $name = 'G', $strict = true, $returnError = false)
++ {
++ self::__construct($directed, $attributes, $name, $strinct, $returnError);
++ }
++
+ /**
+ * Outputs image of the graph in a given format
+ *
diff --git a/dev-php/PEAR-Image_GraphViz/metadata.xml b/dev-php/PEAR-Image_GraphViz/metadata.xml
new file mode 100644
index 000000000000..b86acf66c756
--- /dev/null
+++ b/dev-php/PEAR-Image_GraphViz/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+</pkgmetadata>