summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-Image_GraphViz/PEAR-Image_GraphViz-1.3.0_p20151104.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
commit99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (patch)
treeda76713365257a445f3ae3b95470917f59d46728 /dev-php/PEAR-Image_GraphViz/PEAR-Image_GraphViz-1.3.0_p20151104.ebuild
parent4935506e9a5cbfabd37c64093eac5f36c2ff0017 (diff)
gentoo resync : 24.02.2018
Diffstat (limited to 'dev-php/PEAR-Image_GraphViz/PEAR-Image_GraphViz-1.3.0_p20151104.ebuild')
-rw-r--r--dev-php/PEAR-Image_GraphViz/PEAR-Image_GraphViz-1.3.0_p20151104.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-php/PEAR-Image_GraphViz/PEAR-Image_GraphViz-1.3.0_p20151104.ebuild b/dev-php/PEAR-Image_GraphViz/PEAR-Image_GraphViz-1.3.0_p20151104.ebuild
new file mode 100644
index 000000000000..6f780607fbde
--- /dev/null
+++ b/dev-php/PEAR-Image_GraphViz/PEAR-Image_GraphViz-1.3.0_p20151104.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2 vcs-snapshot
+
+DESCRIPTION="PHP interface to AT&T's GraphViz tools"
+SRC_URI="https://github.com/pear/Image_GraphViz/archive/3f8a01ae0597ca9d1d08a6e442cb0b153358fc0d.tar.gz -> ${PEAR_P}.tar.gz"
+LICENSE="PHP-3"
+SLOT="0"
+KEYWORDS="~alpha amd64 hppa ~ia64 ~sparc x86"
+IUSE="test"
+RDEPEND="media-gfx/graphviz"
+DEPEND="test? ( ${RDEPEND} dev-php/PEAR-PEAR )"
+PATCHES=( "${FILESDIR}/Image_GraphViz-1.3.0-constructor.patch" )
+S="${WORKDIR}/${PEAR_P}"
+
+src_prepare() {
+ mv "${S}/package.xml" "${WORKDIR}" || die
+ default
+}
+
+src_test() {
+ peardev run-tests tests || die
+}