summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-Image_Color2/PEAR-Image_Color2-0.1.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/PEAR-Image_Color2/PEAR-Image_Color2-0.1.5-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/PEAR-Image_Color2/PEAR-Image_Color2-0.1.5-r1.ebuild')
-rw-r--r--dev-php/PEAR-Image_Color2/PEAR-Image_Color2-0.1.5-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-php/PEAR-Image_Color2/PEAR-Image_Color2-0.1.5-r1.ebuild b/dev-php/PEAR-Image_Color2/PEAR-Image_Color2-0.1.5-r1.ebuild
new file mode 100644
index 000000000000..657a45b11c2a
--- /dev/null
+++ b/dev-php/PEAR-Image_Color2/PEAR-Image_Color2-0.1.5-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2
+
+DESCRIPTION="Color conversion and mixing for PHP5"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+DEPEND="test? ( >=dev-php/phpunit-5 )"
+
+src_prepare() {
+ # Modernize tests
+ sed -i -e "/require_once 'PHPUnit\/Framework.php';/d" \
+ -e "s/assertType('\(Image_[a-zA-Z2_]*\)',/assertInstanceOf(\1::class,/" \
+ -e "s/assertType('array',/assertInternalType('array',/" \
+ -e "s/assertType('string',/assertInternalType('string',/" \
+ tests/*.php tests/Model/*.php || die
+ default
+}
+
+src_test() {
+ phpunit tests/AllTests.php || die
+}