summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-File_Find
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/PEAR-File_Find
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/PEAR-File_Find')
-rw-r--r--dev-php/PEAR-File_Find/Manifest3
-rw-r--r--dev-php/PEAR-File_Find/PEAR-File_Find-1.3.3.ebuild45
-rw-r--r--dev-php/PEAR-File_Find/metadata.xml12
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-php/PEAR-File_Find/Manifest b/dev-php/PEAR-File_Find/Manifest
new file mode 100644
index 000000000000..f27f3382e6e8
--- /dev/null
+++ b/dev-php/PEAR-File_Find/Manifest
@@ -0,0 +1,3 @@
+DIST File_Find-1.3.3.tgz 8212 BLAKE2B be45210efcf1aad52df123dd141f1a8ea62321a25cb460da4384456baeff13b51f8850f44e08cb75baa350e7b2a1419b27d89dd5a81f58a7302ab93c95c274a3 SHA512 f912e1f680c5869380791979bd33dabce0e95e40a84ee188052b2be8280de806fd117c11d66b98b7072724ecd9d57203ee5a32fe35705c337e73393fec075bb0
+EBUILD PEAR-File_Find-1.3.3.ebuild 1152 BLAKE2B dba22289766e087460684434bd73faf521c6d57fdbd6a52c9eeabdbfecf9614ddde4cbb6e5c64d168c3452c5e40d4f46d1391570c1c041d3e08d8dc8279bf509 SHA512 c1764666485e5064f9ce92c0b4667c5abc6d06b57b1a5e732a85172c3a67e33aa2f756ef6d7b86f7d43701eeab86dfe2caa90998051283d6c0cafb8c9bf5a4f3
+MISC metadata.xml 377 BLAKE2B d299154cdb99a5ff1562f245e5a24face117c08cb2bd9f457ee83d40bde667ed659c84e94465c1cbaeb6b2220c48738d261ed690aca9bc43fc83d127adcff872 SHA512 1d640be46e06957c8f3c127a9acac3f4f6b197efdcb96b13a5fff00aa638b3cb7febb5cba261ce45bb68c2356894006e3e57343fdf8bfbdb5d60e6a89f173a73
diff --git a/dev-php/PEAR-File_Find/PEAR-File_Find-1.3.3.ebuild b/dev-php/PEAR-File_Find/PEAR-File_Find-1.3.3.ebuild
new file mode 100644
index 000000000000..a4addfe6d4e7
--- /dev/null
+++ b/dev-php/PEAR-File_Find/PEAR-File_Find-1.3.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A class that facillitates the search of filesystems"
+HOMEPAGE="http://pear.php.net/package/${MY_PN}"
+SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
+IUSE="test"
+
+# Really only needs PEAR-Exception at runtime.
+RDEPEND="dev-lang/php:*
+ dev-php/PEAR-PEAR"
+DEPEND="test? ( dev-php/PEAR-PEAR )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ eapply_user
+
+ # Without this sed, the test suite will try (and fail) to mess
+ # around in /tmp.
+ sed -i "s~'/tmp'~'${T}'~" tests/setup.php \
+ || die 'failed to fix temporary directory in tests/setup.php'
+}
+
+src_install() {
+ insinto /usr/share/php
+ doins -r File
+}
+
+src_test() {
+ # Requires the "pear" executable from dev-php/PEAR-PEAR.
+ pear run-tests tests || die
+
+ # The command succeeds regardless of whether or not the test suite
+ # passed, but this file is only written when there was a failure.
+ [[ -f run-tests.log ]] && die "test suite failed"
+}
diff --git a/dev-php/PEAR-File_Find/metadata.xml b/dev-php/PEAR-File_Find/metadata.xml
new file mode 100644
index 000000000000..a200773ff92e
--- /dev/null
+++ b/dev-php/PEAR-File_Find/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pear/File_Find</remote-id>
+ <remote-id type="pear">File_Find</remote-id>
+ </upstream>
+</pkgmetadata>