summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-Exception
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/PEAR-Exception
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/PEAR-Exception')
-rw-r--r--dev-php/PEAR-Exception/Manifest3
-rw-r--r--dev-php/PEAR-Exception/PEAR-Exception-1.0.0.ebuild28
-rw-r--r--dev-php/PEAR-Exception/metadata.xml12
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-php/PEAR-Exception/Manifest b/dev-php/PEAR-Exception/Manifest
new file mode 100644
index 000000000000..3f3a33e01246
--- /dev/null
+++ b/dev-php/PEAR-Exception/Manifest
@@ -0,0 +1,3 @@
+DIST PEAR_Exception-1.0.0.tgz 5270 BLAKE2B f6f6874083fcef2453e1d07e1ee3e900e4f7d18eca8e9a9eda9891492dd3fc1e31eb13944031e82044f976f1070463a3b099a8223d2dabb2da109bb123997f5a SHA512 f2078186fdad6c6ca59ac462a24f7f9689bea08d30f786acb7779d52cd433e490c752ba0a263067d869151b0c051cded327cb3477a039c5de68c854bff002b58
+EBUILD PEAR-Exception-1.0.0.ebuild 654 BLAKE2B b037951a5d5fbfd25883481b9832b89b6502886287c5b014e95af1f73f5946f4d0a38168e2b9d5e45399a3f16eb975e65bf2574b9e03772ae24a9cb22fd85326 SHA512 4471169353b1dc3ac45b513a5e268c4525d9ec5ebecda2d21e1a9434faef9368f705edbe41c1ee73e74b22f375f09574995f4a390f8422fa2b50b71fd56ef514
+MISC metadata.xml 387 BLAKE2B 889a6e870f53bbaf7ea5d86dbddd30c85bbab181886d5eed8b8d05d4b744ed5b1152773a158f7ace3b3bf037d0dc6d5631d5e951a12f4c7a16d05a66156513ba SHA512 c3c5a2c8f8f1696240e9631e2e29d5f0780c856ad92067b24bafdf2325170b24177dd2b0ef6dba4582ec517e64f98019e9c4b823a045c9f65dd5606f0bc29e62
diff --git a/dev-php/PEAR-Exception/PEAR-Exception-1.0.0.ebuild b/dev-php/PEAR-Exception/PEAR-Exception-1.0.0.ebuild
new file mode 100644
index 000000000000..1a4d317b5dde
--- /dev/null
+++ b/dev-php/PEAR-Exception/PEAR-Exception-1.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/-/_}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="The PEAR Exception base class"
+HOMEPAGE="http://pear.php.net/package/${MY_PN}"
+SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
+IUSE="test"
+RDEPEND="dev-lang/php:*
+ !<=dev-php/PEAR-PEAR-1.10.3-r1"
+DEPEND="test? ( ${RDEPEND} dev-php/phpunit )"
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/share/php
+ doins -r PEAR
+}
+
+src_test() {
+ phpunit tests || die "test suite failed"
+}
diff --git a/dev-php/PEAR-Exception/metadata.xml b/dev-php/PEAR-Exception/metadata.xml
new file mode 100644
index 000000000000..37885d3bad10
--- /dev/null
+++ b/dev-php/PEAR-Exception/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pear/pear_exception</remote-id>
+ <remote-id type="pear">PEAR_Exception</remote-id>
+ </upstream>
+</pkgmetadata>