summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-Exception
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-php/PEAR-Exception
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-php/PEAR-Exception')
-rw-r--r--dev-php/PEAR-Exception/Manifest3
-rw-r--r--dev-php/PEAR-Exception/PEAR-Exception-1.0.0.ebuild28
-rw-r--r--dev-php/PEAR-Exception/metadata.xml12
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-php/PEAR-Exception/Manifest b/dev-php/PEAR-Exception/Manifest
new file mode 100644
index 000000000000..85976a31a197
--- /dev/null
+++ b/dev-php/PEAR-Exception/Manifest
@@ -0,0 +1,3 @@
+DIST PEAR_Exception-1.0.0.tgz 5270 SHA256 026b1f5981e7365237effda2a840f696f96a00c59e45ab7dfab79644f72dc2e3 SHA512 f2078186fdad6c6ca59ac462a24f7f9689bea08d30f786acb7779d52cd433e490c752ba0a263067d869151b0c051cded327cb3477a039c5de68c854bff002b58 WHIRLPOOL d11317410ed77c4bfa468c840b44f2b186c01c4b056d72a4f89951d3734d76a1d2888a0d64a9515541721650358c7461a5f1f6c1a032aab4e7937b163f86f10c
+EBUILD PEAR-Exception-1.0.0.ebuild 634 SHA256 7733bb98861fb45e9dd761975b31cf1933d35dea77b8aec4573c41458ae72ba1 SHA512 261e1fe76833c519530fc15cd7c80c99d0b8cbb26422d70e6ad3fb0d309d5eddd04d2a33c450eb369872ca81772e5fd852a25fc7d4a5973407666aafc0cc5fbf WHIRLPOOL 7747a792016199e426876d71aaab5d61f77bbda0f8e7408a54bd80b973848353f0e8a608af9c42a43e65a8649bd1aa0b266e792d8aa5d223fcef14d69a9294fc
+MISC metadata.xml 387 SHA256 bd3bcb2cb0d8274c95f1a70ae6c56cc1087f0f6b3dcb38aa4b66bbd075fca4e0 SHA512 c3c5a2c8f8f1696240e9631e2e29d5f0780c856ad92067b24bafdf2325170b24177dd2b0ef6dba4582ec517e64f98019e9c4b823a045c9f65dd5606f0bc29e62 WHIRLPOOL 0971352b3c6ea01f468a351d3698e32e0dfcf223850451c77d237dbcfe7bdd0327c70ac9a4a3774f5481931d040e099afd28138f1e4594e8604880468220171e
diff --git a/dev-php/PEAR-Exception/PEAR-Exception-1.0.0.ebuild b/dev-php/PEAR-Exception/PEAR-Exception-1.0.0.ebuild
new file mode 100644
index 000000000000..ed45b38d93f5
--- /dev/null
+++ b/dev-php/PEAR-Exception/PEAR-Exception-1.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/-/_}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="The PEAR Exception base class"
+HOMEPAGE="http://pear.php.net/package/${MY_PN}"
+SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64"
+IUSE="test"
+RDEPEND="dev-lang/php:*
+ !<=dev-php/PEAR-PEAR-1.10.3-r1"
+DEPEND="test? ( ${RDEPEND} dev-php/phpunit )"
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/share/php
+ doins -r PEAR
+}
+
+src_test() {
+ phpunit tests || die "test suite failed"
+}
diff --git a/dev-php/PEAR-Exception/metadata.xml b/dev-php/PEAR-Exception/metadata.xml
new file mode 100644
index 000000000000..37885d3bad10
--- /dev/null
+++ b/dev-php/PEAR-Exception/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pear/pear_exception</remote-id>
+ <remote-id type="pear">PEAR_Exception</remote-id>
+ </upstream>
+</pkgmetadata>