summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-Crypt_HMAC
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/PEAR-Crypt_HMAC
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/PEAR-Crypt_HMAC')
-rw-r--r--dev-php/PEAR-Crypt_HMAC/Manifest4
-rw-r--r--dev-php/PEAR-Crypt_HMAC/PEAR-Crypt_HMAC-1.0.1-r2.ebuild25
-rw-r--r--dev-php/PEAR-Crypt_HMAC/files/HMAC-1.0.1.patch57
-rw-r--r--dev-php/PEAR-Crypt_HMAC/metadata.xml8
4 files changed, 94 insertions, 0 deletions
diff --git a/dev-php/PEAR-Crypt_HMAC/Manifest b/dev-php/PEAR-Crypt_HMAC/Manifest
new file mode 100644
index 000000000000..71a0cedc7460
--- /dev/null
+++ b/dev-php/PEAR-Crypt_HMAC/Manifest
@@ -0,0 +1,4 @@
+AUX HMAC-1.0.1.patch 1501 BLAKE2B 2ee57e59c9d4ec6807c3daecc488a39102280c71da62baf9c3cf90a0af8e08c29e6d6be2593f148f4c4808b5d68fd0b681b511eeefd53bd91123959114651474 SHA512 19c968acbe449436f0bde2bbf9b379d9f04e76adf3283504b2fd396c94f19f5767a89a8fa23e23622b6fc3178be9c995b826d5540d994ca31e30f22a835f8c83
+DIST Crypt_HMAC-1.0.1.tgz 2149 BLAKE2B a95f145101cbd9f089948ac62d47b9a449a8cac328636987b49903c07c714c007309b294dd3a16fb5f5cf5bacf00c6e502fd8e29584803c99bff2bf61c5dec0a SHA512 5fb873d9d2e14f18f729e102b0295aaafef53bb150322f4a75d87f6d5ffd3e8829d424ee7285950d92c3408756b40b9ac7fe5123a73cefb341e4224f049bcb18
+EBUILD PEAR-Crypt_HMAC-1.0.1-r2.ebuild 531 BLAKE2B f17c22933aa6828a389d490839d7301749accaaf04731eed61839ad0528ef5495013ffa26a37f5507a6c0cc61974aecbd79970555c24bff4f46a5123ff2f5bf0 SHA512 363518b34f69265cc3a9723751d9204188b021a609cfc07fa36ed1fe6ad668049f0f36c96939eae2076778224a9c2d18193151480b9a7ce83b31391ea05f7d8e
+MISC metadata.xml 239 BLAKE2B 9b7c5dcb74289073481cf07031b7a92f32496cc1097becb074d74a8fbb8133de429ce1baf284e446e44132943c8b32e6b824570f15828588e42ea49ef5661f00 SHA512 2181b874bfe8cd31e7730d8207e26cfd2f272eaf2d1b57ae0faff126347a5298fa1c506d9107e1da9736c8a0ed9c8c339e4d9509a8726b79dbe86e073c12dee0
diff --git a/dev-php/PEAR-Crypt_HMAC/PEAR-Crypt_HMAC-1.0.1-r2.ebuild b/dev-php/PEAR-Crypt_HMAC/PEAR-Crypt_HMAC-1.0.1-r2.ebuild
new file mode 100644
index 000000000000..5fba6c704025
--- /dev/null
+++ b/dev-php/PEAR-Crypt_HMAC/PEAR-Crypt_HMAC-1.0.1-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2
+
+DESCRIPTION="Calculates RFC 2104 compliant hashes"
+LICENSE="PHP-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+DEPEND="test? ( dev-php/PEAR-PEAR )"
+PATCHES=( "${FILESDIR}/HMAC-1.0.1.patch" )
+
+src_test(){
+ ln -s . Crypt || die
+ peardev run-tests tests || die
+}
+
+src_install(){
+ insinto /usr/share/php/Crypt
+ doins HMAC.php
+ php-pear-r2_install_packagexml
+}
diff --git a/dev-php/PEAR-Crypt_HMAC/files/HMAC-1.0.1.patch b/dev-php/PEAR-Crypt_HMAC/files/HMAC-1.0.1.patch
new file mode 100644
index 000000000000..efa9d96bdedf
--- /dev/null
+++ b/dev-php/PEAR-Crypt_HMAC/files/HMAC-1.0.1.patch
@@ -0,0 +1,57 @@
+diff -aurN a/HMAC.php b/HMAC.php
+--- a/HMAC.php 2005-02-20 14:24:14.000000000 -0500
++++ b/HMAC.php 2018-02-13 14:03:59.421976960 -0500
+@@ -68,8 +68,21 @@
+ * @access private
+ */
+ var $_pack;
+-
+-
++
++ /**
++ * Constructor
++ * Pass method as first parameter
++ *
++ * @param string $key Key to use for hash
++ * @param string $func Hash function used for the calculation
++ * @return void
++ * @access public
++ */
++ function __construct($key, $func = 'md5')
++ {
++ $this->Crypt_HMAC($key, $func);
++ }
++
+ /**
+ * Constructor
+ * Pass method as first parameter
+diff -aurN a/tests/HMAC_001.phpt b/tests/HMAC_001.phpt
+--- a/tests/HMAC_001.phpt 1969-12-31 19:00:00.000000000 -0500
++++ b/tests/HMAC_001.phpt 2018-02-13 14:00:47.899812172 -0500
+@@ -0,0 +1,26 @@
++--TEST--
++RFC 2104 Test Vectors
++--DESCRIPTION--
++This test file implements the three test vectors as described in
++RFC 2104 (https://www.ietf.org/rfc/rfc2104.txt)
++--FILE--
++<?php
++ require_once 'Crypt/HMAC.php';
++
++ $key = str_repeat(chr(0x0b), 16);
++ $crypt = new Crypt_HMAC($key, 'md5');
++ echo $crypt->hash('Hi There')."\n";
++
++ $key = 'Jefe';
++ $crypt->setKey($key);
++ echo $crypt->hash('what do ya want for nothing?')."\n";
++
++ $key = str_repeat(chr(0xaa), 16);
++ $data = str_repeat(chr(0xdd), 50);
++ $crypt->setKey($key);
++ echo $crypt->hash($data)."\n";
++?>
++--EXPECT--
++9294727a3638bb1c13f48ef8158bfc9d
++750c783e6ab0b503eaa86e310a5db738
++56be34521d144c88dbb8c733f0e8b3f6
diff --git a/dev-php/PEAR-Crypt_HMAC/metadata.xml b/dev-php/PEAR-Crypt_HMAC/metadata.xml
new file mode 100644
index 000000000000..b86acf66c756
--- /dev/null
+++ b/dev-php/PEAR-Crypt_HMAC/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+</pkgmetadata>