summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-Console_Getopt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-php/PEAR-Console_Getopt
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-php/PEAR-Console_Getopt')
-rw-r--r--dev-php/PEAR-Console_Getopt/Manifest5
-rw-r--r--dev-php/PEAR-Console_Getopt/PEAR-Console_Getopt-1.4.1-r1.ebuild26
-rw-r--r--dev-php/PEAR-Console_Getopt/metadata.xml11
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-php/PEAR-Console_Getopt/Manifest b/dev-php/PEAR-Console_Getopt/Manifest
new file mode 100644
index 000000000000..41085160b1ac
--- /dev/null
+++ b/dev-php/PEAR-Console_Getopt/Manifest
@@ -0,0 +1,5 @@
+DIST Console_Getopt-1.4.1.tgz 5580 SHA256 2ac7b7ad616529b9bb891688459e866aacb3190cb81e208cddfe49e5d0fb5616 SHA512 cbf12a72b33424935f019b17ae8fa55289eae77d3845dcfcbbc1c47b71111992d2c0eb837b0f262ce644809c3cc06ad0c2bb04aa1b6ec89a1e3122f327114dbd WHIRLPOOL 5a5da6e0e977ffd15d69b83ebad079e7fd25d2d38f0cc691dbbe059b92a48fbfdc1169f499aaff045786fb099a993815e5e7c6bc1a41858a7bcf7855696e2fb9
+EBUILD PEAR-Console_Getopt-1.4.1-r1.ebuild 544 SHA256 70fd7a3b2e1fb07ea45a3faac87a0d5bf9b7015cb6782bf4ddbe6baac394f1a2 SHA512 7b7ed16bff52ff571a493a57cd520fe3376d5c34609d573e19bf9252759eeecb0e8ba3537dc180c779e6930afed92b9ee93c0a451ec035583068ec3354056187 WHIRLPOOL 2f927c9949e71f9e0ebdd4f3ed28a3ef73ef87dae3d6bed3788e3eb85fd210ee4efe2c2702c04ceaf27f7dff99a0dde0810e1c1bd916679fcd79a4e33290ff36
+MISC ChangeLog 3858 SHA256 34e375038ad6ff4e59b096fc6d9457f7c02b0a251b31409bbd0efaa6fbb69e65 SHA512 3709c349a8dfa71f83f919016a35e488376967b2eecf7659c92cf58ca542f285062ed65592b529848d2273be282f99180a67021b770c255c4862e7ea6a0b616d WHIRLPOOL 489c9c326badfa5fedc3a446d2f279b9e3f88b503e651853be91b72b9a1fe1e7b6d97d9dca324f4cf93aa8b8b943a66b2f8e952ab6880277ca40f9a957028669
+MISC ChangeLog-2015 3019 SHA256 a114ecaaa9366814a5f35003d88c224499f29b9147115683168d3aba94bf1178 SHA512 d6c0c2521bd060e2b7a1c8d932d2f92ced0eca37f198a9a8b86dad1ab7f281377b177af38163de9e8efb9a62d10433a02b1eabe4a5828ecd2ec9b04d38cfd989 WHIRLPOOL 821bb913a9d0eedac239e08b1048593de7581ebe388d7d4659e0704d26b1e476beb115357b73964fa0fb64a1df52b2f2246704f8e87f31baa98d579e42095a10
+MISC metadata.xml 316 SHA256 0fa7e49fa7974e0a1967fdcf2e1d65ed91e47b2f4b88ddd1f3ff74cb32af99f3 SHA512 8103a2aac5f04ccca0accc1b5dcfc11ee2c59992ea7364e87cf1208fda18f58ac48c833413db682993464912087df6bae19419b153fdf335ea56a1ae406c5994 WHIRLPOOL 5e6b926049242ab9c832fa9257dacd88bb85fdf577640273c97be21fcaf1aa8a89e6a3588ee160e1d7658fcee8de4f2d2617da3d01395ffe04a1de5eb4846e67
diff --git a/dev-php/PEAR-Console_Getopt/PEAR-Console_Getopt-1.4.1-r1.ebuild b/dev-php/PEAR-Console_Getopt/PEAR-Console_Getopt-1.4.1-r1.ebuild
new file mode 100644
index 000000000000..1d230653c536
--- /dev/null
+++ b/dev-php/PEAR-Console_Getopt/PEAR-Console_Getopt-1.4.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Command-line option parser"
+HOMEPAGE="http://pear.php.net/package/${MY_PN}"
+SRC_URI="http://pear.php.net/get/${MY_P}.tgz"
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-lang/php:*"
+PDEPEND="dev-php/PEAR-PEAR"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/share/php
+ doins -r Console
+}
diff --git a/dev-php/PEAR-Console_Getopt/metadata.xml b/dev-php/PEAR-Console_Getopt/metadata.xml
new file mode 100644
index 000000000000..c8c9c843b99e
--- /dev/null
+++ b/dev-php/PEAR-Console_Getopt/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pear">Console_Getopt</remote-id>
+ </upstream>
+</pkgmetadata>