summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-Console_CommandLine
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/PEAR-Console_CommandLine
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/PEAR-Console_CommandLine')
-rw-r--r--dev-php/PEAR-Console_CommandLine/Manifest3
-rw-r--r--dev-php/PEAR-Console_CommandLine/PEAR-Console_CommandLine-1.2.2.ebuild52
-rw-r--r--dev-php/PEAR-Console_CommandLine/metadata.xml12
3 files changed, 67 insertions, 0 deletions
diff --git a/dev-php/PEAR-Console_CommandLine/Manifest b/dev-php/PEAR-Console_CommandLine/Manifest
new file mode 100644
index 000000000000..ad8dcde4ae73
--- /dev/null
+++ b/dev-php/PEAR-Console_CommandLine/Manifest
@@ -0,0 +1,3 @@
+DIST Console_CommandLine-1.2.2.tgz 40705 BLAKE2B 1cf2fd7ffdafe1b6e683d40e24c07bc12c9e41469e42595f40778f0bfef30457b32f80b966835a690724e29216348be0fb3f98a83947459d48f728896a5a056a SHA512 05dbde123d0d4fdbba2a959f4bea3b115e3629060a268d25a3007c2ee5a3530b8ebbd8c7d124a6c9d012cafa19f41690a888943a6c1e2e5ec1b9d83fa821d603
+EBUILD PEAR-Console_CommandLine-1.2.2.ebuild 1377 BLAKE2B 3b37595e9f4b156f847ab9a77dda8dba2bdc6eebe3fc32053ebbf326f1541d73493924d68a3e0cd82c340ff1cd389a8e4742c6ba232322cd10fd317cb1616745 SHA512 08f78d69220c6b0d5d930e4fea81f0196b8d675034c550de59333440282a66be5171637d6bc744872933bcd2c6361a95e8782e43114fba302510d4a7e0948986
+MISC metadata.xml 397 BLAKE2B ed50944409b7944c1da567241dab1e2e287b15e7a03c662c0642540b4fa1c50b6d048f6c7033b7fd1c598e5e2edc07bed8a758ec8f71e56e0c4a459f7efd9175 SHA512 ffb1a260b10acfd50fd5b3ee01d80b082f56e31c18c99232a28947a7b29d1ef1e529052b109573aebac05138982322f3a46cf6652f0e519222fb87ef730f5e84
diff --git a/dev-php/PEAR-Console_CommandLine/PEAR-Console_CommandLine-1.2.2.ebuild b/dev-php/PEAR-Console_CommandLine/PEAR-Console_CommandLine-1.2.2.ebuild
new file mode 100644
index 000000000000..aec17d081cd2
--- /dev/null
+++ b/dev-php/PEAR-Console_CommandLine/PEAR-Console_CommandLine-1.2.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A full-featured command-line options and arguments parser"
+HOMEPAGE="http://pear.php.net/package/${MY_PN}"
+SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm hppa ia64 ppc ppc64 sparc x86"
+IUSE="examples test"
+
+# Only needs PEAR_Exception (not yet packaged) -- not all of PEAR-PEAR.
+RDEPEND="dev-lang/php:*
+ dev-php/PEAR-PEAR"
+
+# Beware, the test suite really needs PEAR-PEAR.
+DEPEND="test? ( ${RDEPEND} )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # There's one occurrence of @data_dir@ that needs to be replaced
+ # This location just has to agree with where we put the "data"
+ # directory during src_install().
+ default
+ sed -i "s|@data_dir@|${EPREFIX}/usr/share|" \
+ Console/CommandLine/XmlParser.php || die
+}
+
+src_install() {
+ use examples && dodoc -r docs/examples
+
+ insinto "/usr/share/${MY_PN}"
+ doins -r data
+
+ insinto /usr/share/php
+ doins -r Console
+}
+
+src_test() {
+ # Requires the "pear" executable from dev-php/PEAR-PEAR.
+ pear run-tests tests || die
+
+ # The command succeeds regardless of whether or not the test suite
+ # passed, but this file is only written when there was a failure.
+ [[ -f run-tests.log ]] && die "test suite failed"
+}
diff --git a/dev-php/PEAR-Console_CommandLine/metadata.xml b/dev-php/PEAR-Console_CommandLine/metadata.xml
new file mode 100644
index 000000000000..9362a60ada6c
--- /dev/null
+++ b/dev-php/PEAR-Console_CommandLine/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pear/Console_CommandLine</remote-id>
+ <remote-id type="pear">Console_CommandLine</remote-id>
+ </upstream>
+</pkgmetadata>