summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-Console_CommandLine/PEAR-Console_CommandLine-1.2.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-php/PEAR-Console_CommandLine/PEAR-Console_CommandLine-1.2.2.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/PEAR-Console_CommandLine/PEAR-Console_CommandLine-1.2.2.ebuild')
-rw-r--r--dev-php/PEAR-Console_CommandLine/PEAR-Console_CommandLine-1.2.2.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-php/PEAR-Console_CommandLine/PEAR-Console_CommandLine-1.2.2.ebuild b/dev-php/PEAR-Console_CommandLine/PEAR-Console_CommandLine-1.2.2.ebuild
deleted file mode 100644
index aec17d081cd2..000000000000
--- a/dev-php/PEAR-Console_CommandLine/PEAR-Console_CommandLine-1.2.2.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MY_PN="${PN/PEAR-/}"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A full-featured command-line options and arguments parser"
-HOMEPAGE="http://pear.php.net/package/${MY_PN}"
-SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm hppa ia64 ppc ppc64 sparc x86"
-IUSE="examples test"
-
-# Only needs PEAR_Exception (not yet packaged) -- not all of PEAR-PEAR.
-RDEPEND="dev-lang/php:*
- dev-php/PEAR-PEAR"
-
-# Beware, the test suite really needs PEAR-PEAR.
-DEPEND="test? ( ${RDEPEND} )"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- # There's one occurrence of @data_dir@ that needs to be replaced
- # This location just has to agree with where we put the "data"
- # directory during src_install().
- default
- sed -i "s|@data_dir@|${EPREFIX}/usr/share|" \
- Console/CommandLine/XmlParser.php || die
-}
-
-src_install() {
- use examples && dodoc -r docs/examples
-
- insinto "/usr/share/${MY_PN}"
- doins -r data
-
- insinto /usr/share/php
- doins -r Console
-}
-
-src_test() {
- # Requires the "pear" executable from dev-php/PEAR-PEAR.
- pear run-tests tests || die
-
- # The command succeeds regardless of whether or not the test suite
- # passed, but this file is only written when there was a failure.
- [[ -f run-tests.log ]] && die "test suite failed"
-}