summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-Archive_Tar/PEAR-Archive_Tar-1.4.14.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
commitb49088575eb777ced2551f484da86317332d6087 (patch)
treebf9a151cf2d61956340d555659ffc098ee1da466 /dev-php/PEAR-Archive_Tar/PEAR-Archive_Tar-1.4.14.ebuild
parent514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (diff)
gentoo resync : 24.07.2021
Diffstat (limited to 'dev-php/PEAR-Archive_Tar/PEAR-Archive_Tar-1.4.14.ebuild')
-rw-r--r--dev-php/PEAR-Archive_Tar/PEAR-Archive_Tar-1.4.14.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-php/PEAR-Archive_Tar/PEAR-Archive_Tar-1.4.14.ebuild b/dev-php/PEAR-Archive_Tar/PEAR-Archive_Tar-1.4.14.ebuild
new file mode 100644
index 000000000000..02c0db09b3a8
--- /dev/null
+++ b/dev-php/PEAR-Archive_Tar/PEAR-Archive_Tar-1.4.14.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Tar file management class"
+HOMEPAGE="https://pear.php.net/package/Archive_Tar"
+SRC_URI="https://pear.php.net/get/${MY_P}.tgz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+# bzip2 and zlib are needed for compressed tarballs, and there's one
+# call to preg_match to test paths against a pattern of files and
+# directories that will be ignored.
+RDEPEND="dev-lang/php:*[bzip2,pcre(+),zlib]"
+PDEPEND="dev-php/PEAR-PEAR"
+DEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/share/php
+ doins -r Archive
+
+ dodoc docs/*
+
+ insinto /usr/share/php/.packagexml
+ newins "${WORKDIR}/package.xml" "${MY_P}.xml"
+}
+
+pkg_postinst() {
+ # It is not critical to complete so only warn on failure
+ if [[ -f "${EROOT}/usr/share/php/.packagexml/${MY_P}.xml" && \
+ -x "${EROOT}/usr/bin/peardev" ]] ; then
+ "${EROOT}/usr/bin/peardev" install -nrO --force \
+ "${EROOT}/usr/share/php/.packagexml/${MY_P}.xml" 2> /dev/null \
+ || ewarn "Failed to insert package into local PEAR database"
+ fi
+}
+
+pkg_postrm() {
+ if [[ -x "${EROOT}/usr/bin/peardev" ]]; then
+ "${EROOT}/usr/bin/peardev" uninstall -nrO "pear.php.net/${MY_PN}"
+ fi
+}