summaryrefslogtreecommitdiff
path: root/dev-php/File_Iterator/File_Iterator-2.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /dev-php/File_Iterator/File_Iterator-2.0.2.ebuild
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'dev-php/File_Iterator/File_Iterator-2.0.2.ebuild')
-rw-r--r--dev-php/File_Iterator/File_Iterator-2.0.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-php/File_Iterator/File_Iterator-2.0.2.ebuild b/dev-php/File_Iterator/File_Iterator-2.0.2.ebuild
new file mode 100644
index 000000000000..7763457d86b5
--- /dev/null
+++ b/dev-php/File_Iterator/File_Iterator-2.0.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="php-file-iterator"
+
+DESCRIPTION="FilterIterator implementation that filters files based on criteria"
+HOMEPAGE="https://github.com/sebastianbergmann/php-file-iterator
+ https://phpunit.de"
+SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-lang/php-7.1:*"
+
+src_install() {
+ insinto /usr/share/php/File/Iterator
+ doins -r src/*
+ doins "${FILESDIR}/autoload.php"
+}
+
+pkg_postinst() {
+ ewarn "This library now loads via /usr/share/php/File/Iterator/autoload.php"
+ ewarn "Please update any scripts to require the autoloader"
+}