summaryrefslogtreecommitdiff
path: root/dev-perl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-19 13:53:29 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-19 13:53:29 +0000
commit00ac4b34406552b4fbca786be59b2983b7f58669 (patch)
treeff2e5facaa5f92566a0362c881beaa9bacb567a0 /dev-perl
parent32b8124b0a5827960601f2183a970103b3d231b7 (diff)
gentoo auto-resync : 19:12:2023 - 13:53:29
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/File-RsyncP/File-RsyncP-0.760.0-r2.ebuild38
-rw-r--r--dev-perl/File-RsyncP/Manifest2
-rw-r--r--dev-perl/File-RsyncP/files/File-RsyncP-0.760.0-c99.patch199
-rw-r--r--dev-perl/Manifest.gzbin285840 -> 285846 bytes
4 files changed, 239 insertions, 0 deletions
diff --git a/dev-perl/File-RsyncP/File-RsyncP-0.760.0-r2.ebuild b/dev-perl/File-RsyncP/File-RsyncP-0.760.0-r2.ebuild
new file mode 100644
index 000000000000..17a8c7600670
--- /dev/null
+++ b/dev-perl/File-RsyncP/File-RsyncP-0.760.0-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=CBARRATT
+DIST_VERSION=0.76
+inherit perl-module toolchain-funcs
+
+DESCRIPTION="An rsync perl module"
+HOMEPAGE="https://perlrsync.sourceforge.net/ https://metacpan.org/release/File-RsyncP"
+# Bundled files make for some weirdness
+LICENSE="GPL-3+ GPL-2+ RSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=virtual/perl-Getopt-Long-2.240.0
+ net-misc/rsync
+"
+BDEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.700.0-make.patch"
+ "${FILESDIR}/${PN}-0.760.0-lto.patch"
+ "${FILESDIR}/${PN}-0.760.0-c99.patch"
+)
+
+src_prepare() {
+ perl-module_src_prepare
+ tc-export CC
+}
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}
diff --git a/dev-perl/File-RsyncP/Manifest b/dev-perl/File-RsyncP/Manifest
index ede76bfcb096..c84c5595c45b 100644
--- a/dev-perl/File-RsyncP/Manifest
+++ b/dev-perl/File-RsyncP/Manifest
@@ -1,7 +1,9 @@
AUX File-RsyncP-0.700.0-make.patch 980 BLAKE2B 997e84bdd3183c324e76df69279fa00ec09663d73906607b3a0d2518d73f8391aab2214221bb797dadd4031b6f1e195f465cc5153e004c1e415a5ce4da9c8eaa SHA512 dccabb516cb4036efd8372c36343b02916ec1576c64f5c449eff1e7f0aac450f732ac4b190578426c52cbfedd3e5df28b4851cf350621a381b605065f473df14
+AUX File-RsyncP-0.760.0-c99.patch 6621 BLAKE2B 3131fee322be9f1c2019047b144f8367beb017c908e74bc276f5fa38a6f2c9ce6fce571c1a9dc81a5e4dd08f3fbcc8928b5d40ef52f528f962443a620b81111b SHA512 4cd5723f51e4568de2f171ca73aeae396aee7c90644f1ea102eb7084ff1b0c9c017c1b8d46cf636f75273b9ff7b5c1c4117e148e4aebb975aae4874525c7a772
AUX File-RsyncP-0.760.0-clang16.patch 6046 BLAKE2B 5d388247096dc604cdf0dac5f070b69826fa4bd106b791d5ea29cdc0d2cf66545926414c5cda37ce9afac64dda862aefe87edeadb39fc0d63c084b6d95890e9e SHA512 a64a38ef191361cb2429a9a7101333e4631f264452825359b0006baeb89517960c86a4bd01b3647c8c4b3f7962782961ff968341c1d1362a21fa6edf492c3e7b
AUX File-RsyncP-0.760.0-lto.patch 1788 BLAKE2B e297938568837ee271e63aed2c520334317e11c08a3481ceae27e657586221f5a813b55e3f2e6a2a1e09cb9a364d80a0236117aeff88fb6a0caf02492d4640e0 SHA512 ab70725cd8503fb59b5df57e66a056f78ef9b6a699e92c76f121decfaf959b51b8804a122af8be66d11ec141f03b0c2eeb1e77eae10ed745d6c2b47622bda065
DIST File-RsyncP-0.76.tar.gz 167744 BLAKE2B e718a8cd18f3bf7c3d8b9ceb440c19b9544c232f2889532a15023ec1da6947085d4d07efb7edf7b1366830005f784e03b76bb9526d5ecb0072b3c0ab5fb88494 SHA512 b81d9ce63181605939e8aff87c9e56ab276899f019f44eb3f149e7ee0d44a94fcbee771381ebe6ca8281c2de0d57d9cbdbcb972ccb7406a0aefd920040603bb3
EBUILD File-RsyncP-0.760.0-r1.ebuild 796 BLAKE2B 49107468e7983fe3324dd14f634e9c0828533f62b17bd2d257bb84b5c5269fbdb6fdb06e810e25bbf0278d7e292f537b18e98006487566b4f4419cec6333f300 SHA512 c47ac20831861d07282ebe3b91a7431c16eed0997c596f36895bfb35589a73614574dcd9404b2555b159c89c047ec042e9cebd1cf88877b6163eae8b2202b072
+EBUILD File-RsyncP-0.760.0-r2.ebuild 795 BLAKE2B cf3ffab25ac115ba408589715ed70849051e6adc106e2d67d183353c323db9f00b7a01a65b5680104621cbd2d51b5b024ac9a4d7b8bf11d4139ee535fbfaf218 SHA512 d39742e1bac62c1bbe9654fa10e620ae999af3fda3b4f9f0443994a968f544bb30a5e9136bc2571ac6828e1bc18ae8ec8d44523b30e13e8bf053a641f8369554
EBUILD File-RsyncP-0.760.0.ebuild 713 BLAKE2B cc34b0170b246eabcfd8d56b402c8653cadadd07b2b3135caad5a236e0643ea774e915e5afd684bad6264d0ba232761e2c7a4c21fdd9d10d89aa5f4e928ddd16 SHA512 8120e6c4881b323ea9830f9b312ced8ed51bc607b36d33d273a0313e0138a3b80186948e44d8c69c7ea964f28e8eb8982dda24c2969835fe18744955894ce8ab
MISC metadata.xml 654 BLAKE2B de95af5a50340b4b1235613c8874a6ab53824c8d4c2ef7253fc58a349d72a63afeef797944da7ce8195e0314247f3904aaf61a42bfd02940101fadd7edad7c92 SHA512 9e8b272c3d070616e3434e597e014a3ccfa77a1749790708453e03ed29dedb993ebab52e178fca3dfc064db335e28524ebd22adc879ead7b6e3a3473e8ed72aa
diff --git a/dev-perl/File-RsyncP/files/File-RsyncP-0.760.0-c99.patch b/dev-perl/File-RsyncP/files/File-RsyncP-0.760.0-c99.patch
new file mode 100644
index 000000000000..f57348df3bfe
--- /dev/null
+++ b/dev-perl/File-RsyncP/files/File-RsyncP-0.760.0-c99.patch
@@ -0,0 +1,199 @@
+https://src.fedoraproject.org/rpms/perl-File-RsyncP/blob/0faafaa6c4c1ebf930c1c119c57bea85cbd6118b/f/perl-File-RsyncP-configure-c99.patch
+https://rt.cpan.org/Public/Bug/Display.html?id=145943
+
+Various fixes for the configure script. Most of them are specific to
+this package, and not related to autoconf limitations. The
+configure.in/configure.ac autoconf input is not included among
+upstream sources, so they are not patched here.
+
+Submitted upstream: <https://rt.cpan.org/Public/Bug/Display.html?id=145943>
+
+diff --git a/FileList/configure b/FileList/configure
+index 023b6066e0f9d362..cdf2a72b57d73abf 100755
+--- a/FileList/configure
++++ b/FileList/configure
+@@ -2246,7 +2246,7 @@ if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; }; then
+ for ac_declaration in \
+- '' \
++ '#include <stdlib.h>' \
+ 'extern "C" void std::exit (int) throw (); using std::exit;' \
+ 'extern "C" void std::exit (int); using std::exit;' \
+ 'extern "C" void exit (int) throw ();' \
+@@ -2905,6 +2905,8 @@ cat >>conftest.$ac_ext <<_ACEOF
+ #include <fcntl.h>
+ #include <sys/types.h>
+ #include <sys/wait.h>
++#include <stdlib.h>
++#include <string.h>
+
+ int main(void)
+ {
+@@ -4492,8 +4494,8 @@ main ()
+ for (i = 0; i < 256; i++)
+ if (XOR (islower (i), ISLOWER (i))
+ || toupper (i) != TOUPPER (i))
+- exit(2);
+- exit (0);
++ return 2;
++ return 0;
+ }
+ _ACEOF
+ rm -f conftest$ac_exeext
+@@ -6841,6 +6843,8 @@ cat >>conftest.$ac_ext <<_ACEOF
+ #define NGID 256
+ #undef MAX
+ #define MAX(x, y) ((x) > (y) ? (x) : (y))
++#include <unistd.h>
++#include <stdlib.h>
+
+ int
+ main ()
+@@ -8828,12 +8832,13 @@ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+ $ac_includes_default
++#include <utime.h>
+ int
+ main ()
+ {
+ struct stat s, t;
+ exit (!(stat ("conftest.data", &s) == 0
+- && utime ("conftest.data", (long *)0) == 0
++ && utime ("conftest.data", 0) == 0
+ && stat ("conftest.data", &t) == 0
+ && t.st_mtime >= s.st_mtime
+ && t.st_mtime - s.st_mtime < 120));
+@@ -9397,9 +9402,9 @@ cat >>conftest.$ac_ext <<_ACEOF
+ #include <sys/types.h>
+ #include <sys/socket.h>
+
+-main() {
++int main(void) {
+ int fd[2];
+- exit((socketpair(AF_UNIX, SOCK_STREAM, 0, fd) != -1) ? 0 : 1);
++ return (socketpair(AF_UNIX, SOCK_STREAM, 0, fd) != -1) ? 0 : 1;
+ }
+ _ACEOF
+ rm -f conftest$ac_exeext
+@@ -9451,7 +9456,7 @@ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+ #include <stdio.h>
+-main() { long long x = 1000000; x *= x; exit(((x/1000000) == 1000000)? 0: 1); }
++int main(void) { long long x = 1000000; x *= x; return ((x/1000000) == 1000000)? 0: 1; }
+ _ACEOF
+ rm -f conftest$ac_exeext
+ if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
+@@ -9503,7 +9508,7 @@ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+ #include <stdio.h>
+ #include <sys/stat.h>
+-main() { struct stat64 st; off64_t s; if (sizeof(off_t) == sizeof(off64_t)) exit(1); exit((lstat64("/dev/null", &st)==0)?0:1); }
++int main(void) { struct stat64 st; off64_t s; if (sizeof(off_t) == sizeof(off64_t)) return 1; return (lstat64("/dev/null", &st)==0)?0:1; }
+ _ACEOF
+ rm -f conftest$ac_exeext
+ if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
+@@ -9556,7 +9561,7 @@ cat >>conftest.$ac_ext <<_ACEOF
+ #include <stdio.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+-main() { if (sizeof(ino_t) < sizeof(unsigned int)) return 0; return 1; }
++int main(void) { if (sizeof(ino_t) < sizeof(unsigned int)) return 0; return 1; }
+ _ACEOF
+ rm -f conftest$ac_exeext
+ if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
+@@ -9607,7 +9612,7 @@ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+ #include <stdio.h>
+-main() { char c; c=250; exit((c > 0)?0:1); }
++int main(void) { char c; c=250; return (c > 0)?0:1; }
+ _ACEOF
+ rm -f conftest$ac_exeext
+ if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
+@@ -9659,9 +9664,9 @@ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+ #include <sys/types.h>
+ #include <dirent.h>
+-main() { struct dirent *di; DIR *d = opendir("."); di = readdir(d);
++int main(void) { struct dirent *di; DIR *d = opendir("."); di = readdir(d);
+ if (di && di->d_name[-2] == '.' && di->d_name[-1] == 0 &&
+-di->d_name[0] == 0) exit(0); exit(1);}
++di->d_name[0] == 0) return 0; return 1;}
+ _ACEOF
+ rm -f conftest$ac_exeext
+ if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
+@@ -9713,7 +9718,7 @@ cat >>conftest.$ac_ext <<_ACEOF
+ int
+ main ()
+ {
+-struct utimbuf tbuf; tbuf.actime = 0; tbuf.modtime = 1; exit(utime("foo.c",&tbuf));
++struct utimbuf tbuf; tbuf.actime = 0; tbuf.modtime = 1; return utime("foo.c",&tbuf);
+ ;
+ return 0;
+ }
+@@ -9777,7 +9782,7 @@ cat >>conftest.$ac_ext <<_ACEOF
+
+ #include <sys/time.h>
+ #include <unistd.h>
+-main() { struct timeval tv; exit(gettimeofday(&tv, NULL));}
++int main(void) { struct timeval tv; return gettimeofday(&tv, NULL);}
+ _ACEOF
+ rm -f conftest$ac_exeext
+ if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
+@@ -9830,6 +9835,9 @@ cat >>conftest.$ac_ext <<_ACEOF
+
+ #include <sys/types.h>
+ #include <stdarg.h>
++#include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
+ void foo(const char *format, ...) {
+ va_list ap;
+ int len;
+@@ -9844,7 +9852,7 @@ void foo(const char *format, ...) {
+
+ exit(0);
+ }
+-main() { foo("hello"); }
++int main(void) { foo("hello"); }
+
+ _ACEOF
+ rm -f conftest$ac_exeext
+@@ -9900,7 +9908,7 @@ cat >>conftest.$ac_ext <<_ACEOF
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <unistd.h>
+-main() {
++int main(void) {
+ struct stat st;
+ char tpl[20]="/tmp/test.XXXXXX";
+ int fd = mkstemp(tpl);
+@@ -9965,10 +9973,11 @@ cat >>conftest.$ac_ext <<_ACEOF
+ #include <sys/types.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+-main() { struct in_addr ip; ip.s_addr = 0x12345678;
++#include <string.h>
++int main(void) { struct in_addr ip; ip.s_addr = 0x12345678;
+ if (strcmp(inet_ntoa(ip),"18.52.86.120") &&
+- strcmp(inet_ntoa(ip),"120.86.52.18")) { exit(1); }
+-exit(0);}
++ strcmp(inet_ntoa(ip),"120.86.52.18")) { return 1; }
++return 0;}
+ _ACEOF
+ rm -f conftest$ac_exeext
+ if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
+@@ -10024,8 +10033,8 @@ cat >>conftest.$ac_ext <<_ACEOF
+ #include <sys/types.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+-main() { struct in_addr ip;
+-if (inet_aton("example", &ip) == 0) exit(0); exit(1);}
++int main(void) { struct in_addr ip;
++if (inet_aton("example", &ip) == 0) return 0; return 1;}
+ _ACEOF
+ rm -f conftest$ac_exeext
+ if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
diff --git a/dev-perl/Manifest.gz b/dev-perl/Manifest.gz
index d96c59d6db40..770cf9685b45 100644
--- a/dev-perl/Manifest.gz
+++ b/dev-perl/Manifest.gz
Binary files differ