summaryrefslogtreecommitdiff
path: root/dev-perl/libwww-perl/libwww-perl-6.550.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-15 18:47:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-15 18:47:53 +0000
commita4eda25bf0f72d757244b128657832bc4da28375 (patch)
tree5a4bda4947a8d19e1f07c2385db1aff2c18ba0d2 /dev-perl/libwww-perl/libwww-perl-6.550.0.ebuild
parent6e8d3793323b8f24be801a4aaf31cdd31a8483e9 (diff)
gentoo auto-resync : 15:03:2024 - 18:47:52
Diffstat (limited to 'dev-perl/libwww-perl/libwww-perl-6.550.0.ebuild')
-rw-r--r--dev-perl/libwww-perl/libwww-perl-6.550.0.ebuild73
1 files changed, 0 insertions, 73 deletions
diff --git a/dev-perl/libwww-perl/libwww-perl-6.550.0.ebuild b/dev-perl/libwww-perl/libwww-perl-6.550.0.ebuild
deleted file mode 100644
index a2c8669ecbb3..000000000000
--- a/dev-perl/libwww-perl/libwww-perl-6.550.0.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DIST_AUTHOR=OALDERS
-DIST_VERSION=6.55
-inherit perl-module
-
-DESCRIPTION="A collection of Perl Modules for the WWW"
-
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-solaris"
-IUSE="ssl"
-
-RDEPEND="
- virtual/perl-Digest-MD5
- >=virtual/perl-Encode-2.120.0
- dev-perl/Encode-Locale
- >=dev-perl/File-Listing-6.0.0
- >=dev-perl/HTML-Parser-3.340.0
- >=dev-perl/HTTP-Cookies-6.0.0
- >=dev-perl/HTTP-Date-6.0.0
- >=dev-perl/HTTP-Negotiate-6.0.0
- >=dev-perl/HTTP-Message-6.70.0
- virtual/perl-IO
- >=dev-perl/LWP-MediaTypes-6.0.0
- >=virtual/perl-MIME-Base64-2.100.0
- >=virtual/perl-libnet-2.580.0
- >=dev-perl/Net-HTTP-6.180.0
- virtual/perl-Scalar-List-Utils
- dev-perl/Try-Tiny
- >=dev-perl/URI-1.100.0
- >=dev-perl/WWW-RobotRules-6.0.0
-"
-BDEPEND="${RDEPEND}
- >=virtual/perl-CPAN-Meta-Requirements-2.120.620
- virtual/perl-ExtUtils-MakeMaker
- virtual/perl-Getopt-Long
- virtual/perl-Module-Metadata
- test? (
- virtual/perl-File-Spec
- >=dev-perl/HTTP-Daemon-6.120.0
- dev-perl/Test-Fatal
- >=virtual/perl-Test-Simple-0.960.0
- dev-perl/Test-Needs
- dev-perl/Test-RequiresInternet
- )
-"
-PDEPEND="
- ssl? (
- >=dev-perl/LWP-Protocol-https-6.20.0
- )
-"
-
-src_install() {
- perl-module_src_install
-
- # Perform a check to see if the live filesystem is case-INsensitive
- # or not. If it is, the symlinks GET, POST and in particular HEAD
- # will collide with e.g. head from coreutils. While under Linux
- # having a case-INsensitive filesystem is really unusual, most Mac
- # OS X users are on it, and also Interix users deal with
- # case-INsensitivity since Windows is underneath.
-
- # bash should always be there, if we can find it in capitals, we're
- # on a case-INsensitive filesystem.
- if [[ ! -f ${EROOT}/BIN/BASH ]] ; then
- dosym lwp-request /usr/bin/GET
- dosym lwp-request /usr/bin/POST
- dosym lwp-request /usr/bin/HEAD
- fi
-}