summaryrefslogtreecommitdiff
path: root/dev-perl/librg-utils-perl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /dev-perl/librg-utils-perl
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'dev-perl/librg-utils-perl')
-rw-r--r--dev-perl/librg-utils-perl/Manifest2
-rw-r--r--dev-perl/librg-utils-perl/librg-utils-perl-1.0.43-r2.ebuild (renamed from dev-perl/librg-utils-perl/librg-utils-perl-1.0.43-r1.ebuild)54
2 files changed, 32 insertions, 24 deletions
diff --git a/dev-perl/librg-utils-perl/Manifest b/dev-perl/librg-utils-perl/Manifest
index 33773db4d712..c78bcfe02682 100644
--- a/dev-perl/librg-utils-perl/Manifest
+++ b/dev-perl/librg-utils-perl/Manifest
@@ -1,4 +1,4 @@
AUX librg-utils-perl-1.0.43-defined-array.patch 6546 BLAKE2B eea57e7a175b0f1ef2963232e1db469ce6674dfe7d569bbedc362e4e4f05eba3ce5722ee418cc099c52433dd5b5426b2ef2287fbc88fac0e979b3c7a059a6353 SHA512 232c9f2a45c3c98a0d1019afe5380a33b079a615d1e3f0c7f563575fe3d5b0efc7ce6b30473dfd6a49ab9c4695797bf71ea4507ba20beb4bafe9e0d320ca09c1
DIST librg-utils-perl-1.0.43.tar.gz 222433 BLAKE2B 8dad61ead9f33dc0ac3f3767a1f5e277ee65ebe8c3f97c4e318588303ea16c227cc22c22a7f085ca4fd0ae6ff60d0ce06e84682523f074c2717d0c4814b12143 SHA512 90480f8292e09277263808036e729b2e7e692a186b682466f491d5be90e5fa2accc11b1a1b694b32113b91af4ad56e9ccdf25e6c596759b9c4d45322687c1fa1
-EBUILD librg-utils-perl-1.0.43-r1.ebuild 1259 BLAKE2B b5b23ac8e6e09c0c283dba94b451badab82427559c72b9cc5fb342a886a3306e6fe1547fc717cd5edfd2c06518b9dbd4277f5694d50c723b4fd896ee70f27f5c SHA512 e7744e45c1b11cd066ef66f7a3ecc6f4c7826b89a459cfb3ac19bbb4fa3295ce896739752d63de820b090806224cea87544471b852a5b445812e5bc0da688526
+EBUILD librg-utils-perl-1.0.43-r2.ebuild 1257 BLAKE2B db771423d05b39fe2b84cbde3b8c47e213e878785bb96180c1affd33de33db23100f733bd2bbf42545a8c47f1c7581f00d1b98bb828aaf92380736d4e4436c7b SHA512 33ad090405cf3c3816d16e77cf05748196fcedc4ae08282431c1af701b6462a0244563c16ca8de69eb2d484429c0096d833222773ddb778914f59663cc554b3b
MISC metadata.xml 268 BLAKE2B a4d67334cdad8626d60e46b677ee1c83f569e5e20b3739a7664bb33be1829f8478af35e135bf734a6ff151b8543ea6c4ecafbf822cee8189f7e7096bd9698711 SHA512 59d3d8213b1a219396b74b6f4188c01e1cb4eb1c63e6792ce1e7fdb8000d1a4625919337ff77288ca7f7e07d9753f481d2381a06f554012633cd678194c980de
diff --git a/dev-perl/librg-utils-perl/librg-utils-perl-1.0.43-r1.ebuild b/dev-perl/librg-utils-perl/librg-utils-perl-1.0.43-r2.ebuild
index 88b8d7cf6e04..b61dd58c9a08 100644
--- a/dev-perl/librg-utils-perl/librg-utils-perl-1.0.43-r1.ebuild
+++ b/dev-perl/librg-utils-perl/librg-utils-perl-1.0.43-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit perl-module
@@ -9,32 +9,24 @@ DESCRIPTION="Parsers and format conversion utilities used by (e.g.) profphd"
HOMEPAGE="http://rostlab.org/"
SRC_URI="ftp://rostlab.org/librg-utils-perl/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-RDEPEND="
- dev-perl/List-MoreUtils"
+RDEPEND="dev-perl/List-MoreUtils"
DEPEND="${RDEPEND}
- sci-libs/profphd-utils
- dev-perl/Module-Build
-"
-PATCHES=("${FILESDIR}/${P}-defined-array.patch")
+ sci-libs/profphd-utils"
+BDEPEND="dev-perl/Module-Build"
+
+PATCHES=(
+ "${FILESDIR}/${P}-defined-array.patch"
+)
+
src_configure() {
econf
perl-module_src_configure
}
-src_install() {
- rm mat/Makefile* || die
- perl-module_src_install
- insinto /usr/share/${PN}
- doins -r mat
- exeinto /usr/share/${PN}
- doexe *.pl dbSwiss
- doman blib/libdoc/*
-}
src_test() {
local MODULES=(
"RG::Utils::Conv_hssp2saf"
@@ -42,18 +34,34 @@ src_test() {
"RG::Utils::Copf"
)
local failed=()
+
for dep in "${MODULES[@]}"; do
ebegin "Compile testing ${dep}"
- perl -Mblib="${S}" -M"${dep} ()" -e1
+ perl -Mblib="${S}" -M"${dep} ()" -e1
eend $? || failed+=( "$dep" )
done
+
if [[ ${failed[@]} ]]; then
- echo
- eerror "One or more modules failed compile:";
+ eerror "One or more modules failed compile:"
for dep in "${failed[@]}"; do
eerror " ${dep}"
done
- die "Failing due to module compilation errors";
+ die "Failing due to module compilation errors"
fi
+
perl-module_src_test
}
+
+src_install() {
+ rm mat/Makefile* || die
+
+ perl-module_src_install
+
+ insinto /usr/share/${PN}
+ doins -r mat
+
+ exeinto /usr/share/${PN}
+ doexe *.pl dbSwiss
+
+ doman blib/libdoc/*
+}