summaryrefslogtreecommitdiff
path: root/dev-perl/glib-perl/glib-perl-1.329.300.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-12 08:41:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-12 08:41:54 +0100
commit4df3bf9762850b34cd1ead5c80374d1a0fc3362e (patch)
tree3080c5cb7ad17abcb63776a9f21c4947845546a6 /dev-perl/glib-perl/glib-perl-1.329.300.ebuild
parent814f4cf860e299a046b649eaee5463427984c09c (diff)
gentoo resync : 12.07.2021
Diffstat (limited to 'dev-perl/glib-perl/glib-perl-1.329.300.ebuild')
-rw-r--r--dev-perl/glib-perl/glib-perl-1.329.300.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-perl/glib-perl/glib-perl-1.329.300.ebuild b/dev-perl/glib-perl/glib-perl-1.329.300.ebuild
new file mode 100644
index 000000000000..5942e7eddbaa
--- /dev/null
+++ b/dev-perl/glib-perl/glib-perl-1.329.300.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_NAME=Glib
+DIST_AUTHOR=XAOC
+DIST_VERSION=1.3293
+inherit perl-module
+
+DESCRIPTION="Glib - Perl wrappers for the GLib utility and Object libraries"
+HOMEPAGE="http://gtk2-perl.sf.net/ https://metacpan.org/release/Glib"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2
+"
+DEPEND="${RDEPEND}
+"
+
+# Log::Agent optional by Storable but has caused unexplained segv's
+# from build/doc.pl : https://bugs.gentoo.org/529080
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ >=dev-perl/ExtUtils-Depends-0.300.0
+ >=dev-perl/ExtUtils-PkgConfig-1.0.0
+ virtual/pkgconfig
+ dev-perl/Log-Agent
+"