summaryrefslogtreecommitdiff
path: root/dev-perl/YAML
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/YAML
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/YAML')
-rw-r--r--dev-perl/YAML/Manifest5
-rw-r--r--dev-perl/YAML/YAML-1.150.0.ebuild22
-rw-r--r--dev-perl/YAML/YAML-1.240.0.ebuild24
-rw-r--r--dev-perl/YAML/metadata.xml33
4 files changed, 84 insertions, 0 deletions
diff --git a/dev-perl/YAML/Manifest b/dev-perl/YAML/Manifest
new file mode 100644
index 000000000000..2d0005286bbd
--- /dev/null
+++ b/dev-perl/YAML/Manifest
@@ -0,0 +1,5 @@
+DIST YAML-1.15.tar.gz 80702 BLAKE2B adb4874943a2bd1b7aab688d5a0843e78e28e2934138589ee2b3c502ea105c672c8d4e860607f562c231065f903abd0d20f79bc046316283b0bbf5323974134a SHA512 c1b715c46186009e27e25857c99cbd729fc49a1854dd987dcab53e4279528f19a1b9822dd1ca95162aa2a0b6627cf15ef6a692ad22c659dbd5c251fc3f898b7b
+DIST YAML-1.24.tar.gz 83296 BLAKE2B c15d041ee5004b5c9d13b994abb2aca1753aa8aad4f498eee82008a5476c84f844f3ab5d2d40ed2fc46c876e1ce51c8cd24b870e207a8bc4395e9b3aaecbbb6b SHA512 20ba196cf9c68a38154f68b884262b9f89463af5e67c1e59944070b2493f6d9515f92a2793f456e20fe7e6372b74da8f6c16b884274793b6c3aa0ed0134c340d
+EBUILD YAML-1.150.0.ebuild 579 BLAKE2B e23dbb9131452a6d9e3270dfc5dd794f3f91bbf7f48e1b1f52a7b065ce3f3b59d247ccaf9caccaf8332bdccc7b3a2c76ceb6222e04b16843364b1d78593f8997 SHA512 08c3585856a078de15f96a71f488627c6bb698574383f76acd79adfd8a53f202d7e19bc6f2792a519a2ccf77b59430c189366d5f8c83dc4316e3ffd7192dceba
+EBUILD YAML-1.240.0.ebuild 660 BLAKE2B 3fddb3f141a57a9478d98bedc4b0f9604ca8c112250906a2c728c28d03b16d246557f88592e4ba906316ab96749a253b89b4aae4f309c576d56ef01815a1e295 SHA512 775577e530d0ff8ebe6cecd11e3edb68a78a7be0aad523c7dd24e67c1d21f548abf0e4bbbd8f8996fa76617d73a43ef427c1b2f0955d839d73701e70353350ff
+MISC metadata.xml 1648 BLAKE2B fa4dee8b87f50eebb9b1b0f454a5ff54983210525f03e900b8356dcf6270ed7db786ce8d6bb20755244a2c4370c88fd444b32cdd83c331895adef2dfe60afb62 SHA512 d4f824afe8a3e3c8feab3d2d6c3788d201e4aafc3879cdb9e8a9e248022c09d8160c5c1db574ff35e1327afe4c898c11939105e4772a8b6c7917bae6146f033c
diff --git a/dev-perl/YAML/YAML-1.150.0.ebuild b/dev-perl/YAML/YAML-1.150.0.ebuild
new file mode 100644
index 000000000000..a19f73c9182d
--- /dev/null
+++ b/dev-perl/YAML/YAML-1.150.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=INGY
+MODULE_VERSION=1.15
+inherit perl-module
+
+DESCRIPTION="YAML Ain't Markup Language (tm)"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( dev-perl/Test-YAML )
+"
+
+SRC_TEST="do"
diff --git a/dev-perl/YAML/YAML-1.240.0.ebuild b/dev-perl/YAML/YAML-1.240.0.ebuild
new file mode 100644
index 000000000000..2d824b0805c6
--- /dev/null
+++ b/dev-perl/YAML/YAML-1.240.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=TINITA
+DIST_VERSION=1.24
+inherit perl-module
+
+DESCRIPTION="YAML Ain't Markup Language (tm)"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-0.880.0
+ >=dev-perl/Test-YAML-1.50.0
+ )
+"
+PERL_RM_FILES=("t/author-pod-syntax.t")
diff --git a/dev-perl/YAML/metadata.xml b/dev-perl/YAML/metadata.xml
new file mode 100644
index 000000000000..a277421c7ca2
--- /dev/null
+++ b/dev-perl/YAML/metadata.xml
@@ -0,0 +1,33 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">YAML</remote-id>
+ <remote-id type="cpan-module">YAML</remote-id>
+ <remote-id type="cpan-module">YAML::Any</remote-id>
+ <remote-id type="cpan-module">YAML::Dumper</remote-id>
+ <remote-id type="cpan-module">YAML::Dumper::Base</remote-id>
+ <remote-id type="cpan-module">YAML::Error</remote-id>
+ <remote-id type="cpan-module">YAML::Loader</remote-id>
+ <remote-id type="cpan-module">YAML::Loader::Base</remote-id>
+ <remote-id type="cpan-module">YAML::Marshall</remote-id>
+ <remote-id type="cpan-module">YAML::Mo</remote-id>
+ <remote-id type="cpan-module">YAML::Node</remote-id>
+ <remote-id type="cpan-module">YAML::Tag</remote-id>
+ <remote-id type="cpan-module">YAML::Type::blessed</remote-id>
+ <remote-id type="cpan-module">YAML::Type::code</remote-id>
+ <remote-id type="cpan-module">YAML::Type::glob</remote-id>
+ <remote-id type="cpan-module">YAML::Type::ref</remote-id>
+ <remote-id type="cpan-module">YAML::Type::regexp</remote-id>
+ <remote-id type="cpan-module">YAML::Type::undef</remote-id>
+ <remote-id type="cpan-module">YAML::Types</remote-id>
+ <remote-id type="cpan-module">YAML::Warning</remote-id>
+ <remote-id type="cpan-module">yaml_mapping</remote-id>
+ <remote-id type="cpan-module">yaml_scalar</remote-id>
+ <remote-id type="cpan-module">yaml_sequence</remote-id>
+ </upstream>
+</pkgmetadata>