summaryrefslogtreecommitdiff
path: root/dev-perl/XML-Simple/XML-Simple-2.250.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-29 16:53:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-03-29 16:53:27 +0100
commit1173ad5704ce725916e0c332416aff326d850d06 (patch)
treed48d60977ce19864893dfb2222bf2982ffb4262a /dev-perl/XML-Simple/XML-Simple-2.250.0.ebuild
parent8c364c784966be1700ea39ae45028f3e9be9cae0 (diff)
gentoo resync : 29.03.2018
Diffstat (limited to 'dev-perl/XML-Simple/XML-Simple-2.250.0.ebuild')
-rw-r--r--dev-perl/XML-Simple/XML-Simple-2.250.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-perl/XML-Simple/XML-Simple-2.250.0.ebuild b/dev-perl/XML-Simple/XML-Simple-2.250.0.ebuild
new file mode 100644
index 000000000000..44f22539e97c
--- /dev/null
+++ b/dev-perl/XML-Simple/XML-Simple-2.250.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=GRANTM
+DIST_VERSION=2.25
+inherit perl-module
+
+DESCRIPTION="An API for simple XML files"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Storable
+ >=dev-perl/XML-NamespaceSupport-1.40.0
+ >=dev-perl/XML-SAX-0.150.0
+ dev-perl/XML-SAX-Expat
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( >=virtual/perl-Test-Simple-0.880.0 )
+"
+PATCHES=("${FILESDIR}/${PN}-2.25-saxtests.patch")
+PERL_RM_FILES=("t/author-pod-syntax.t")