summaryrefslogtreecommitdiff
path: root/dev-perl/XML-SAX-Expat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-perl/XML-SAX-Expat
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-perl/XML-SAX-Expat')
-rw-r--r--dev-perl/XML-SAX-Expat/Manifest2
-rw-r--r--dev-perl/XML-SAX-Expat/XML-SAX-Expat-0.510.0-r3.ebuild (renamed from dev-perl/XML-SAX-Expat/XML-SAX-Expat-0.510.0-r1.ebuild)9
2 files changed, 7 insertions, 4 deletions
diff --git a/dev-perl/XML-SAX-Expat/Manifest b/dev-perl/XML-SAX-Expat/Manifest
index c26eace1a586..d9aac256efc2 100644
--- a/dev-perl/XML-SAX-Expat/Manifest
+++ b/dev-perl/XML-SAX-Expat/Manifest
@@ -1,3 +1,3 @@
DIST XML-SAX-Expat-0.51.tar.gz 7134 BLAKE2B bc1f7a9bf5e5edeb4f8102569b6c4edad38666af5d2466f53c4b874366443ebe8b24c36b2431fd77119c6f9e32f40fae611df2c45b0df0ae51d022edc51d49c4 SHA512 9cd3c7a1cdf0b0a49ea9f871095984fb67ff54c9e5ed49884c591a450c2662acbd6d0f5232a5720663bcab09ff4f41093d414daa0b72457dc98eea5001270478
-EBUILD XML-SAX-Expat-0.510.0-r1.ebuild 1276 BLAKE2B aaf84ceca9d29eac63832ea40a27ff2c09030feecacb97aeeddfde6f04440434dd5be7643f09cb7833e0081b6d836105bd1303d9e28d6b33d050398996267050 SHA512 65f6c781b3bc61e00543913fb27e3f837adb61430b384a5c6b375842220cae3df6cf3facd1b486ac35d6e9e0c30a245f0cc775fdda80d72ae9b707eba1b960d2
+EBUILD XML-SAX-Expat-0.510.0-r3.ebuild 1469 BLAKE2B 18655fea8d688d254ea8dff139eefe621cd532f6abbf3540169c79071270b355c29157b1cde0870e0e939c49177718d66790bd5de971a251373ba58540060f91 SHA512 a2dfbd47f7cfbfd2c83bb01210303fb0bb5d56d73542739a2c621a94e5cf91e1f47bc581215e86252bff38e9a0d1f0d9b08dc93578be68b0cce6a8fc295dd121
MISC metadata.xml 400 BLAKE2B f08ea44bcd2a8f0145ddd3d95c5c603820d52a64d17869e1b438a6ff813c01a62063dd40c8db281e787e5b7566ebb91805edfdbb95bba85e6a4bb32c5c602e6a SHA512 1440c451231b3090dbe96135059a9ee92a7f16a4da67d52000ee63a066efeec6d04364a4bb74bee7cbc03b77bf3d9a0eef39c085ecbdfb1bb3f25c5a5abddd90
diff --git a/dev-perl/XML-SAX-Expat/XML-SAX-Expat-0.510.0-r1.ebuild b/dev-perl/XML-SAX-Expat/XML-SAX-Expat-0.510.0-r3.ebuild
index 22648f93e9d0..2a2c86d12c50 100644
--- a/dev-perl/XML-SAX-Expat/XML-SAX-Expat-0.510.0-r1.ebuild
+++ b/dev-perl/XML-SAX-Expat/XML-SAX-Expat-0.510.0-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -11,8 +11,11 @@ DESCRIPTION="SAX2 Driver for Expat"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+# >= on XML-Sax needed to avoid "miscompilation" (essentially empty install), as newer XML-Sax
+# has the ROOT check fixed. Didn't happen with XML-SAX-Expat, but best to be careful.
+# bug #840053
RDEPEND="
- >=dev-perl/XML-SAX-0.150.0-r1
+ >=dev-perl/XML-SAX-1.20.0-r1
>=dev-perl/XML-NamespaceSupport-1.90.0
dev-perl/XML-Parser
"
@@ -45,7 +48,7 @@ pkg_update_parser() {
local action=$1
local parser_module=$2
- if [[ "$ROOT" = "/" ]] ; then
+ if [[ -z "${ROOT}" ]] ; then
einfo "Update Parser: $1 $2"
perl -MXML::SAX -e "XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()" \
|| ewarn "Update Parser: $1 $2 failed"