summaryrefslogtreecommitdiff
path: root/dev-perl/XML-Compile/XML-Compile-1.540.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/XML-Compile/XML-Compile-1.540.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/XML-Compile/XML-Compile-1.540.0.ebuild')
-rw-r--r--dev-perl/XML-Compile/XML-Compile-1.540.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/XML-Compile/XML-Compile-1.540.0.ebuild b/dev-perl/XML-Compile/XML-Compile-1.540.0.ebuild
new file mode 100644
index 000000000000..7ff94c671821
--- /dev/null
+++ b/dev-perl/XML-Compile/XML-Compile-1.540.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MARKOV
+DIST_VERSION=1.54
+inherit perl-module
+
+DESCRIPTION="Compilation based XML Processing"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-Digest-MD5-2.360.0
+ >=dev-perl/Log-Report-1.30.0
+ >=virtual/perl-MIME-Base64-3.100.0
+ >=virtual/perl-Math-BigInt-1.770.0
+ >=virtual/perl-Math-BigRat-0.100.0
+ virtual/perl-Scalar-List-Utils
+ >=dev-perl/XML-LibXML-2.10.700
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=dev-perl/Test-Deep-0.95.0
+ >=virtual/perl-Test-Simple-0.540.0
+ >=dev-perl/XML-Compile-Tester-0.900.0
+ )
+"
+src_install() {
+ perl-module_src_install
+ dodoc -r html
+}