summaryrefslogtreecommitdiff
path: root/dev-perl/WWW-RobotRules
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/WWW-RobotRules
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/WWW-RobotRules')
-rw-r--r--dev-perl/WWW-RobotRules/Manifest4
-rw-r--r--dev-perl/WWW-RobotRules/WWW-RobotRules-6.20.0-r1.ebuild19
-rw-r--r--dev-perl/WWW-RobotRules/WWW-RobotRules-6.20.0.ebuild21
-rw-r--r--dev-perl/WWW-RobotRules/metadata.xml14
4 files changed, 58 insertions, 0 deletions
diff --git a/dev-perl/WWW-RobotRules/Manifest b/dev-perl/WWW-RobotRules/Manifest
new file mode 100644
index 000000000000..07dfd46ee60a
--- /dev/null
+++ b/dev-perl/WWW-RobotRules/Manifest
@@ -0,0 +1,4 @@
+DIST WWW-RobotRules-6.02.tar.gz 9059 BLAKE2B b9ad0d2a16a6614bba6b307ba8d81095be59b7c4128050fdd019723f22e1085571abe9eb977cbf5e971dbfce18eb4be1ef1866a0bc86bd7c017c033541cad352 SHA512 781a2fc90e4efed901a91ecf4f2aaac2684409c6a75a8434ff140654838bb05d11f8fa760642e20eee96450d3ced6815a4dab11a4245bc8120c69ca68ab49e44
+EBUILD WWW-RobotRules-6.20.0-r1.ebuild 563 BLAKE2B 534af27577df52010c862cad8c33e98700376109f33b7d72f4484d51df17fd4cb42cb30c0410c7de6ddc2a29aeba140f5001bffa9681bdca1738a3ff9193611b SHA512 c77f3dd105a5352b21889888608a69b2fedac502c1af36f26b8df609afebe39dcb1c706e1da3638a1de22ef6adce6d8f30259ccec80dd6fa94655a3f24fe0f2f
+EBUILD WWW-RobotRules-6.20.0.ebuild 574 BLAKE2B 68d51a0cd6e9476a6039b562cd105a2fd64d8ec27caf08c25ac551efbdbd977834ae11499a77836068bd0bbec7482791c69068c00bc9b836652cb64295c02c5a SHA512 e4da7171b41fd914abc5b8889aa1ed4e96904755404e5eef5c1987a2ba417e013bdc1bae8cecee8a3b3426a3e86db5fe9a073e10857396888f4fe3ecee7630f5
+MISC metadata.xml 529 BLAKE2B 390a88dfaf65a9a0471a732941ff2d38f4f4500c828fd5f293ce57ec69df2dc6886ff15be540770ddd78ece6305948fca3b687519a49c079fa3a05be9866f6ce SHA512 e97dfe7c14b0239c4b6d3104a422215de68648dcdc54040a50fad6d3f4718a74766718bf5c00f7882258062e7658faf7e068157d6123baea35cf3adfbd4575d4
diff --git a/dev-perl/WWW-RobotRules/WWW-RobotRules-6.20.0-r1.ebuild b/dev-perl/WWW-RobotRules/WWW-RobotRules-6.20.0-r1.ebuild
new file mode 100644
index 000000000000..171d6dbd8883
--- /dev/null
+++ b/dev-perl/WWW-RobotRules/WWW-RobotRules-6.20.0-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=GAAS
+DIST_VERSION=6.02
+inherit perl-module
+
+DESCRIPTION="Parse /robots.txt file"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ !<dev-perl/libwww-perl-6
+ >=dev-perl/URI-1.10
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-perl/WWW-RobotRules/WWW-RobotRules-6.20.0.ebuild b/dev-perl/WWW-RobotRules/WWW-RobotRules-6.20.0.ebuild
new file mode 100644
index 000000000000..096f9f943142
--- /dev/null
+++ b/dev-perl/WWW-RobotRules/WWW-RobotRules-6.20.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=GAAS
+MODULE_VERSION=6.02
+inherit perl-module
+
+DESCRIPTION="Parse /robots.txt file"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ !<dev-perl/libwww-perl-6
+ >=dev-perl/URI-1.10
+"
+DEPEND="${RDEPEND}"
+
+SRC_TEST=online
diff --git a/dev-perl/WWW-RobotRules/metadata.xml b/dev-perl/WWW-RobotRules/metadata.xml
new file mode 100644
index 000000000000..886a75caa48a
--- /dev/null
+++ b/dev-perl/WWW-RobotRules/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">WWW-RobotRules</remote-id>
+ <remote-id type="cpan-module">WWW::RobotRules</remote-id>
+ <remote-id type="cpan-module">WWW::RobotRules::AnyDBM_File</remote-id>
+ <remote-id type="cpan-module">WWW::RobotRules::InCore</remote-id>
+ </upstream>
+</pkgmetadata>