summaryrefslogtreecommitdiff
path: root/dev-perl/WWW-Pastebin-PastebinCom-Create/WWW-Pastebin-PastebinCom-Create-1.3.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/WWW-Pastebin-PastebinCom-Create/WWW-Pastebin-PastebinCom-Create-1.3.0-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/WWW-Pastebin-PastebinCom-Create/WWW-Pastebin-PastebinCom-Create-1.3.0-r1.ebuild')
-rw-r--r--dev-perl/WWW-Pastebin-PastebinCom-Create/WWW-Pastebin-PastebinCom-Create-1.3.0-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/WWW-Pastebin-PastebinCom-Create/WWW-Pastebin-PastebinCom-Create-1.3.0-r1.ebuild b/dev-perl/WWW-Pastebin-PastebinCom-Create/WWW-Pastebin-PastebinCom-Create-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..61f7a1ac6ffc
--- /dev/null
+++ b/dev-perl/WWW-Pastebin-PastebinCom-Create/WWW-Pastebin-PastebinCom-Create-1.3.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=ZOFFIX
+DIST_VERSION=1.003
+inherit perl-module
+
+DESCRIPTION="Paste on www.pastebin.com without API keys"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Moo-1.4.1
+ >=dev-perl/WWW-Mechanize-1.730.0
+"
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+
+src_test() {
+ local my_test_control=${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}}
+ if ! has network ${my_test_control} ; then
+ einfo "Supressing Network Test without DIST_TEST_OVERRIDE =~ network"
+ perl_rm_files t/01-paste.t
+ fi
+ perl-module_src_test
+}