summaryrefslogtreecommitdiff
path: root/dev-perl/Unicode-LineBreak
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Unicode-LineBreak
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Unicode-LineBreak')
-rw-r--r--dev-perl/Unicode-LineBreak/Manifest7
-rw-r--r--dev-perl/Unicode-LineBreak/Unicode-LineBreak-2016.3.0.ebuild21
-rw-r--r--dev-perl/Unicode-LineBreak/Unicode-LineBreak-2017.4.0-r1.ebuild21
-rw-r--r--dev-perl/Unicode-LineBreak/Unicode-LineBreak-2017.4.0.ebuild21
-rw-r--r--dev-perl/Unicode-LineBreak/files/Unicode-LineBreak-2017.004-dotinc.patch232
-rw-r--r--dev-perl/Unicode-LineBreak/metadata.xml14
6 files changed, 316 insertions, 0 deletions
diff --git a/dev-perl/Unicode-LineBreak/Manifest b/dev-perl/Unicode-LineBreak/Manifest
new file mode 100644
index 000000000000..e0ffe56a11a2
--- /dev/null
+++ b/dev-perl/Unicode-LineBreak/Manifest
@@ -0,0 +1,7 @@
+AUX Unicode-LineBreak-2017.004-dotinc.patch 4512 BLAKE2B e86fb471d296e642aedb25472c8ed7921293bc8beb5d560132ce5dfd7abfd5db2f5c17948f3384e328f760f318cf2f9ec2d2274d18fc371ad2a4b3ca3e88cd8b SHA512 e31fc9648c637d3ece712d71f8e3e1a35b949f554aeceb52b33bbf09831acd9541b044cedcc3fbb098701f542e9df60d567d49c4d2c4ef4bebe8c6e1a646c289
+DIST Unicode-LineBreak-2016.003.tar.gz 304042 BLAKE2B c0b3d48b0b0855757f3a1555871d52935cdd19d3617a9e10bbe82d21e47fa7bbef648e2d3d235476f9d683d3ccb7f0ea9e960060c47214486dcd968f1105f1e5 SHA512 c2296ebd87a06c55d95f198ef355566c05257a75a38876c726cebe309f5e6082a7bfd7d86f28505e183e3150313e781a6f1999e8de8b35ee772d94845cd08e2f
+DIST Unicode-LineBreak-2017.004.tar.gz 311366 BLAKE2B 7f4ff93365c0542ae1a8f9d17e0e9e20224b95949c4965e69f241ff949f625793a19bde4a81830f9f0214abe3d18fa6c52f43f9a04860ec4d13db55169d120f7 SHA512 f372174a761f87663761dc8b0f9bf387ffe289ba267fc0fb58353ac06dfa9418d4b0ac6e4e0d7833d842feacae4f8e90e521cd677ab22db1bf32e75f10f2e727
+EBUILD Unicode-LineBreak-2016.3.0.ebuild 406 BLAKE2B c674677e9d1c9452b5dabfd138c0bf8f298352d3314d90500d8dd455a120f8bc44300809a51618ae45b2bcb131c34300c38b8851655441da79f5ee7f8bdc18a6 SHA512 200118373c41717160ee3ea105cbf9972019cc445f6f07749b570993a889807fa9f7f2d594782e8e475e597677b8db65f6333ab4e9d0bf12d734c03169c95bf7
+EBUILD Unicode-LineBreak-2017.4.0-r1.ebuild 498 BLAKE2B 5b8454ab865845572db026c8eb331588c954f989e5ca3dc797101e37b8a6e5681766d25f1433b8bc562ab3a467627574ad6ad5faa883f6c37c18b0170f9e3a6b SHA512 044dcac0e3700aa10e78dea96ae39887fb8d968abeab99ba696c58c87315c75cc6dc3315e5ddbe78e7c456967010a5cf02f1ab77da1266a2f8837dcf2121d4be
+EBUILD Unicode-LineBreak-2017.4.0.ebuild 439 BLAKE2B cabde985bc70d710dd4d0370a0e31c58a37299c772c32c0027aa5db9af2b4631e9f2ccf0d8fef6081b708eb836e3dec2b07c9eee72117780841bbe687d285d08 SHA512 73a5a55008c3939e69acf9a82409582fa0b33c3157eff12e61b918bc144b37868ff09d34612dab9cd04f4d36d0b91174dc4aa4ad989d2267d035428b2053e122
+MISC metadata.xml 531 BLAKE2B 222c5b7ac9a391d440e8d2d74525ffe988ebfaaafeacbeb725b944bb688977ac2a44f5934ccdcf719ccf516d3580308f0cddb6b1f4c7d2b3ae2e2ceadd5cb1db SHA512 831c5152759f2a9b2c549295aec94a7a9a00f261fedeca2744aa5161ba4cc9c68efd59da63b80e3b70ea83fe16491f7438580fc614bfcf57fd813654307710ed
diff --git a/dev-perl/Unicode-LineBreak/Unicode-LineBreak-2016.3.0.ebuild b/dev-perl/Unicode-LineBreak/Unicode-LineBreak-2016.3.0.ebuild
new file mode 100644
index 000000000000..b0a813e44a27
--- /dev/null
+++ b/dev-perl/Unicode-LineBreak/Unicode-LineBreak-2016.3.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR="NEZUMI"
+MODULE_VERSION="2016.003"
+
+inherit perl-module
+
+DESCRIPTION="UAX #14 Unicode Line Breaking Algorithm"
+
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 x86"
+IUSE=""
+
+RDEPEND="dev-perl/MIME-Charset
+ virtual/perl-Encode"
+DEPEND="${RDEPEND}"
+
+SRC_TEST="do"
diff --git a/dev-perl/Unicode-LineBreak/Unicode-LineBreak-2017.4.0-r1.ebuild b/dev-perl/Unicode-LineBreak/Unicode-LineBreak-2017.4.0-r1.ebuild
new file mode 100644
index 000000000000..faae92187717
--- /dev/null
+++ b/dev-perl/Unicode-LineBreak/Unicode-LineBreak-2017.4.0-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=NEZUMI
+DIST_VERSION=2017.004
+
+inherit perl-module
+
+DESCRIPTION="UAX #14 Unicode Line Breaking Algorithm"
+
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc x86 ~amd64-fbsd"
+IUSE=""
+
+RDEPEND="dev-perl/MIME-Charset
+ virtual/perl-Encode"
+DEPEND="${RDEPEND}"
+PATCHES=("${FILESDIR}/${PN}-2017.004-dotinc.patch")
+PERL_RM_FILES=("t/pod.t")
diff --git a/dev-perl/Unicode-LineBreak/Unicode-LineBreak-2017.4.0.ebuild b/dev-perl/Unicode-LineBreak/Unicode-LineBreak-2017.4.0.ebuild
new file mode 100644
index 000000000000..07d6a57100b6
--- /dev/null
+++ b/dev-perl/Unicode-LineBreak/Unicode-LineBreak-2017.4.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR="NEZUMI"
+MODULE_VERSION="2017.004"
+
+inherit perl-module
+
+DESCRIPTION="UAX #14 Unicode Line Breaking Algorithm"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+IUSE=""
+
+RDEPEND="dev-perl/MIME-Charset
+ virtual/perl-Encode"
+DEPEND="${RDEPEND}"
+
+SRC_TEST="do"
diff --git a/dev-perl/Unicode-LineBreak/files/Unicode-LineBreak-2017.004-dotinc.patch b/dev-perl/Unicode-LineBreak/files/Unicode-LineBreak-2017.004-dotinc.patch
new file mode 100644
index 000000000000..3a9b808f4669
--- /dev/null
+++ b/dev-perl/Unicode-LineBreak/files/Unicode-LineBreak-2017.004-dotinc.patch
@@ -0,0 +1,232 @@
+From fd36408d8e59381c0ea217166a244222adbd5ec9 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Sun, 18 Mar 2018 22:02:48 +1300
+Subject: Fix tests for '.' in @INC removal on Perl 5.26+
+
+---
+ t/01break.t | 2 +-
+ t/02hangul.t | 2 +-
+ t/03ns.t | 2 +-
+ t/04fold.t | 2 +-
+ t/05urgent.t | 2 +-
+ t/06context.t | 2 +-
+ t/07sea.t | 2 +-
+ t/08partial.t | 2 +-
+ t/09uri.t | 2 +-
+ t/11format.t | 2 +-
+ t/12fold2.t | 2 +-
+ t/13flowedsp.t | 2 +-
+ t/14sea_al.t | 2 +-
+ t/15array.t | 2 +-
+ t/16regex.t | 2 +-
+ t/17prop.t | 2 +-
+ t/18currency.t | 2 +-
+ 17 files changed, 17 insertions(+), 17 deletions(-)
+
+diff --git a/t/01break.t b/t/01break.t
+index a7676bc..4d80758 100644
+--- a/t/01break.t
++++ b/t/01break.t
+@@ -1,6 +1,6 @@
+ use strict;
+ use Test::More;
+-require "t/lb.pl";
++require "./t/lb.pl";
+
+ BEGIN { plan tests => 13 }
+
+diff --git a/t/02hangul.t b/t/02hangul.t
+index 5140636..027f418 100644
+--- a/t/02hangul.t
++++ b/t/02hangul.t
+@@ -1,6 +1,6 @@
+ use strict;
+ use Test::More;
+-require "t/lb.pl";
++require "./t/lb.pl";
+
+ BEGIN { plan tests => 2 }
+
+diff --git a/t/03ns.t b/t/03ns.t
+index 8d515dd..43b50f7 100644
+--- a/t/03ns.t
++++ b/t/03ns.t
+@@ -1,6 +1,6 @@
+ use strict;
+ use Test::More;
+-require "t/lb.pl";
++require "./t/lb.pl";
+
+ BEGIN { plan tests => 2 }
+
+diff --git a/t/04fold.t b/t/04fold.t
+index 8eb9624..50287cb 100644
+--- a/t/04fold.t
++++ b/t/04fold.t
+@@ -1,6 +1,6 @@
+ use strict;
+ use Test::More;
+-require "t/lf.pl";
++require "./t/lf.pl";
+
+ BEGIN { plan tests => 15 + 2 }
+
+diff --git a/t/05urgent.t b/t/05urgent.t
+index e5f27c7..0ae4c66 100644
+--- a/t/05urgent.t
++++ b/t/05urgent.t
+@@ -1,6 +1,6 @@
+ use strict;
+ use Test::More;
+-require "t/lb.pl";
++require "./t/lb.pl";
+
+ BEGIN { plan tests => 5 }
+
+diff --git a/t/06context.t b/t/06context.t
+index 4de9f4e..e8ac3f7 100644
+--- a/t/06context.t
++++ b/t/06context.t
+@@ -1,6 +1,6 @@
+ use strict;
+ use Test::More;
+-require "t/lb.pl";
++require "./t/lb.pl";
+
+ BEGIN { plan tests => 2 }
+
+diff --git a/t/07sea.t b/t/07sea.t
+index 8446e96..da4d49a 100644
+--- a/t/07sea.t
++++ b/t/07sea.t
+@@ -1,6 +1,6 @@
+ use strict;
+ use Test::More;
+-require "t/lb.pl";
++require "./t/lb.pl";
+
+ BEGIN {
+ require Unicode::LineBreak;
+diff --git a/t/08partial.t b/t/08partial.t
+index e94f0a0..5baa894 100644
+--- a/t/08partial.t
++++ b/t/08partial.t
+@@ -1,6 +1,6 @@
+ use strict;
+ use Test::More;
+-require "t/lb.pl";
++require "./t/lb.pl";
+
+ BEGIN { plan tests => 15 }
+
+diff --git a/t/09uri.t b/t/09uri.t
+index 333e1cf..edb4d25 100644
+--- a/t/09uri.t
++++ b/t/09uri.t
+@@ -1,6 +1,6 @@
+ use strict;
+ use Test::More;
+-require "t/lb.pl";
++require "./t/lb.pl";
+
+ BEGIN { plan tests => 2 }
+
+diff --git a/t/11format.t b/t/11format.t
+index 62167cc..d4ebd5b 100644
+--- a/t/11format.t
++++ b/t/11format.t
+@@ -1,6 +1,6 @@
+ use strict;
+ use Test::More;
+-require "t/lb.pl";
++require "./t/lb.pl";
+
+ BEGIN { plan tests => 6 }
+
+diff --git a/t/12fold2.t b/t/12fold2.t
+index c9a64ef..d9fd4e8 100644
+--- a/t/12fold2.t
++++ b/t/12fold2.t
+@@ -1,6 +1,6 @@
+ use strict;
+ use Test::More;
+-require "t/lf.pl";
++require "./t/lf.pl";
+
+ BEGIN { plan tests => 2 }
+
+diff --git a/t/13flowedsp.t b/t/13flowedsp.t
+index 4454e6b..d4b96b8 100644
+--- a/t/13flowedsp.t
++++ b/t/13flowedsp.t
+@@ -1,6 +1,6 @@
+ use strict;
+ use Test::More;
+-require "t/lf.pl";
++require "./t/lf.pl";
+
+ BEGIN { plan tests => 1 }
+
+diff --git a/t/14sea_al.t b/t/14sea_al.t
+index 5a45574..2990333 100644
+--- a/t/14sea_al.t
++++ b/t/14sea_al.t
+@@ -1,6 +1,6 @@
+ use strict;
+ use Test::More;
+-require "t/lb.pl";
++require "./t/lb.pl";
+
+ BEGIN { plan tests => 1 }
+
+diff --git a/t/15array.t b/t/15array.t
+index 5ab75c2..51d79ab 100644
+--- a/t/15array.t
++++ b/t/15array.t
+@@ -1,6 +1,6 @@
+ use strict;
+ use Test::More;
+-require "t/lb.pl";
++require "./t/lb.pl";
+
+ BEGIN { plan tests => 19 }
+
+diff --git a/t/16regex.t b/t/16regex.t
+index 4a7f0db..e85e203 100644
+--- a/t/16regex.t
++++ b/t/16regex.t
+@@ -1,6 +1,6 @@
+ use strict;
+ use Test::More;
+-require "t/lb.pl";
++require "./t/lb.pl";
+
+ my $splitre;
+ BEGIN {
+diff --git a/t/17prop.t b/t/17prop.t
+index 55b9944..7f5b68c 100644
+--- a/t/17prop.t
++++ b/t/17prop.t
+@@ -1,6 +1,6 @@
+ use strict;
+ use Test::More;
+-require 't/lb.pl';
++require './t/lb.pl';
+
+ BEGIN { plan tests => 12 }
+
+diff --git a/t/18currency.t b/t/18currency.t
+index e280ddd..4d6feef 100644
+--- a/t/18currency.t
++++ b/t/18currency.t
+@@ -1,6 +1,6 @@
+ use strict;
+ use Test::More;
+-require 't/lb.pl';
++require './t/lb.pl';
+
+ BEGIN { plan tests => 96 }
+
+--
+2.16.2
+
diff --git a/dev-perl/Unicode-LineBreak/metadata.xml b/dev-perl/Unicode-LineBreak/metadata.xml
new file mode 100644
index 000000000000..de9136171e5d
--- /dev/null
+++ b/dev-perl/Unicode-LineBreak/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Unicode-LineBreak</remote-id>
+ <remote-id type="cpan-module">Text::LineFold</remote-id>
+ <remote-id type="cpan-module">Unicode::GCString</remote-id>
+ <remote-id type="cpan-module">Unicode::LineBreak</remote-id>
+ </upstream>
+</pkgmetadata>