summaryrefslogtreecommitdiff
path: root/dev-perl/Unicode-EastAsianWidth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Unicode-EastAsianWidth
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Unicode-EastAsianWidth')
-rw-r--r--dev-perl/Unicode-EastAsianWidth/Manifest4
-rw-r--r--dev-perl/Unicode-EastAsianWidth/Unicode-EastAsianWidth-1.330.0-r1.ebuild21
-rw-r--r--dev-perl/Unicode-EastAsianWidth/files/no-dot-inc.patch25
-rw-r--r--dev-perl/Unicode-EastAsianWidth/metadata.xml12
4 files changed, 62 insertions, 0 deletions
diff --git a/dev-perl/Unicode-EastAsianWidth/Manifest b/dev-perl/Unicode-EastAsianWidth/Manifest
new file mode 100644
index 000000000000..99b5d7a61e95
--- /dev/null
+++ b/dev-perl/Unicode-EastAsianWidth/Manifest
@@ -0,0 +1,4 @@
+AUX no-dot-inc.patch 602 BLAKE2B 2e2070b2620fd85118f643acc73ee5a5dc02a7c6bba52f0de734db65f021d125a2ab51f656af42ce2aeac071e380c1145a35c846dce31a2ce3b674812a21828c SHA512 fdad62c560595ec49f7de0dfd6f1f700abbfdc77053a016053573bb105251684ff4fcf8cf9fb534b2a2eeb5b38c21f089380876e3433fbbc47d0eabe9d542ec0
+DIST Unicode-EastAsianWidth-1.33.tar.gz 31498 BLAKE2B 1838e1447ad341ec711008ae0c2c48f27fd192ae32def73359e485010ad7d54e0907031a000a08dca0b15538f526851f554a3ee05a62145e87363ca74250b49f SHA512 c21e988f460534b370954d0448daec5bfb0a34ec816459f8422943ebe44ff17b5acb8a423d69daba81599111d7fa4aa33a3598e0ea4614eed25a587c1f5690eb
+EBUILD Unicode-EastAsianWidth-1.330.0-r1.ebuild 633 BLAKE2B 66c82a2cf5cc6c44789ba4e475b74674c85b05513a2c35b54de94725b52cc96ecde3f7d016eb5e49fbc632f7ff76456cbb84185c09214ffdcc98723a5601d26d SHA512 7bb7659f512098ac6373824221edabe6d8189cfbeef9527ad0f5ee36df5350f3277a87edd1099b67c404e5f557fa957555e0ace2401c942e4155d9b6188a8354
+MISC metadata.xml 404 BLAKE2B a3d5b61a32fe5fd531521c1acc4cddfdc92d4383062ca1ac9cce2ceb55ef760ebb75494918d2ce590a1970a796dd5bc621400e3ccf55d3eb8c6d6f747e83140b SHA512 0a9b4c003b910b30c439687e339e267459f3f85b877de4baaa4f89b0994771ac8a40b4096dafe5db19fff5c48fa69ac520e897dc59823ff306eb495295454b13
diff --git a/dev-perl/Unicode-EastAsianWidth/Unicode-EastAsianWidth-1.330.0-r1.ebuild b/dev-perl/Unicode-EastAsianWidth/Unicode-EastAsianWidth-1.330.0-r1.ebuild
new file mode 100644
index 000000000000..002917f89b86
--- /dev/null
+++ b/dev-perl/Unicode-EastAsianWidth/Unicode-EastAsianWidth-1.330.0-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=AUDREYT
+MODULE_VERSION=1.33
+inherit perl-module
+
+DESCRIPTION="East Asian Width properties"
+
+LICENSE="CC0-1.0"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="virtual/perl-File-Spec"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker"
+PATCHES=("${FILESDIR}/no-dot-inc.patch")
+SRC_TEST="do"
diff --git a/dev-perl/Unicode-EastAsianWidth/files/no-dot-inc.patch b/dev-perl/Unicode-EastAsianWidth/files/no-dot-inc.patch
new file mode 100644
index 000000000000..16d42e582a42
--- /dev/null
+++ b/dev-perl/Unicode-EastAsianWidth/files/no-dot-inc.patch
@@ -0,0 +1,25 @@
+From 9cb5f1551566addf37a47e935164519842bab0d8 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Sun, 11 Jun 2017 16:10:47 +1200
+Subject: [PATCH] Fix for Perl 5.26 w/o '.' in @INC
+
+---
+ Makefile.PL | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index 6745b7c..2db030d 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,6 +1,7 @@
+ #!/usr/bin/perl
+ use strict;
+-use inc::Module::Package 'Au:dry 1';
++use lib './inc';
++use Module::Package 'Au:dry 1';
+
+ my $DefaultVersion = 'v5.0.0';
+ my $DefaultDate = '2006-02-15';
+--
+2.13.1
+
diff --git a/dev-perl/Unicode-EastAsianWidth/metadata.xml b/dev-perl/Unicode-EastAsianWidth/metadata.xml
new file mode 100644
index 000000000000..f446398908c0
--- /dev/null
+++ b/dev-perl/Unicode-EastAsianWidth/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Unicode-EastAsianWidth</remote-id>
+ <remote-id type="cpan-module">Unicode::EastAsianWidth</remote-id>
+ </upstream>
+</pkgmetadata>