summaryrefslogtreecommitdiff
path: root/dev-perl/UUID/UUID-0.280.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
commite23a08d0c97a0cc415aaa165da840b056f93c997 (patch)
tree4c5f7db60483518201fef36f8cc0712789a08db2 /dev-perl/UUID/UUID-0.280.0.ebuild
parent391b5b359a346aff490103da7dddc85047f83830 (diff)
gentoo resync : 08.10.2021
Diffstat (limited to 'dev-perl/UUID/UUID-0.280.0.ebuild')
-rw-r--r--dev-perl/UUID/UUID-0.280.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-perl/UUID/UUID-0.280.0.ebuild b/dev-perl/UUID/UUID-0.280.0.ebuild
new file mode 100644
index 000000000000..a41ea98f302d
--- /dev/null
+++ b/dev-perl/UUID/UUID-0.280.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=JRM
+DIST_VERSION=0.28
+inherit perl-module
+
+DESCRIPTION="Perl extension for using UUID interfaces as defined in e2fsprogs"
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+
+# Note: UUID appears to link against a bunch of different UUID
+# implementations depending on availability and platform.
+# Presently uses uuid.h/libuuid.so from util-linux which is fine for Linux
+# platforms, but may need special attention on *bsd, *osx and win*
+
+RDEPEND="sys-apps/util-linux"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ >=dev-perl/Devel-CheckLib-1.20.0
+"
+DEPEND="${RDEPEND}
+"