summaryrefslogtreecommitdiff
path: root/dev-perl/Type-Tiny/Type-Tiny-1.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Type-Tiny/Type-Tiny-1.2.1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Type-Tiny/Type-Tiny-1.2.1.ebuild')
-rw-r--r--dev-perl/Type-Tiny/Type-Tiny-1.2.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-perl/Type-Tiny/Type-Tiny-1.2.1.ebuild b/dev-perl/Type-Tiny/Type-Tiny-1.2.1.ebuild
new file mode 100644
index 000000000000..7b3ee9329fd3
--- /dev/null
+++ b/dev-perl/Type-Tiny/Type-Tiny-1.2.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=TOBYINK
+DIST_VERSION=1.002001
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="tiny, yet Moo(se)-compatible type constraint"
+
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="test minimal"
+
+# Test rdep for Test::TypeTiny
+RDEPEND="
+ !<dev-perl/Kavorka-0.13.0
+ !<dev-perl/Types-ReadOnly-0.1.0
+ >=dev-perl/Exporter-Tiny-0.26.0
+ >=virtual/perl-Test-Simple-1.1.10
+ !minimal? (
+ >=dev-perl/Devel-LexAlias-0.50.0
+ dev-perl/Devel-StackTrace
+ >=dev-perl/Ref-Util-XS-0.100.0
+ >=dev-perl/Regexp-Util-0.3.0
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Type-Tie
+ >=dev-perl/Type-Tiny-XS-0.11.0
+ )
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.170.0
+ >=virtual/perl-CPAN-Meta-Requirements-2.0.0
+ test? (
+ dev-perl/Test-Warnings
+ )
+"