summaryrefslogtreecommitdiff
path: root/dev-perl/Type-Tiny-XS/Type-Tiny-XS-0.22.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-perl/Type-Tiny-XS/Type-Tiny-XS-0.22.0.ebuild
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-perl/Type-Tiny-XS/Type-Tiny-XS-0.22.0.ebuild')
-rw-r--r--dev-perl/Type-Tiny-XS/Type-Tiny-XS-0.22.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-perl/Type-Tiny-XS/Type-Tiny-XS-0.22.0.ebuild b/dev-perl/Type-Tiny-XS/Type-Tiny-XS-0.22.0.ebuild
new file mode 100644
index 000000000000..43f5105c5a9a
--- /dev/null
+++ b/dev-perl/Type-Tiny-XS/Type-Tiny-XS-0.22.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=TOBYINK
+DIST_VERSION=0.022
+inherit perl-module
+
+DESCRIPTION="provides an XS boost for some of Type::Tiny's built-in type constraints"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="test minimal"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !minimal? ( dev-perl/Type-Tiny )
+"
+BDEPEND="
+ ${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.170.0
+ test? (
+ >=virtual/perl-Test-Simple-0.920.0
+ )
+"