summaryrefslogtreecommitdiff
path: root/dev-perl/Tk-CursorControl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Tk-CursorControl
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Tk-CursorControl')
-rw-r--r--dev-perl/Tk-CursorControl/Manifest6
-rw-r--r--dev-perl/Tk-CursorControl/Tk-CursorControl-0.400.0-r1.ebuild24
-rw-r--r--dev-perl/Tk-CursorControl/Tk-CursorControl-0.400.0-r2.ebuild30
-rw-r--r--dev-perl/Tk-CursorControl/files/0.4-demo.patch12
-rw-r--r--dev-perl/Tk-CursorControl/files/Tk-CursorControl-0.4-nodemo.patch40
-rw-r--r--dev-perl/Tk-CursorControl/metadata.xml12
6 files changed, 124 insertions, 0 deletions
diff --git a/dev-perl/Tk-CursorControl/Manifest b/dev-perl/Tk-CursorControl/Manifest
new file mode 100644
index 000000000000..4ac10f879f1a
--- /dev/null
+++ b/dev-perl/Tk-CursorControl/Manifest
@@ -0,0 +1,6 @@
+AUX 0.4-demo.patch 397 BLAKE2B 485f3e167d8a8161151ab123149f14b7d13a40a192db8143e4040f68e7ec35db2419edd810cae4e71b7a18b38f8575fba69dd39ad0382b6b39df4c03f3b0aa21 SHA512 da2fb2d67e91476ccbc9fe1807bf85f5bf0aeecb35f363e3067a4b4bf33c559cccebfc05cf862095637217b9034935b8c103a08fab3f51d77128887cfe897f9b
+AUX Tk-CursorControl-0.4-nodemo.patch 1116 BLAKE2B 38871b9e9b0cbefe3a48d78ff37c8250695b78a22194cb49e16f7e6cf0381d5d5108bce5b528e0876ea7fdf94d6c67b158dd1b07d5534748c05ddf536c4c644b SHA512 ce35fca632faa25082ab529a59403ad719df468788c60e0b57113001881861877763454e6c645ee61b2e4ddd5d85782c41c682e2d6b8a419390ee228b6e6609b
+DIST Tk-CursorControl-0.4.tar.gz 12847 BLAKE2B 819cc96d1a2e3665cf83622959639cc78e9f4c497a87c79608addbbb3c500a9f44a3d632aecfd566c13ee7350fb66f9a22b4339e139c875fe3eb102467353e35 SHA512 9e4f052173211360f9239759259576c4928d8ffff3476005680ef1b0e90056465fe2a20ea4c6f3b949588c4162c2a4a03cf36ef6aef4bbe9ea5a6461248ced5b
+EBUILD Tk-CursorControl-0.400.0-r1.ebuild 478 BLAKE2B c15492e68199b78cbd685dbb8f4a84ed7eccd5dda40eb3186734a85051d1f32cc9b40363fea706580d7868b863a196ff821960ee71055926d4d667850f333838 SHA512 d70488be2b5d226873e757bbf03282da84c80e396194d8ddeaae806a687ca286912c274cf3175aa04f7479b254fc3213fd3a5c3ed4499e64f9866787001c848c
+EBUILD Tk-CursorControl-0.400.0-r2.ebuild 621 BLAKE2B bf7660daf65b5bb02ca9844b9e168fd4be5c517c8e24c7f086736765799a3e8a623dc3c66391b09317cf383044061e29fb008b41550d12513a22445b3f0da9fd SHA512 e79a6333a3373d4debe1094d2cf55c8cf200e0723794ed71f9514ba300b649767ec52aaceadfc12104caab386ba39ac41405103c6b28032a2557a188f400d73e
+MISC metadata.xml 404 BLAKE2B cb9bd81588e661f7082515627a058d7a571eac8cfbf6c4c78d846a59325c59cb2359dc4fe89b7a7db25eecd3ecd4bd2e1f2b4dc40efd3562bae54c56d79b7bf4 SHA512 75c185ea0c9570372a845bc3c46fe2675a33defc87d908db3a554aa7a603666c314bb7b6c83d593ef79e4544b8b50da73b86ec1d25ac3e24d241f08f9d26a56f
diff --git a/dev-perl/Tk-CursorControl/Tk-CursorControl-0.400.0-r1.ebuild b/dev-perl/Tk-CursorControl/Tk-CursorControl-0.400.0-r1.ebuild
new file mode 100644
index 000000000000..8d35eaa33e8d
--- /dev/null
+++ b/dev-perl/Tk-CursorControl/Tk-CursorControl-0.400.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=DUNNIGANJ
+MODULE_VERSION=0.4
+inherit eutils perl-module
+
+DESCRIPTION="Manipulate the mouse cursor programmatically"
+
+SLOT="0"
+KEYWORDS="amd64 ia64 sparc x86"
+IUSE=""
+
+RDEPEND="dev-perl/Tk"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/0.4-demo.patch" )
+
+src_prepare() {
+ perl-module_src_prepare
+ edos2unix "${S}"/{CursorControl.pm,demos/cursor.pl}
+}
diff --git a/dev-perl/Tk-CursorControl/Tk-CursorControl-0.400.0-r2.ebuild b/dev-perl/Tk-CursorControl/Tk-CursorControl-0.400.0-r2.ebuild
new file mode 100644
index 000000000000..0cb384cb448f
--- /dev/null
+++ b/dev-perl/Tk-CursorControl/Tk-CursorControl-0.400.0-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DUNNIGANJ
+DIST_VERSION=0.4
+
+# https://rt.cpan.org/Ticket/Display.html?id=124794
+# DIST_EXAMPLES=( "demos/*" )
+inherit eutils perl-module virtualx
+
+DESCRIPTION="Manipulate the mouse cursor programmatically"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-perl/Tk"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-0.4-nodemo.patch" )
+
+src_prepare() {
+ perl-module_src_prepare
+ edos2unix "${S}"/{CursorControl.pm,demos/cursor.pl}
+}
+src_test() {
+ virtx perl-module_src_test
+}
diff --git a/dev-perl/Tk-CursorControl/files/0.4-demo.patch b/dev-perl/Tk-CursorControl/files/0.4-demo.patch
new file mode 100644
index 000000000000..8bb70f86e42a
--- /dev/null
+++ b/dev-perl/Tk-CursorControl/files/0.4-demo.patch
@@ -0,0 +1,12 @@
+Collision with perl-tk -- bug 272083
+--- Tk-CursorControl-0.4/Makefile.PL
++++ Tk-CursorControl-0.4/Makefile.PL
+@@ -16,7 +16,7 @@
+ 'trans_cur.mask' => '$(INST_LIB)/Tk/trans_cur.mask',
+ 'demos/cursor.pl' => ($] >= 5.005
+ ? '$(INST_ARCHLIB)'
+- : '$(INST_LIB)') . '/Tk/demos/widtrib/cursor.pl',
++ : '$(INST_LIB)') . '/Tk/demos/widtrib/cursor_control.pl',
+ },
+
+ 'PREREQ_PM' => {
diff --git a/dev-perl/Tk-CursorControl/files/Tk-CursorControl-0.4-nodemo.patch b/dev-perl/Tk-CursorControl/files/Tk-CursorControl-0.4-nodemo.patch
new file mode 100644
index 000000000000..386a6f0aa255
--- /dev/null
+++ b/dev-perl/Tk-CursorControl/files/Tk-CursorControl-0.4-nodemo.patch
@@ -0,0 +1,40 @@
+From 299ab08346de3f8f670d3a50c6180bccf0402067 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Sat, 17 Mar 2018 14:52:48 +1300
+Subject: Stop installing demo's to @INC
+
+---
+ Makefile.PL | 13 +------------
+ 1 file changed, 1 insertion(+), 12 deletions(-)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index c229779..2503a8e 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -14,11 +14,7 @@ WriteMakefile(
+ 'CursorControl.pm' => '$(INST_LIB)/Tk/CursorControl.pm',
+ 'trans_cur.xbm' => '$(INST_LIB)/Tk/trans_cur.xbm',
+ 'trans_cur.mask' => '$(INST_LIB)/Tk/trans_cur.mask',
+- 'demos/cursor.pl' => ($] >= 5.005
+- ? '$(INST_ARCHLIB)'
+- : '$(INST_LIB)') . '/Tk/demos/widtrib/cursor.pl',
+- },
+-
++ },
+ 'PREREQ_PM' => {
+ 'Tk' => 800.015,
+ ($^O =~ /(MSWin32|cygwin)/ ? ('Win32::API' => 0.20) : ()),
+@@ -28,10 +24,3 @@ WriteMakefile(
+ 'CursorControl.pm' => '$(INST_MAN3DIR)/Tk::CursorControl.$(MAN3EXT)',
+ },
+ );
+-
+-sub MY::postamble {
+- '
+-demo :: pure_all
+- $(FULLPERL) -w -I$(SITELIBEXP)/Tk/demos/widget_lib -I$(SITEARCHEXP)/Tk/demos/widget_lib -Mblib demos/cursor.pl
+-';
+-}
+--
+2.16.2
+
diff --git a/dev-perl/Tk-CursorControl/metadata.xml b/dev-perl/Tk-CursorControl/metadata.xml
new file mode 100644
index 000000000000..eb06c2755e6f
--- /dev/null
+++ b/dev-perl/Tk-CursorControl/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Tk-CursorControl</remote-id>
+ <remote-id type="cpan-module">Tk::CursorControl</remote-id>
+ </upstream>
+</pkgmetadata>