summaryrefslogtreecommitdiff
path: root/dev-perl/Time-Format
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-18 04:54:42 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-18 04:54:42 +0000
commit5510d9d7d1c93c2ea71a2bd6f0666168808d5dd6 (patch)
treec968fff3108e2b4d88e4e564a56bfd066f170573 /dev-perl/Time-Format
parent1dde4e5c4b92d849bf1abf0a48135b2a0644f7e1 (diff)
gentoo resync : 18.03.2018
Diffstat (limited to 'dev-perl/Time-Format')
-rw-r--r--dev-perl/Time-Format/Manifest3
-rw-r--r--dev-perl/Time-Format/Time-Format-1.120.0-r1.ebuild32
-rw-r--r--dev-perl/Time-Format/files/Time-Format-1.12-datetimetest.patch117
-rw-r--r--dev-perl/Time-Format/files/Time-Format-1.12-nosig.patch91
4 files changed, 243 insertions, 0 deletions
diff --git a/dev-perl/Time-Format/Manifest b/dev-perl/Time-Format/Manifest
index b91e0f508686..d8405db27425 100644
--- a/dev-perl/Time-Format/Manifest
+++ b/dev-perl/Time-Format/Manifest
@@ -1,3 +1,6 @@
+AUX Time-Format-1.12-datetimetest.patch 3812 BLAKE2B c693ea0c8cdceb146e83117461e5eaa6c5f19132bc4a63d609c80d40e0a0dfce9388b3528eea559c8ddc422100cc40b0af28209eac0700dcaa368dbe1f9f984d SHA512 8bfbea3da6a97dd5e12a6f9286a96fe2390b01494d2cb321ee5a147b019e0308b386c16432b5578388a12c09674db249ffa5e5dad76fa85f38e7129dedce6b1f
+AUX Time-Format-1.12-nosig.patch 2507 BLAKE2B 86d417983c738e7c526ae78838a40bdf6a499a49e80c89269117014e1cb6b2e547e6a56e7c99b35fe318db55f56116f846104402c99f51ec2c2c68d5efe5cc0a SHA512 13816577ba193d143da3f5b5174f2500c4a529c042a03dda19453fb658c3f65cd12c7b53d062c8447fad58cadb60301eabaaef53c22afcf234b657b38031b662
DIST Time-Format-1.12.tar.gz 38131 BLAKE2B 8d067752e119a8d1ade15dbb96db64ce5b66b435dd3753f5996611372c1d17cea602d92b7852a076acb8d4db16f430ce7a9463ffbef1291a5f20842bfc89fe87 SHA512 16640c5673f6a38768baf7affa8a7595dddee17a25913370cf9ed24fa6f7ad3458d0cab256e731e928ee0f40a072424e64c9c75046db85a5df6876f268f48c9d
+EBUILD Time-Format-1.120.0-r1.ebuild 714 BLAKE2B ce7808eb2a5f30175191d181c2a297218323b40eebb439625d2d45a1f3137a77013bf3b91c694f69fe5b60720ee44345ef3e04359607b84e8832f6ecbf35f71d SHA512 743b96d7160cbb71ec6f49a08304e8629b706e45a648dd8cffdaa3b764d01b46b4c43d7f4e2ab6ce930376ff1ef915a8e64485b7ee82545d847e8c7e2772a230
EBUILD Time-Format-1.120.0.ebuild 569 BLAKE2B 0585a8f5b3fe84dfd225c7c5cdbfbde4a22e65d09e397221d6c278c234e51bc7f551da9f22119cb0796fda8a1409dcffdf44e6d2f50967c6444a5c9ec256690d SHA512 52098d4bb79772a5d7a7254319ba80de09b411fa5fc528dfbfa796142b158d84dd10265c3f28f36b7271da0554094f35a039ea5ee70437e699a65d40c8a5eced
MISC metadata.xml 466 BLAKE2B 347d505a5b39f3a372c36b8bbf996398095633947b199e394a558b08be97b27446f3c85750c2df4248e4a4e4767eb74310ffd7f1f135f75f6ed1bc19245e87a1 SHA512 aeac9778ff3e6602c38ec9c46046f46c7dcc47e03f5fa245ceea7f661d0eaf7d19ede342f21b3754ad19b60465377c39f4666f004c79a448a824a10c0afcfe31
diff --git a/dev-perl/Time-Format/Time-Format-1.120.0-r1.ebuild b/dev-perl/Time-Format/Time-Format-1.120.0-r1.ebuild
new file mode 100644
index 000000000000..a42be47c6766
--- /dev/null
+++ b/dev-perl/Time-Format/Time-Format-1.120.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+DIST_AUTHOR=ROODE
+DIST_VERSION=1.12
+inherit perl-module
+
+DESCRIPTION="Easy-to-use date/time formatting"
+LICENSE="Time-Format"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/Date-Manip
+ >=virtual/perl-Time-Local-1.70.0
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.400.0
+ test? ( >=virtual/perl-Test-Simple-0.400.0 )
+"
+PATCHES=(
+ "${FILESDIR}/${PN}-1.12-datetimetest.patch"
+ "${FILESDIR}/${PN}-1.12-nosig.patch"
+)
+PERL_RM_FILES=( "t/0-signature.t" "SIGNATURE" )
+
+src_configure() {
+ export TZ=UTC # https://rt.cpan.org/Public/Bug/Display.html?id=85001
+ perl-module_src_configure
+}
diff --git a/dev-perl/Time-Format/files/Time-Format-1.12-datetimetest.patch b/dev-perl/Time-Format/files/Time-Format-1.12-datetimetest.patch
new file mode 100644
index 000000000000..b43f685c7b01
--- /dev/null
+++ b/dev-perl/Time-Format/files/Time-Format-1.12-datetimetest.patch
@@ -0,0 +1,117 @@
+From 83aaff839cf3b6788d95a253bb099992b366136d Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Fri, 16 Mar 2018 21:09:54 +1300
+Subject: Disable auto-probes for Date-Manip
+
+These are currently fragile and broken, and ultimately unnecessary
+on Gentoo (because we have the luxury of forcing a TZ, and if
+Date::Manip still doesn't work, that's a bigger bug we care about )
+
+Bug: https://rt.cpan.org/Public/Bug/Display.html?id=85001
+---
+ t/doc.t | 15 ---------------
+ t/funcs.t | 14 --------------
+ t/manip.t | 17 -----------------
+ 3 files changed, 46 deletions(-)
+
+diff --git a/t/doc.t b/t/doc.t
+index c5bfe6f..b9ce2af 100755
+--- a/t/doc.t
++++ b/t/doc.t
+@@ -9,19 +9,6 @@ BEGIN { $Time::Format::NOXS = 1 }
+ BEGIN { use_ok 'Time::Format', qw(:all) }
+ my $tl_notok;
+ BEGIN { $tl_notok = eval('use Time::Local; 1')? 0 : 1 }
+-my $dm_notok;
+-my $dm_notz;
+-BEGIN
+-{
+- $dm_notok = eval('use Date::Manip (); 1')? 0 : 1;
+- unless ($dm_notok)
+- {
+- # If Date::Manip can't determine the time zone, it'll bomb out of the tests.
+- $dm_notz = eval('Date::Manip::Date_TimeZone (); 1')? 0 : 1;
+- }
+- delete $INC{'Date/Manip.pm'};
+- %Date::Manip:: = ();
+-}
+
+ # Were all variables imported? (3)
+ is ref tied %time, 'Time::Format' => '%time imported';
+@@ -83,8 +70,6 @@ SKIP:
+ # manip tests (3)
+ SKIP:
+ {
+- skip 'Date::Manip not available', 3 if $dm_notok;
+- skip 'Date::Manip cannot determine timezone', 3 if $dm_notz;
+ is $manip{'%m/%d/%Y',"epoch $t"}, '06/05/2003' => 'Example 13';
+ is $manip{'%m/%d/%Y','first monday in November 2000'}, '11/06/2000' => 'Example 14';
+ is qq[$time{'yyyymmdd',$manip{'%s',"epoch $t"}}], '20030605' => 'Example 15';
+diff --git a/t/funcs.t b/t/funcs.t
+index 1e5bdb6..88f3fdc 100755
+--- a/t/funcs.t
++++ b/t/funcs.t
+@@ -13,18 +13,6 @@ BEGIN {
+ delete $INC{'POSIX.pm'};
+ %POSIX:: = ();
+ }
+-my $manip_bad;
+-my $manip_notz;
+-BEGIN {
+- $manip_bad = eval('use Date::Manip (); 1')? 0 : 1;
+- unless ($manip_bad)
+- {
+- # If Date::Manip can't determine the time zone, it'll bomb out of the tests.
+- $manip_notz = eval ('Date::Manip::Date_TimeZone (); 1')? 0 : 1;
+- }
+- delete $INC{'Date/Manip.pm'};
+- %Date::Manip:: = ();
+-}
+
+ # Get day/month names in current locale
+ my ($Thursday, $Thu, $June, $Jun);
+@@ -71,8 +59,6 @@ SKIP:
+ # time_manip tests (6)
+ SKIP:
+ {
+- skip 'Date::Manip not available', 6 if $manip_bad;
+- skip 'Date::Manip cannot determine timezone', 6 if $manip_notz;
+ my $m = 'first thursday in june 2003';
+ is time_manip('%Y',$m), '2003' => 'year';
+ is time_manip('%d',$m), '05' => 'day of month';
+diff --git a/t/manip.t b/t/manip.t
+index 763ad59..6f94607 100755
+--- a/t/manip.t
++++ b/t/manip.t
+@@ -5,28 +5,11 @@ use Test::More tests => 6;
+
+ BEGIN { $Time::Format::NOXS = 1 }
+ BEGIN { use_ok 'Time::Format', qw(%manip) }
+-my $manip_bad;
+-BEGIN
+-{
+- unless (eval 'use Date::Manip (); 1')
+- {
+- $manip_bad = 'Date::Manip is not available';
+- }
+- else
+- {
+- # If Date::Manip can't determine the time zone, it'll bomb out of the tests.
+- $manip_bad = 'Date::Manip cannot determine time zone'
+- unless eval 'Date::Manip::Date_TimeZone(); 1';
+- }
+- delete $INC{'Date/Manip.pm'};
+- %Date::Manip:: = ();
+-}
+
+ my $t = 'first thursday in june 2003';
+
+ SKIP:
+ {
+- skip $manip_bad, 5 if $manip_bad;
+ is $manip{'%Y',$t}, '2003' => 'year';
+ is $manip{'%d',$t}, '05' => 'day of month';
+ is $manip{'%D',$t}, '06/05/03' => '%D';
+--
+2.16.2
+
diff --git a/dev-perl/Time-Format/files/Time-Format-1.12-nosig.patch b/dev-perl/Time-Format/files/Time-Format-1.12-nosig.patch
new file mode 100644
index 000000000000..ccb11b849f21
--- /dev/null
+++ b/dev-perl/Time-Format/files/Time-Format-1.12-nosig.patch
@@ -0,0 +1,91 @@
+From 24b17d6a4787db19888cda208197539c324b257f Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Fri, 16 Mar 2018 21:18:37 +1300
+Subject: Kill signature code
+
+Invalidated anyway due to other patches, and non-critical on Gentoo
+due to many other layers of integrity checks.
+---
+ Build.PL | 2 --
+ MANIFEST | 3 ---
+ META.json | 1 -
+ META.yml | 1 -
+ Makefile.PL | 1 -
+ SIGNATURE | 59 ---------------------------------------------------------
+ t/0-signature.t | 26 -------------------------
+ 7 files changed, 93 deletions(-)
+ delete mode 100644 SIGNATURE
+ delete mode 100755 t/0-signature.t
+
+diff --git a/Build.PL b/Build.PL
+index faed77f..6541305 100755
+--- a/Build.PL
++++ b/Build.PL
+@@ -29,9 +29,7 @@ my $builder = Module::Build->new(
+ 'Time::HiRes' => 0,
+ 'DateTime' => 0,
+ 'Date::Manip' => 0,
+- 'Module::Signature' => 0,
+ },
+- sign => 1,
+ add_to_cleanup => [ 'Time-Format-*' ],
+ );
+
+diff --git a/MANIFEST b/MANIFEST
+index e1aeeb9..fd31290 100755
+--- a/MANIFEST
++++ b/MANIFEST
+@@ -6,11 +6,9 @@ META.json
+ META.yml
+ Makefile.PL
+ README
+-SIGNATURE
+ lib/Time/Format.pm
+ quickref.ps
+ quickref.txt
+-t/0-signature.t
+ t/1-load.t
+ t/DateManip.t
+ t/DateTime.t
+@@ -35,4 +33,3 @@ t/xs_funcs.t
+ t/xs_locale.t
+ t/xs_quot.t
+ t/xs_time.t
+-SIGNATURE Added here by Module::Build
+diff --git a/META.json b/META.json
+index cdfee24..e57c760 100644
+--- a/META.json
++++ b/META.json
+@@ -29,7 +29,6 @@
+ "Date::Manip" : 0,
+ "DateTime" : 0,
+ "I18N::Langinfo" : 0,
+- "Module::Signature" : 0,
+ "POSIX" : 0,
+ "Time::HiRes" : 0
+ },
+diff --git a/META.yml b/META.yml
+index 2efa55e..318c0ff 100644
+--- a/META.yml
++++ b/META.yml
+@@ -21,7 +21,6 @@ recommends:
+ Date::Manip: 0
+ DateTime: 0
+ I18N::Langinfo: 0
+- Module::Signature: 0
+ POSIX: 0
+ Time::HiRes: 0
+ requires:
+diff --git a/Makefile.PL b/Makefile.PL
+index 7d3059e..14903ab 100755
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -13,5 +13,4 @@ WriteMakefile (
+ ($] >= 5.005 ? ## Add these new keywords supported since 5.005
+ (ABSTRACT_FROM => 'lib/Time/Format.pm', # retrieve abstract from module
+ AUTHOR => 'Eric Roode <roode@cpan.org>') : ()),
+- (MM->can('signature_target')? (SIGN => 1) : ()),
+ );
+--
+2.16.2
+