summaryrefslogtreecommitdiff
path: root/dev-perl/TheSchwartz
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/TheSchwartz
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/TheSchwartz')
-rw-r--r--dev-perl/TheSchwartz/Manifest4
-rw-r--r--dev-perl/TheSchwartz/TheSchwartz-1.120.0-r1.ebuild22
-rw-r--r--dev-perl/TheSchwartz/files/TheSchwartz-1.12-no-dot-inc.patch342
-rw-r--r--dev-perl/TheSchwartz/metadata.xml18
4 files changed, 386 insertions, 0 deletions
diff --git a/dev-perl/TheSchwartz/Manifest b/dev-perl/TheSchwartz/Manifest
new file mode 100644
index 000000000000..87e4ce2ae904
--- /dev/null
+++ b/dev-perl/TheSchwartz/Manifest
@@ -0,0 +1,4 @@
+AUX TheSchwartz-1.12-no-dot-inc.patch 8095 BLAKE2B d8c40697d7d2d10406672f7312b090dedfd97b33f86b76a879fe8b775f0ab0c00e71d1f9e4ba75733be16fefb3e1212d6c23739271bd476823c2b9ade8c3f8e8 SHA512 15e2b5ce6de9b3eb24997086266e515c2a6af480289529a15210b54e5478f11ebc960ec5f33d6b40c6654afd777e40a8ee765cf5d63ff48e7a80ad9aaa0a1e71
+DIST TheSchwartz-1.12.tar.gz 55047 BLAKE2B ebf7563203790dd1ecf7c026cefb2027bf1aa5e1af46200617625d48f6327338f08606ea47d21a474b35331eacd00b03c0924bfc9d28e6cc9f72fe5f96ca2007 SHA512 87c691c6aee0603a68d4116e9254308331974042d8578d6df086bc6f0f07783d757951f8c3a35227b9d716e94ccecbcea1f92ab488005384c2caf2ba9aecae59
+EBUILD TheSchwartz-1.120.0-r1.ebuild 468 BLAKE2B 865de268cd57439ff44116d9ddd9cdef909b24f0e4f1ab3e7276bee6f9acf8c47256a50166c16e3e51a656d7b71e48b4b9019b5b08aaef0f2ef79529087c86ae SHA512 933f58bde826691d6bb9496d64eb7217b05b858f277d96e87ea4aa1641d0fbe7d3b90910448c018540dc77f296a869a28368eb9e025288498b58ff6f263a9228
+MISC metadata.xml 793 BLAKE2B 833d246051d0a4c1c094266028e4cbae7c462312f4535c885f6df3a83e6eecbebf378806076f4701f4e047e93812b84e75f591ee6968650baa681daa5d86177f SHA512 eeeebf27c8f69b20091c316ab7fe4e91f0ea335b8fd3da4db16638aa25c7cc5e77d66bca46287ad6f7a232918209b24a30350186c935beebf7624b6d93375344
diff --git a/dev-perl/TheSchwartz/TheSchwartz-1.120.0-r1.ebuild b/dev-perl/TheSchwartz/TheSchwartz-1.120.0-r1.ebuild
new file mode 100644
index 000000000000..89a4a378e57e
--- /dev/null
+++ b/dev-perl/TheSchwartz/TheSchwartz-1.120.0-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=JFEARN
+DIST_VERSION=1.12
+inherit perl-module
+
+DESCRIPTION="Reliable job queue"
+
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE=""
+
+RDEPEND=">=dev-perl/Data-ObjectDriver-0.06"
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+"
+PATCHES=( "${FILESDIR}/${PN}-1.12-no-dot-inc.patch" )
+# Parallel tests fail due to database ordering issues
+DIST_TEST="do"
diff --git a/dev-perl/TheSchwartz/files/TheSchwartz-1.12-no-dot-inc.patch b/dev-perl/TheSchwartz/files/TheSchwartz-1.12-no-dot-inc.patch
new file mode 100644
index 000000000000..fefd0ffd1a51
--- /dev/null
+++ b/dev-perl/TheSchwartz/files/TheSchwartz-1.12-no-dot-inc.patch
@@ -0,0 +1,342 @@
+From 6c9a65ff8a2c896e7359d9b2da47fc8836c5dfe9 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Wed, 28 Feb 2018 08:34:19 +1300
+Subject: Fix test failures on 5.26+ due to removal of '.' from @INC
+
+'.' not being in @INC means `require "foo"` no longer implies
+`require "./foo"` will occur as a result of @INC traversal.
+
+This changes to use explicit paths ( ie: paths with a leading '/'
+ or './' ) which disables @INC traversal and restores expected
+semantics.
+
+Bug: https://rt.cpan.org/Ticket/Display.html?id=124610
+Bug: https://bugs.gentoo.org/623128
+---
+ t/api.t | 2 +-
+ t/cleanup.t | 2 +-
+ t/client-time-unsync.t | 2 +-
+ t/coalesce.t | 2 +-
+ t/dead-dbs.t | 2 +-
+ t/declined.t | 2 +-
+ t/empty-db.t | 2 +-
+ t/evenly-distribute.t | 2 +-
+ t/fail-working-multiple.t | 2 +-
+ t/funcid.t | 2 +-
+ t/grab-race.t | 2 +-
+ t/grab_and_work_on.t | 2 +-
+ t/high-funcid-starvation.t | 2 +-
+ t/insert-and-do.t | 2 +-
+ t/parallel-workers.t | 2 +-
+ t/priority.t | 2 +-
+ t/replace-abort.t | 2 +-
+ t/replace-with.t | 2 +-
+ t/retry-delay.t | 2 +-
+ t/scoreboard.t | 2 +-
+ t/server-time.t | 2 +-
+ t/unique.t | 2 +-
+ t/work-before-funcids-exist.t | 2 +-
+ 23 files changed, 23 insertions(+), 23 deletions(-)
+
+diff --git a/t/api.t b/t/api.t
+index 9d4d177..fb9c7b2 100644
+--- a/t/api.t
++++ b/t/api.t
+@@ -4,7 +4,7 @@
+ use strict;
+ use warnings;
+
+-require 't/lib/db-common.pl';
++require './t/lib/db-common.pl';
+
+ use TheSchwartz;
+ use Test::More tests => 58 * 3;
+diff --git a/t/cleanup.t b/t/cleanup.t
+index 034dc59..f13f23f 100644
+--- a/t/cleanup.t
++++ b/t/cleanup.t
+@@ -3,7 +3,7 @@
+ use strict;
+ use warnings;
+
+-require 't/lib/db-common.pl';
++require './t/lib/db-common.pl';
+
+ use TheSchwartz;
+ use Test::More tests => 30;
+diff --git a/t/client-time-unsync.t b/t/client-time-unsync.t
+index fa19a85..fd10047 100644
+--- a/t/client-time-unsync.t
++++ b/t/client-time-unsync.t
+@@ -17,7 +17,7 @@ BEGIN {
+ }
+ no warnings 'redefine';
+
+-require 't/lib/db-common.pl';
++require './t/lib/db-common.pl';
+
+ use TheSchwartz;
+ use Test::More tests => 2;
+diff --git a/t/coalesce.t b/t/coalesce.t
+index b42f732..0c152f4 100644
+--- a/t/coalesce.t
++++ b/t/coalesce.t
+@@ -3,7 +3,7 @@
+ use strict;
+ use warnings;
+
+-require 't/lib/db-common.pl';
++require './t/lib/db-common.pl';
+
+ use TheSchwartz;
+ use Test::More tests => 14 * 3;
+diff --git a/t/dead-dbs.t b/t/dead-dbs.t
+index eee73a6..673f5b4 100644
+--- a/t/dead-dbs.t
++++ b/t/dead-dbs.t
+@@ -4,7 +4,7 @@
+ use strict;
+ use warnings;
+
+-require 't/lib/db-common.pl';
++require './t/lib/db-common.pl';
+
+ use TheSchwartz;
+ use Test::More tests => 6;
+diff --git a/t/declined.t b/t/declined.t
+index 8fca90d..78dca2f 100644
+--- a/t/declined.t
++++ b/t/declined.t
+@@ -1,7 +1,7 @@
+ use strict;
+ use warnings;
+
+-require 't/lib/db-common.pl';
++require './t/lib/db-common.pl';
+
+ use TheSchwartz;
+ use Test::More tests => (5 + 21) * 3;
+diff --git a/t/empty-db.t b/t/empty-db.t
+index 17353cd..6fc9bc1 100644
+--- a/t/empty-db.t
++++ b/t/empty-db.t
+@@ -4,7 +4,7 @@
+ use strict;
+ use warnings;
+
+-require 't/lib/db-common.pl';
++require './t/lib/db-common.pl';
+
+ use TheSchwartz;
+ use Test::More tests => 9;
+diff --git a/t/evenly-distribute.t b/t/evenly-distribute.t
+index 56533f0..3fc9082 100644
+--- a/t/evenly-distribute.t
++++ b/t/evenly-distribute.t
+@@ -4,7 +4,7 @@
+ use strict;
+ use warnings;
+
+-require 't/lib/db-common.pl';
++require './t/lib/db-common.pl';
+
+ use TheSchwartz;
+ use Test::More tests => 12;
+diff --git a/t/fail-working-multiple.t b/t/fail-working-multiple.t
+index 3750fc7..94f07f7 100644
+--- a/t/fail-working-multiple.t
++++ b/t/fail-working-multiple.t
+@@ -3,7 +3,7 @@
+ use strict;
+ use warnings;
+
+-require 't/lib/db-common.pl';
++require './t/lib/db-common.pl';
+
+ use TheSchwartz;
+ use Test::More tests => 12;
+diff --git a/t/funcid.t b/t/funcid.t
+index f363791..60510ba 100644
+--- a/t/funcid.t
++++ b/t/funcid.t
+@@ -4,7 +4,7 @@
+ use strict;
+ use warnings;
+
+-require 't/lib/db-common.pl';
++require './t/lib/db-common.pl';
+
+ use TheSchwartz;
+ use Test::More tests => 24;
+diff --git a/t/grab-race.t b/t/grab-race.t
+index 1071362..efcdff8 100644
+--- a/t/grab-race.t
++++ b/t/grab-race.t
+@@ -4,7 +4,7 @@
+ use strict;
+ use warnings;
+
+-require 't/lib/db-common.pl';
++require './t/lib/db-common.pl';
+
+ use TheSchwartz;
+ use Test::More tests => 2;
+diff --git a/t/grab_and_work_on.t b/t/grab_and_work_on.t
+index 7f7628e..be99827 100644
+--- a/t/grab_and_work_on.t
++++ b/t/grab_and_work_on.t
+@@ -3,7 +3,7 @@
+ use strict;
+ use warnings;
+
+-require 't/lib/db-common.pl';
++require './t/lib/db-common.pl';
+
+ use TheSchwartz;
+ use Test::More tests => 27;
+diff --git a/t/high-funcid-starvation.t b/t/high-funcid-starvation.t
+index 8469e9d..c879049 100644
+--- a/t/high-funcid-starvation.t
++++ b/t/high-funcid-starvation.t
+@@ -4,7 +4,7 @@
+ use strict;
+ use warnings;
+
+-require 't/lib/db-common.pl';
++require './t/lib/db-common.pl';
+
+ use TheSchwartz;
+ use Test::More tests => 12;
+diff --git a/t/insert-and-do.t b/t/insert-and-do.t
+index f6cc9f9..662abbd 100644
+--- a/t/insert-and-do.t
++++ b/t/insert-and-do.t
+@@ -3,7 +3,7 @@
+ use strict;
+ use warnings;
+
+-require 't/lib/db-common.pl';
++require './t/lib/db-common.pl';
+
+ use TheSchwartz;
+ use Test::More tests => 26 * 3;
+diff --git a/t/parallel-workers.t b/t/parallel-workers.t
+index 1834041..5300385 100644
+--- a/t/parallel-workers.t
++++ b/t/parallel-workers.t
+@@ -4,7 +4,7 @@
+ use strict;
+ use warnings;
+
+-require 't/lib/db-common.pl';
++require './t/lib/db-common.pl';
+
+ use TheSchwartz;
+ use Test::More tests => 2;
+diff --git a/t/priority.t b/t/priority.t
+index b6e1208..3ce6c6e 100644
+--- a/t/priority.t
++++ b/t/priority.t
+@@ -3,7 +3,7 @@
+ use strict;
+ use warnings;
+
+-require 't/lib/db-common.pl';
++require './t/lib/db-common.pl';
+
+ use TheSchwartz;
+ use Test::More tests => ( ( 31 * 3 ) + ( 16 * 3 ) + ( 12 * 3 ) );
+diff --git a/t/replace-abort.t b/t/replace-abort.t
+index 86d70f0..252bfb0 100644
+--- a/t/replace-abort.t
++++ b/t/replace-abort.t
+@@ -3,7 +3,7 @@
+ use strict;
+ use warnings;
+
+-require 't/lib/db-common.pl';
++require './t/lib/db-common.pl';
+
+ use TheSchwartz;
+ use Test::More tests => 13;
+diff --git a/t/replace-with.t b/t/replace-with.t
+index f9e7978..6887988 100644
+--- a/t/replace-with.t
++++ b/t/replace-with.t
+@@ -3,7 +3,7 @@
+ use strict;
+ use warnings;
+
+-require 't/lib/db-common.pl';
++require './t/lib/db-common.pl';
+
+ use TheSchwartz;
+ use Test::More tests => 30;
+diff --git a/t/retry-delay.t b/t/retry-delay.t
+index 27c5663..fdda944 100644
+--- a/t/retry-delay.t
++++ b/t/retry-delay.t
+@@ -4,7 +4,7 @@
+ use strict;
+ use warnings;
+
+-require 't/lib/db-common.pl';
++require './t/lib/db-common.pl';
+
+ use TheSchwartz;
+ use Test::More tests => 24;
+diff --git a/t/scoreboard.t b/t/scoreboard.t
+index c19a9d8..bc197d0 100644
+--- a/t/scoreboard.t
++++ b/t/scoreboard.t
+@@ -3,7 +3,7 @@
+ use strict;
+ use warnings;
+
+-require 't/lib/db-common.pl';
++require './t/lib/db-common.pl';
+
+ use Test::More tests => 30;
+
+diff --git a/t/server-time.t b/t/server-time.t
+index 870ab8e..47ded3a 100644
+--- a/t/server-time.t
++++ b/t/server-time.t
+@@ -3,7 +3,7 @@
+ use strict;
+ use warnings;
+
+-require 't/lib/db-common.pl';
++require './t/lib/db-common.pl';
+
+ use TheSchwartz;
+ use Test::More tests => 6;
+diff --git a/t/unique.t b/t/unique.t
+index f0bcea5..e013a32 100644
+--- a/t/unique.t
++++ b/t/unique.t
+@@ -4,7 +4,7 @@
+ use strict;
+ use warnings;
+
+-require 't/lib/db-common.pl';
++require './t/lib/db-common.pl';
+
+ use TheSchwartz;
+ use Test::More tests => 18;
+diff --git a/t/work-before-funcids-exist.t b/t/work-before-funcids-exist.t
+index 9c06e43..17efbbc 100644
+--- a/t/work-before-funcids-exist.t
++++ b/t/work-before-funcids-exist.t
+@@ -4,7 +4,7 @@
+ use strict;
+ use warnings;
+
+-require 't/lib/db-common.pl';
++require './t/lib/db-common.pl';
+
+ use TheSchwartz;
+ use Test::More tests => 6;
+--
+2.15.1
+
diff --git a/dev-perl/TheSchwartz/metadata.xml b/dev-perl/TheSchwartz/metadata.xml
new file mode 100644
index 000000000000..f57da2dce378
--- /dev/null
+++ b/dev-perl/TheSchwartz/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">TheSchwartz</remote-id>
+ <remote-id type="cpan-module">TheSchwartz</remote-id>
+ <remote-id type="cpan-module">TheSchwartz::Error</remote-id>
+ <remote-id type="cpan-module">TheSchwartz::ExitStatus</remote-id>
+ <remote-id type="cpan-module">TheSchwartz::FuncMap</remote-id>
+ <remote-id type="cpan-module">TheSchwartz::Job</remote-id>
+ <remote-id type="cpan-module">TheSchwartz::JobHandle</remote-id>
+ <remote-id type="cpan-module">TheSchwartz::Worker</remote-id>
+ </upstream>
+</pkgmetadata>