summaryrefslogtreecommitdiff
path: root/dev-perl/Text-Autoformat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/Text-Autoformat
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/Text-Autoformat')
-rw-r--r--dev-perl/Text-Autoformat/Manifest4
-rw-r--r--dev-perl/Text-Autoformat/Text-Autoformat-1.740.0.ebuild29
-rw-r--r--dev-perl/Text-Autoformat/metadata.xml14
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-perl/Text-Autoformat/Manifest b/dev-perl/Text-Autoformat/Manifest
new file mode 100644
index 000000000000..6d678e4d628b
--- /dev/null
+++ b/dev-perl/Text-Autoformat/Manifest
@@ -0,0 +1,4 @@
+DIST Text-Autoformat-1.74.tar.gz 29485 SHA256 07eb3c2b3515897340ca6e9377495bbe2e05ec80d7f3f146adab8e534a818d5e SHA512 276e97a0db20032919a6aeacba701350fa8fadf6c1bda7dcda714ef4f1c168b8cc3150a126719d940194c8b20dd534543ec914f03c50e27e4a61b1083ca312c6 WHIRLPOOL 3a855e8c987ed5ad756c98e921370a29ef89ed830db8c8d1e69a431c1cc414d5ba1edc0169c780c9eed880200a70e7c44696bd45fa22de695fabdd0c305948e9
+EBUILD Text-Autoformat-1.740.0.ebuild 720 SHA256 e596ef89b9c26f96d65b496bc98ac35ca4b8e03d098b5c5ac001dbf6190cfc2e SHA512 6cd8fc71132013aef9d73b6953464fadbb49bc629aec4663a184a5e0cda1d80a04f004029d7cd6e04a904c3c58dfbc4490fafae440b9908f4d90da848834e8fc WHIRLPOOL bffb72c8b0d1283afa5b827472ee310f905fccbaab6f5627575c6e91d01ccea4a0ec7b499b525faf3b90d95374f6c1c89a4e49dea3d6aab5bfc0822d72033d3f
+MISC ChangeLog 2614 SHA256 4afffae36d84851e9a81efde217caa21ce0236a762207bf1a6a3ef96b1e2ecce SHA512 634f6d423e614689fc4e370b067b01989b3ee50c79b9c09f85f75e6c90c0b4eee4027a7f942892ee105c8590bc6a969aef924083725637603f26a8d1ec76fc9d WHIRLPOOL 942097ce18025e790d7b3a82fe504fcf37f5922e34dea1008ba0956c94f637bf08e62ca941e74ac3551f5cfd9de45840bcb2d5919c7aa4ddfb1446c37a0cdc3b
+MISC metadata.xml 544 SHA256 2f6db8d0325a8a1d72c5df22cc15339ea0508b57f755a988bb7f0abe80e4a2e2 SHA512 1c8c5fd5304c9d939e9493a79052165953277cad6f7d9d0073583eb15549285b73d868dec19b71a19bc0e1dd41576f226efd499521ac939b76068c415d70dc1d WHIRLPOOL 242b429eac85ef532422ea9da4d8d6fca818c5ed9cdeb2bbddc00098cb4c1afa186cffa01fa488bc6333b6dbeba9d9f6a6b164886c589ae645d777361d1529a2
diff --git a/dev-perl/Text-Autoformat/Text-Autoformat-1.740.0.ebuild b/dev-perl/Text-Autoformat/Text-Autoformat-1.740.0.ebuild
new file mode 100644
index 000000000000..915b46b72fe6
--- /dev/null
+++ b/dev-perl/Text-Autoformat/Text-Autoformat-1.740.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=NEILB
+DIST_VERSION=1.74
+inherit perl-module
+
+DESCRIPTION="Automatic text wrapping and reformatting"
+
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 sparc x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="test examples"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Exporter
+ dev-perl/Text-Reform
+ virtual/perl-Text-Tabs+Wrap
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( >=virtual/perl-Test-Simple-0.880.0 )
+"
+src_install() {
+ perl-module_src_install
+ use examples && perl_doexamples "config.emacs" "config.vim"
+}
diff --git a/dev-perl/Text-Autoformat/metadata.xml b/dev-perl/Text-Autoformat/metadata.xml
new file mode 100644
index 000000000000..6bc30a05b4c6
--- /dev/null
+++ b/dev-perl/Text-Autoformat/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Text-Autoformat</remote-id>
+ <remote-id type="cpan-module">Text::Autoformat</remote-id>
+ <remote-id type="cpan-module">Text::Autoformat::Hang</remote-id>
+ <remote-id type="cpan-module">Text::Autoformat::NullHang</remote-id>
+ </upstream>
+</pkgmetadata>