summaryrefslogtreecommitdiff
path: root/dev-perl/Test-MockModule/Test-MockModule-0.110.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/Test-MockModule/Test-MockModule-0.110.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/Test-MockModule/Test-MockModule-0.110.0.ebuild')
-rw-r--r--dev-perl/Test-MockModule/Test-MockModule-0.110.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/Test-MockModule/Test-MockModule-0.110.0.ebuild b/dev-perl/Test-MockModule/Test-MockModule-0.110.0.ebuild
new file mode 100644
index 000000000000..7ac25c5da5ed
--- /dev/null
+++ b/dev-perl/Test-MockModule/Test-MockModule-0.110.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_VERSION=0.11
+DIST_AUTHOR=GFRANKS
+inherit perl-module
+
+DESCRIPTION="Override subroutines in a module for unit testing"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris
+~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/SUPER
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.380.0
+ test? ( >=virtual/perl-Test-Simple-0.450.0 )
+"
+src_test() {
+ perl_rm_files t/pod_coverage.t t/pod.t
+ perl-module_src_test
+}