summaryrefslogtreecommitdiff
path: root/dev-perl/Test-Mock-LWP-Dispatch/Test-Mock-LWP-Dispatch-0.80.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/Test-Mock-LWP-Dispatch/Test-Mock-LWP-Dispatch-0.80.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/Test-Mock-LWP-Dispatch/Test-Mock-LWP-Dispatch-0.80.0.ebuild')
-rw-r--r--dev-perl/Test-Mock-LWP-Dispatch/Test-Mock-LWP-Dispatch-0.80.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/Test-Mock-LWP-Dispatch/Test-Mock-LWP-Dispatch-0.80.0.ebuild b/dev-perl/Test-Mock-LWP-Dispatch/Test-Mock-LWP-Dispatch-0.80.0.ebuild
new file mode 100644
index 000000000000..a03a4036920e
--- /dev/null
+++ b/dev-perl/Test-Mock-LWP-Dispatch/Test-Mock-LWP-Dispatch-0.80.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=TADAM
+DIST_VERSION=0.08
+inherit perl-module
+
+DESCRIPTION="Mocks LWP::UserAgent and dispatches your requests/responses"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Data-Dumper
+ virtual/perl-Exporter
+ dev-perl/HTTP-Message
+ dev-perl/libwww-perl
+ dev-perl/Test-MockObject
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.300.0
+ test? (
+ virtual/perl-File-Spec
+ dev-perl/Test-Exception
+ )
+"
+src_test() {
+ perl_rm_files t/release-pod-coverage.t t/release-pod-syntax.t
+ perl-module_src_test
+}