summaryrefslogtreecommitdiff
path: root/dev-perl/Test-Memory-Cycle/Test-Memory-Cycle-1.60.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Test-Memory-Cycle/Test-Memory-Cycle-1.60.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Test-Memory-Cycle/Test-Memory-Cycle-1.60.0.ebuild')
-rw-r--r--dev-perl/Test-Memory-Cycle/Test-Memory-Cycle-1.60.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/Test-Memory-Cycle/Test-Memory-Cycle-1.60.0.ebuild b/dev-perl/Test-Memory-Cycle/Test-Memory-Cycle-1.60.0.ebuild
new file mode 100644
index 000000000000..9e4aeccff560
--- /dev/null
+++ b/dev-perl/Test-Memory-Cycle/Test-Memory-Cycle-1.60.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=PETDANCE
+DIST_VERSION=1.06
+inherit perl-module
+
+DESCRIPTION="Check for memory leaks and circular memory references"
+
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="
+ >=dev-perl/Devel-Cycle-1.70.0
+ virtual/perl-Getopt-Long
+ dev-perl/PadWalker
+ >=virtual/perl-Test-Simple-0.620.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+src_test() {
+ perl_rm_files t/pod-coverage.t t/pod.t
+ perl-module_src_test
+}