summaryrefslogtreecommitdiff
path: root/dev-perl/Test-Manifest/Test-Manifest-2.22.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-21 23:14:26 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-21 23:14:26 +0100
commit7c59acba5699c9c58090a7a738669669a7307023 (patch)
treed51d27d020895a6b7a3298d9d1b9846c1fcb59a0 /dev-perl/Test-Manifest/Test-Manifest-2.22.0.ebuild
parente2db47eaae00ec33f8971db44b68645c5d3b9590 (diff)
gentoo resync : 21.08.2021
Diffstat (limited to 'dev-perl/Test-Manifest/Test-Manifest-2.22.0.ebuild')
-rw-r--r--dev-perl/Test-Manifest/Test-Manifest-2.22.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-perl/Test-Manifest/Test-Manifest-2.22.0.ebuild b/dev-perl/Test-Manifest/Test-Manifest-2.22.0.ebuild
new file mode 100644
index 000000000000..f274d3497bb4
--- /dev/null
+++ b/dev-perl/Test-Manifest/Test-Manifest-2.22.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=BDFOY
+DIST_VERSION=2.022
+inherit perl-module
+
+DESCRIPTION="Interact with a t/test_manifest file"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+LICENSE="Artistic-2"
+
+RDEPEND="
+ virtual/perl-File-Spec
+ virtual/perl-Test-Harness
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.640.0
+ test? (
+ virtual/perl-File-Temp
+ >=virtual/perl-Test-Simple-1.0.0
+ )
+"
+
+src_test() {
+ # Ugh, Upstream has tests that depend on tests ...
+ echo 'print qq[1..1\nok 1];' > "${S}/t/99pod.t"
+ echo 'print qq[1..1\nok 1];' > "${S}/t/pod_coverage.t"
+ perl-module_src_test
+}