summaryrefslogtreecommitdiff
path: root/dev-perl/Test-Kit/Test-Kit-2.150.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-perl/Test-Kit/Test-Kit-2.150.0.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-perl/Test-Kit/Test-Kit-2.150.0.ebuild')
-rw-r--r--dev-perl/Test-Kit/Test-Kit-2.150.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-perl/Test-Kit/Test-Kit-2.150.0.ebuild b/dev-perl/Test-Kit/Test-Kit-2.150.0.ebuild
new file mode 100644
index 000000000000..4f05bb88b805
--- /dev/null
+++ b/dev-perl/Test-Kit/Test-Kit-2.150.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=KAORU
+DIST_VERSION=2.15
+inherit perl-module
+
+DESCRIPTION="Build custom test packages with only the features you want"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+RDEPEND="
+ virtual/perl-Exporter
+ dev-perl/Hook-LexWrap
+ dev-perl/Import-Into
+ dev-perl/Module-Runtime
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Sub-Delete
+ virtual/perl-Test-Simple
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Test-Exception
+ dev-perl/Test-NoWarnings
+ dev-perl/Test-Output
+ >=virtual/perl-Test-Simple-0.920.0
+ dev-perl/Test-Warn
+ )
+"
+PERL_RM_FILES=(
+ "t/author-pod-syntax.t"
+ "t/release-cpan-changes.t"
+)