summaryrefslogtreecommitdiff
path: root/dev-perl/Test-FailWarnings/Test-FailWarnings-0.8.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-21 23:14:26 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-21 23:14:26 +0100
commit7c59acba5699c9c58090a7a738669669a7307023 (patch)
treed51d27d020895a6b7a3298d9d1b9846c1fcb59a0 /dev-perl/Test-FailWarnings/Test-FailWarnings-0.8.0-r2.ebuild
parente2db47eaae00ec33f8971db44b68645c5d3b9590 (diff)
gentoo resync : 21.08.2021
Diffstat (limited to 'dev-perl/Test-FailWarnings/Test-FailWarnings-0.8.0-r2.ebuild')
-rw-r--r--dev-perl/Test-FailWarnings/Test-FailWarnings-0.8.0-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/Test-FailWarnings/Test-FailWarnings-0.8.0-r2.ebuild b/dev-perl/Test-FailWarnings/Test-FailWarnings-0.8.0-r2.ebuild
new file mode 100644
index 000000000000..38254a409686
--- /dev/null
+++ b/dev-perl/Test-FailWarnings/Test-FailWarnings-0.8.0-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=DAGOLDEN
+DIST_VERSION=0.008
+inherit perl-module
+
+DESCRIPTION="Add test failures if warnings are caught"
+
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+LICENSE="Apache-2.0"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-File-Spec
+ >=virtual/perl-Test-Simple-0.860.0
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=dev-perl/Capture-Tiny-0.120.0
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ virtual/perl-IO
+ virtual/perl-Scalar-List-Utils
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"