summaryrefslogtreecommitdiff
path: root/dev-perl/Test-Compile
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-perl/Test-Compile
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-perl/Test-Compile')
-rw-r--r--dev-perl/Test-Compile/Manifest3
-rw-r--r--dev-perl/Test-Compile/Test-Compile-2.4.1.ebuild42
-rw-r--r--dev-perl/Test-Compile/metadata.xml13
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-perl/Test-Compile/Manifest b/dev-perl/Test-Compile/Manifest
new file mode 100644
index 000000000000..cceb8e189db9
--- /dev/null
+++ b/dev-perl/Test-Compile/Manifest
@@ -0,0 +1,3 @@
+DIST Test-Compile-v2.4.1.tar.gz 18425 BLAKE2B 604626b07772241f0ab306b06de70223a25673fe944e66c1c031dfe0e55610f7ce1cc0222bfc839331b2f10bd63168100b9e07b1013dc8ca96d03bd53848d3dd SHA512 e6878fa16544be75581144d125f547a799cc79210b925b86f07ad236395026bdc197c22af1820e893f5887e53933f0ba827377ae133752f63076cb436b624aee
+EBUILD Test-Compile-2.4.1.ebuild 798 BLAKE2B 9437a5ec66ca974a1895f2668c2053a3b02bbcb23eee354760611e03ea3cb825332815a4b92566d82e3be6067705ae3e1b9cd1cc59c687a1473f30a0a3538d01 SHA512 e5d4bd361c8b7a634291846bcadc0df0e84011f227c8a29e0bb9d930a4c369efd018a13b216652926cac21519639a10cb976ad884973c9412a81051512ffaf5d
+MISC metadata.xml 466 BLAKE2B d130f7563653c0c2ece62d8550ab310763c769b34bf3629df95c6a74fcdf62d6522c4643525119057fc6fd29af904a26f5711f8d991980fb62a766b7ac43ed8c SHA512 a5ebc2d397ea684f950030e00f144fff6832b9adcd5b84a8f743622b0629c6c4cf96f2c6da58b850650b770906f48eba4ef032fb10d51de3c5e6a28c85547e10
diff --git a/dev-perl/Test-Compile/Test-Compile-2.4.1.ebuild b/dev-perl/Test-Compile/Test-Compile-2.4.1.ebuild
new file mode 100644
index 000000000000..92cdc20fcc54
--- /dev/null
+++ b/dev-perl/Test-Compile/Test-Compile-2.4.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=EGILES
+DIST_VERSION=v2.4.1
+inherit perl-module
+
+DESCRIPTION="Check whether Perl files compile correctly"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !minimal? (
+ dev-perl/Devel-CheckOS
+ )
+ >=virtual/perl-Exporter-5.680.0
+ dev-perl/UNIVERSAL-require
+ >=virtual/perl-parent-0.225.0
+ virtual/perl-version
+"
+DEPEND="dev-perl/Module-Build"
+BDEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.380.0
+ test? (
+ dev-perl/Test-Exception
+ dev-perl/Test-Warnings
+ virtual/perl-Test-Simple
+ )
+"
+PERL_RM_FILES=(
+ t/999-has-version.t
+ t/999-perlcritic.t
+ t/999-pod-coverage.t
+ t/999-pod.t
+ t/999-portability.t
+ t/999-synopsis.t
+ t/999-version.t
+)
diff --git a/dev-perl/Test-Compile/metadata.xml b/dev-perl/Test-Compile/metadata.xml
new file mode 100644
index 000000000000..205627648151
--- /dev/null
+++ b/dev-perl/Test-Compile/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Test-Compile</remote-id>
+ <remote-id type="cpan-module">Test::Compile</remote-id>
+ <remote-id type="cpan-module">Test::Compile::Internal</remote-id>
+ </upstream>
+</pkgmetadata>