summaryrefslogtreecommitdiff
path: root/dev-perl/Term-Table/Term-Table-0.15.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /dev-perl/Term-Table/Term-Table-0.15.0.ebuild
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'dev-perl/Term-Table/Term-Table-0.15.0.ebuild')
-rw-r--r--dev-perl/Term-Table/Term-Table-0.15.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/Term-Table/Term-Table-0.15.0.ebuild b/dev-perl/Term-Table/Term-Table-0.15.0.ebuild
new file mode 100644
index 000000000000..6ab00ebad544
--- /dev/null
+++ b/dev-perl/Term-Table/Term-Table-0.15.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=EXODIST
+DIST_VERSION=0.015
+inherit perl-module optfeature
+
+DESCRIPTION="Format a header and rows into a table"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-Carp
+ >=dev-perl/Importer-0.24.0
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-1.302.97
+ )
+"
+pkg_postinst() {
+ # optfeature "Improved Automatic detection of terminal width" Term::Size::Any
+ optfeature "Improved rendering of UTF8 Characters" '>=dev-perl/Unicode-LineBreak-2013.100.0'
+ optfeature "Automatic detection of terminal width" 'dev-perl/TermReadKey'
+}