summaryrefslogtreecommitdiff
path: root/dev-perl/Term-ReadLine-Perl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-18 04:54:42 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-18 04:54:42 +0000
commit5510d9d7d1c93c2ea71a2bd6f0666168808d5dd6 (patch)
treec968fff3108e2b4d88e4e564a56bfd066f170573 /dev-perl/Term-ReadLine-Perl
parent1dde4e5c4b92d849bf1abf0a48135b2a0644f7e1 (diff)
gentoo resync : 18.03.2018
Diffstat (limited to 'dev-perl/Term-ReadLine-Perl')
-rw-r--r--dev-perl/Term-ReadLine-Perl/Manifest3
-rw-r--r--dev-perl/Term-ReadLine-Perl/Term-ReadLine-Perl-1.30.300-r2.ebuild25
-rw-r--r--dev-perl/Term-ReadLine-Perl/files/Term-ReadLine-Perl-1.0303-nointeractive.patch78
-rw-r--r--dev-perl/Term-ReadLine-Perl/files/Term-ReadLine-Perl-1.0303-packlistcollision.patch56
4 files changed, 162 insertions, 0 deletions
diff --git a/dev-perl/Term-ReadLine-Perl/Manifest b/dev-perl/Term-ReadLine-Perl/Manifest
index 90fc6b02c912..148f980dcabd 100644
--- a/dev-perl/Term-ReadLine-Perl/Manifest
+++ b/dev-perl/Term-ReadLine-Perl/Manifest
@@ -1,3 +1,6 @@
+AUX Term-ReadLine-Perl-1.0303-nointeractive.patch 2435 BLAKE2B b2a5812f390fadaf5fb85de6115e8d0247a6944da984135429b50fefd9780caa7febb364b83331b9219823ddafca6623d4d075770cd5acf1880d23603e99804b SHA512 8184a917c512463af2dc3bd291c344b00375ba1863b0aaf9ceea641abed69532f3330cdda9b1d5e795e766103fdf935228651bb891c2daba1de30f6c5159e830
+AUX Term-ReadLine-Perl-1.0303-packlistcollision.patch 1822 BLAKE2B 052bcb575a8d4e96a6b7555141f8fd5ce848450257181f3f606269f46b9f6c29630e4537afcfaa2b91f91a932f3b4e4413cf48a8342860c1e28d5bef28ee3baf SHA512 eceea31331ae4e3e52f7d58b380f977099eef54c5f9c442ee6f01e6f3552db5c409f069cddc737acb34f52e78773542518b1589dc12e5cdc9186a21e65c10442
DIST Term-ReadLine-Perl-1.0303.tar.gz 48710 BLAKE2B ef85ea0104be2ce607a782ef50bc12bb5566536a310ffb98522c8ddc20752f937a9c21b4244c00becab90ff10b9b52f418cf59a6586ff4dc4182d4a19373ddb2 SHA512 df6a9f4ff2e02b0b0bc6b990fc2be091be7609322476f74bb6628148543804e30ac44ded991e7f8655bb25ecedf8e53497be6d0ce80b395edce35b9d84ad7937
EBUILD Term-ReadLine-Perl-1.30.300-r1.ebuild 467 BLAKE2B f75caad9a230fbc1ca6ff11310fcffbda8843e70526e15f053deca396e588f2c10eae2baf7904c84de7145184071e47863e77b5ce51fe726dcb2c6f1bb040be3 SHA512 a3dcc3eacf37ad7f2b552e85c7899d1a6c826c66b11aeac4598d72fc9a938a82ce5e3312c3c5a1968f6f832ed9e42a7c4e4927fc71a55437ba02dacd307896f5
+EBUILD Term-ReadLine-Perl-1.30.300-r2.ebuild 598 BLAKE2B 7dabf8b0bb1df38b9923207004b62793f8653b3f63671b6fbf7614fca53ea5ae67e43405359777ed5991a20ee893783951cbb4ac89ddccaa61fc3346f3cc44de SHA512 7049af12a0ac9d23c7962ea23d42808d808e2b51641d0b5c46456cfb17acff46f1fb3cda390921a69e87883543b471daea1b1c2fbff55132530f9f20984becd2
MISC metadata.xml 675 BLAKE2B 0bdb8e5cc615de9441abae61b77a5a8f6d04b396329741e5981fb9d2c9f8af742b0419453b81db818173a5797c01ded4bddeaa1359b0c6bd7b26ef36847084f2 SHA512 9b8158a057bcbefadb59c94c653d685332ba90fa6338f1e1ce907578b3ec669005f25d729434da1b23f90775d9a2ab31a73b114a7aa238a05f18e9d221d14050
diff --git a/dev-perl/Term-ReadLine-Perl/Term-ReadLine-Perl-1.30.300-r2.ebuild b/dev-perl/Term-ReadLine-Perl/Term-ReadLine-Perl-1.30.300-r2.ebuild
new file mode 100644
index 000000000000..7d5b9646aa7e
--- /dev/null
+++ b/dev-perl/Term-ReadLine-Perl/Term-ReadLine-Perl-1.30.300-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=ILYAZ
+DIST_SECTION=modules
+DIST_VERSION=1.0303
+
+inherit perl-module
+
+DESCRIPTION="Quick implementation of readline utilities"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0303-nointeractive.patch"
+ "${FILESDIR}/${PN}-1.0303-packlistcollision.patch"
+)
+RDEPEND="dev-perl/TermReadKey"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
diff --git a/dev-perl/Term-ReadLine-Perl/files/Term-ReadLine-Perl-1.0303-nointeractive.patch b/dev-perl/Term-ReadLine-Perl/files/Term-ReadLine-Perl-1.0303-nointeractive.patch
new file mode 100644
index 000000000000..d5e7a889466d
--- /dev/null
+++ b/dev-perl/Term-ReadLine-Perl/files/Term-ReadLine-Perl-1.0303-nointeractive.patch
@@ -0,0 +1,78 @@
+From 93b819a6723f096a2157325f437e1ae0c72a0a2c Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Wed, 14 Mar 2018 19:38:19 +1300
+Subject: Use file for input data instead of STDIN ( non-interactive testing )
+
+test.pl as-is is useless because it executes no readline code when in
+automated testing conditions.
+
+Additionally, attempting to use the built-in file redirection
+mechanisms is useless, as there's no way to set those parts from
+
+ make test
+
+And 'preput' support causes readline to barf when the input stream
+is not a real TTY.
+
+Subsequently, the pre-inserted "exit" also has to be removed.
+
+Bug: https://bugs.gentoo.org/492212
+---
+ t/input.txt | 2 ++
+ test.pl | 23 +++--------------------
+ 2 files changed, 5 insertions(+), 20 deletions(-)
+ create mode 100644 t/input.txt
+
+diff --git a/t/input.txt b/t/input.txt
+new file mode 100644
+index 0000000..6077553
+--- /dev/null
++++ b/t/input.txt
+@@ -0,0 +1,2 @@
++printf "input ok: sqrt(42)^2 == %20.20f", sqrt(42) * sqrt(42);
++exit 0
+diff --git a/test.pl b/test.pl
+index 7fcda2a..b2f7847 100755
+--- a/test.pl
++++ b/test.pl
+@@ -9,26 +9,9 @@ use Term::ReadLine;
+ use Carp;
+ $SIG{__WARN__} = sub { warn Carp::longmess(@_) };
+
+-my $ev;
+-if ($ENV{$ev = 'AUTOMATED_TESTING'} or $ENV{$ev = 'PERL_MM_NONINTERACTIVE'}) {
+- print "1..0 # skip: \$ENV{$ev} is TRUE\n";
+- exit;
+-}
++open (IN, '<','./t/input.txt') or die "Can't open input.txt, $@, $!";
++$term = Term::ReadLine->new('Simple Perl calc', \*IN, \*STDOUT);
+
+-if (!@ARGV) {
+- $term = new Term::ReadLine 'Simple Perl calc';
+-} elsif (@ARGV == 2) {
+- open(IN,"<$ARGV[0]");
+- open(OUT,">$ARGV[1]");
+- $term = new Term::ReadLine 'Simple Perl calc', \*IN, \*OUT;
+-} elsif ($ARGV[0] =~ m|^/dev|) {
+- open(IN,"<$ARGV[0]");
+- open(OUT,">$ARGV[0]");
+- $term = new Term::ReadLine 'Simple Perl calc', \*IN, \*OUT;
+-} else {
+- $term = new Term::ReadLine 'Simple Perl calc', \*STDIN, \*STDOUT;
+- $no_print = $ARGV[0] eq '--no-print';
+-}
+ $prompt = "Enter arithmetic or Perl expression: ";
+ if ((my $l = $ENV{PERL_RL_TEST_PROMPT_MINLEN} | 0) > length $prompt) {
+ $prompt =~ s/(?=:)/ ' ' x ($l - length $prompt)/e;
+@@ -51,7 +34,7 @@ print $OUT <<EOP;
+ this word should be already entered.)
+
+ EOP
+-while ( defined ($_ = $term->readline($prompt, "exit")) ) {
++while ( defined ($_ = $term->readline($prompt)) ) {
+ $res = eval($_);
+ warn $@ if $@;
+ print $OUT $res, "\n" unless $@ or $no_print;
+--
+2.16.2
+
diff --git a/dev-perl/Term-ReadLine-Perl/files/Term-ReadLine-Perl-1.0303-packlistcollision.patch b/dev-perl/Term-ReadLine-Perl/files/Term-ReadLine-Perl-1.0303-packlistcollision.patch
new file mode 100644
index 000000000000..b6fced559704
--- /dev/null
+++ b/dev-perl/Term-ReadLine-Perl/files/Term-ReadLine-Perl-1.0303-packlistcollision.patch
@@ -0,0 +1,56 @@
+From 635bf84ee3916ec578a56bdfaed39a4759dd6579 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Wed, 14 Mar 2018 19:40:00 +1300
+Subject: Fix NAME to reflect MAIN MODULE NAME
+
+Otherwise generated packlist is called "Term/ReadLine/.packlist"
+which collides with Term::ReadLine's
+---
+ MANIFEST | 4 ++--
+ Makefile.PL | 4 ++--
+ {ReadLine => lib/Term/ReadLine}/Perl.pm | 0
+ {ReadLine => lib/Term/ReadLine}/readline.pm | 0
+ 4 files changed, 4 insertions(+), 4 deletions(-)
+ rename {ReadLine => lib/Term/ReadLine}/Perl.pm (100%)
+ rename {ReadLine => lib/Term/ReadLine}/readline.pm (100%)
+
+diff --git a/MANIFEST b/MANIFEST
+index 633f90c..9a6d460 100755
+--- a/MANIFEST
++++ b/MANIFEST
+@@ -1,7 +1,7 @@
+ CHANGES
+ MANIFEST
+ Makefile.PL
+-ReadLine/Perl.pm
+-ReadLine/readline.pm
++lib/Term/ReadLine/Perl.pm
++lib/Term/ReadLine/readline.pm
+ README
+ test.pl
+diff --git a/Makefile.PL b/Makefile.PL
+index e9fb967..15b1dce 100755
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -3,8 +3,8 @@ use ExtUtils::MakeMaker;
+ # the contents of the Makefile that is written.
+ WriteMakefile(
+ DISTNAME => 'Term-ReadLine-Perl',
+- NAME => 'Term::ReadLine',
+- VERSION_FROM => 'ReadLine/readline.pm',
++ NAME => 'Term::ReadLine::Perl',
++ VERSION_FROM => 'lib/Term/ReadLine/readline.pm',
+ linkext => {LINKTYPE => '' },
+ # dist => {COMPRESS=>'gzip -9f', SUFFIX=>'gz',
+ # DIST_DEFAULT => 'all uutardist'},
+diff --git a/ReadLine/Perl.pm b/lib/Term/ReadLine/Perl.pm
+similarity index 100%
+rename from ReadLine/Perl.pm
+rename to lib/Term/ReadLine/Perl.pm
+diff --git a/ReadLine/readline.pm b/lib/Term/ReadLine/readline.pm
+similarity index 100%
+rename from ReadLine/readline.pm
+rename to lib/Term/ReadLine/readline.pm
+--
+2.16.2
+