summaryrefslogtreecommitdiff
path: root/dev-perl/Template-XML
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Template-XML
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Template-XML')
-rw-r--r--dev-perl/Template-XML/Manifest4
-rw-r--r--dev-perl/Template-XML/Template-XML-2.170.0-r1.ebuild25
-rw-r--r--dev-perl/Template-XML/files/bug-144689-branch-2.17.patch13
-rw-r--r--dev-perl/Template-XML/metadata.xml26
4 files changed, 68 insertions, 0 deletions
diff --git a/dev-perl/Template-XML/Manifest b/dev-perl/Template-XML/Manifest
new file mode 100644
index 000000000000..7ccfbdf8e31b
--- /dev/null
+++ b/dev-perl/Template-XML/Manifest
@@ -0,0 +1,4 @@
+AUX bug-144689-branch-2.17.patch 475 BLAKE2B 44d63e9ed48211099f1759f0e129c60074d24818a4d8e123af9f05eaf065771efb3507dac126a4eec99ddf3cc5ec0b4cccd745610ea8c7342bd6174d171f753f SHA512 266d8843dc06e63db06d036638c5885403c2018bc960de03aed95457758782ab858a6d5f85ee9924292fd7990ead556947cd13a180f02b3ad596594dce9b94be
+DIST Template-XML-2.17.tar.gz 26496 BLAKE2B a6423e5792ee54b458443f4b0dac198d907ff0cabda7f59e823c9f647ea1bdaf7122a19b9c54a4574d26dba3e48ab3dab11b9b7be482c4a1e74c5ff55667d12f SHA512 bc835332655b444b67337e0351cdb246f108a35df5010bf4cfee918f1603106a02a8e1534ecccf9fd34b4e7e02123b00edc2701a0382b665d06c6002c5f4be4d
+EBUILD Template-XML-2.170.0-r1.ebuild 538 BLAKE2B 45e2ba5301b140f7f0393591f7e58ffa31f307ddc658cf48fadfc47506a044b472df735c77debe032b82e4264d90cbc92c4f635f53653607d4d668d8a9aa924c SHA512 e9e5c6adc44e3873f7148798b98b0e08a20ca77b211c00a4a8237586fffcb9ad1a9eb38cc8979a4ed2b5c44b70aec62f49e8bcddc5a4db09b8eff7f669cc4e51
+MISC metadata.xml 1427 BLAKE2B d85b24b3b646923e28a1b42132a3edbe6f331c34aee3e1654a7addf1e2b8ce5ca2ee1a198ed1c08fa7488eff4c64f0772a8cba695be110290dbbef456b292ed2 SHA512 3cb3421790be2ce60cb3861a7a09e6785ab127e8fdbcaf7dd81dfed9cce4b13eaf35330458e7f6060169b0433eaaa580fe29f57308c445e11f093f195333a160
diff --git a/dev-perl/Template-XML/Template-XML-2.170.0-r1.ebuild b/dev-perl/Template-XML/Template-XML-2.170.0-r1.ebuild
new file mode 100644
index 000000000000..539ed035b550
--- /dev/null
+++ b/dev-perl/Template-XML/Template-XML-2.170.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=ABW
+MODULE_VERSION=2.17
+inherit perl-module
+
+DESCRIPTION="XML plugins for the Template Toolkit"
+
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~x86-fbsd ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=dev-perl/Template-Toolkit-2.15-r1
+ dev-perl/XML-DOM
+ dev-perl/XML-Parser
+ dev-perl/XML-RSS
+ dev-perl/XML-Simple
+ dev-perl/XML-XPath"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/bug-144689-branch-2.17.patch" )
+SRC_TEST="do"
diff --git a/dev-perl/Template-XML/files/bug-144689-branch-2.17.patch b/dev-perl/Template-XML/files/bug-144689-branch-2.17.patch
new file mode 100644
index 000000000000..c9c5c1cca0b7
--- /dev/null
+++ b/dev-perl/Template-XML/files/bug-144689-branch-2.17.patch
@@ -0,0 +1,13 @@
+--- Template-XML-2.17/lib/Template/Plugin/XML/LibXML.pm 2007-02-09
+09:48:07.000000000 -0600
++++ Template-XML-2.17-fixed/lib/Template/Plugin/XML/LibXML.pm 2007-02-19
+17:22:29.000000000 -0600
+@@ -112,7 +112,7 @@
+ eval { $parser->$method($args->{$method}) };
+
+ # if there's a problem throw a Tempalte::Exception
+- $self->throw("option '$method' not supported") if $@;
++ $class->throw("option '$method' not supported") if $@;
+ }
+
+ # parse
diff --git a/dev-perl/Template-XML/metadata.xml b/dev-perl/Template-XML/metadata.xml
new file mode 100644
index 000000000000..028cc40187b9
--- /dev/null
+++ b/dev-perl/Template-XML/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Template-XML</remote-id>
+ <remote-id type="cpan-module">Template::Plugin::XML</remote-id>
+ <remote-id type="cpan-module">Template::Plugin::XML::DOM</remote-id>
+ <remote-id type="cpan-module">Template::Plugin::XML::File</remote-id>
+ <remote-id type="cpan-module">Template::Plugin::XML::RSS</remote-id>
+ <remote-id type="cpan-module">Template::Plugin::XML::Simple</remote-id>
+ <remote-id type="cpan-module">Template::Plugin::XML::Style</remote-id>
+ <remote-id type="cpan-module">Template::Plugin::XML::View</remote-id>
+ <remote-id type="cpan-module">Template::Plugin::XML::View::Element</remote-id>
+ <remote-id type="cpan-module">Template::Plugin::XML::View::Parser</remote-id>
+ <remote-id type="cpan-module">Template::Plugin::XML::XPath</remote-id>
+ <remote-id type="cpan-module">XML::DOM::Element</remote-id>
+ <remote-id type="cpan-module">XML::DOM::Node</remote-id>
+ <remote-id type="cpan-module">XML::XPath::Node::Comment</remote-id>
+ <remote-id type="cpan-module">XML::XPath::Node::Element</remote-id>
+ <remote-id type="cpan-module">XML::XPath::Node::Text</remote-id>
+ </upstream>
+</pkgmetadata>