summaryrefslogtreecommitdiff
path: root/dev-perl/Template-Plugin-Cycle/Template-Plugin-Cycle-1.60.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Template-Plugin-Cycle/Template-Plugin-Cycle-1.60.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Template-Plugin-Cycle/Template-Plugin-Cycle-1.60.0.ebuild')
-rw-r--r--dev-perl/Template-Plugin-Cycle/Template-Plugin-Cycle-1.60.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-perl/Template-Plugin-Cycle/Template-Plugin-Cycle-1.60.0.ebuild b/dev-perl/Template-Plugin-Cycle/Template-Plugin-Cycle-1.60.0.ebuild
new file mode 100644
index 000000000000..3252874f10fa
--- /dev/null
+++ b/dev-perl/Template-Plugin-Cycle/Template-Plugin-Cycle-1.60.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR="ADAMK"
+DIST_VERSION="1.06"
+
+inherit perl-module
+
+DESCRIPTION="Cyclically insert into a Template from a sequence of values"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=dev-perl/Params-Util-1.60.0
+ >=dev-perl/Template-Toolkit-2.240.0
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install/use lib q[.]; use inc::Module::Install/' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}