summaryrefslogtreecommitdiff
path: root/dev-perl/Template-Plugin-Cycle/Template-Plugin-Cycle-1.60.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/Template-Plugin-Cycle/Template-Plugin-Cycle-1.60.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/Template-Plugin-Cycle/Template-Plugin-Cycle-1.60.0.ebuild')
-rw-r--r--dev-perl/Template-Plugin-Cycle/Template-Plugin-Cycle-1.60.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-perl/Template-Plugin-Cycle/Template-Plugin-Cycle-1.60.0.ebuild b/dev-perl/Template-Plugin-Cycle/Template-Plugin-Cycle-1.60.0.ebuild
new file mode 100644
index 000000000000..3252874f10fa
--- /dev/null
+++ b/dev-perl/Template-Plugin-Cycle/Template-Plugin-Cycle-1.60.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR="ADAMK"
+DIST_VERSION="1.06"
+
+inherit perl-module
+
+DESCRIPTION="Cyclically insert into a Template from a sequence of values"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=dev-perl/Params-Util-1.60.0
+ >=dev-perl/Template-Toolkit-2.240.0
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install/use lib q[.]; use inc::Module::Install/' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}