summaryrefslogtreecommitdiff
path: root/dev-perl/Sys-Virt/Sys-Virt-8.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-perl/Sys-Virt/Sys-Virt-8.3.0.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-perl/Sys-Virt/Sys-Virt-8.3.0.ebuild')
-rw-r--r--dev-perl/Sys-Virt/Sys-Virt-8.3.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-perl/Sys-Virt/Sys-Virt-8.3.0.ebuild b/dev-perl/Sys-Virt/Sys-Virt-8.3.0.ebuild
new file mode 100644
index 000000000000..cf4e90c07aca
--- /dev/null
+++ b/dev-perl/Sys-Virt/Sys-Virt-8.3.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Packages which get releases together:
+# app-emacs/nxml-libvirt-schemas
+# dev-python/libvirt-python
+# dev-perl/Sys-Virt
+# app-emulation/libvirt
+# Please bump them together!
+
+DIST_AUTHOR=DANBERR
+DIST_VERSION=v${PV}
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="API for using the libvirt library from Perl"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=app-emulation/libvirt-${PV}
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-CBuilder
+ dev-perl/Module-Build
+ virtual/pkgconfig
+ test? (
+ virtual/perl-Test-Simple
+ dev-perl/XML-XPath
+ virtual/perl-Time-HiRes
+ )"
+DEPEND="
+ >=app-emulation/libvirt-${PV}
+"
+
+src_compile() {
+ MAKEOPTS+=" -j1" perl-module_src_compile
+}