summaryrefslogtreecommitdiff
path: root/dev-perl/Sys-Syscall
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Sys-Syscall
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Sys-Syscall')
-rw-r--r--dev-perl/Sys-Syscall/Manifest4
-rw-r--r--dev-perl/Sys-Syscall/Sys-Syscall-0.250.0-r2.ebuild23
-rw-r--r--dev-perl/Sys-Syscall/files/Sys-Syscall-0.25-INSTALL.SKIP1
-rw-r--r--dev-perl/Sys-Syscall/metadata.xml13
4 files changed, 41 insertions, 0 deletions
diff --git a/dev-perl/Sys-Syscall/Manifest b/dev-perl/Sys-Syscall/Manifest
new file mode 100644
index 000000000000..8551fda53c84
--- /dev/null
+++ b/dev-perl/Sys-Syscall/Manifest
@@ -0,0 +1,4 @@
+AUX Sys-Syscall-0.25-INSTALL.SKIP 13 BLAKE2B 5477232d5849ecc7dc7bf4ef33af43a8136a2d93856dbdba484916a65093cb9c04b5a8a4969a5f081bf6ed94bd74c58790714c016a9bd2f7a7129c87455b71f9 SHA512 90f3f3dad86f5b9cf88fa9c22ed8011d8f4b463baee85de2e96f9af792a0b0101b40aa0e91df9dd87d8476a440261fd59de7d013b24e037e8120c18bf71876f7
+DIST Sys-Syscall-0.25.tar.gz 6222 BLAKE2B 7f5a6654ab3710bb4b0a074e2993fb4218b2c31267bf8b61147ba8037739a81c3eddbf316d011063e62055aba19076fd5781ad82475a33f05ab943e776f39353 SHA512 8b0641c992865cc7a29874a2166a4f0542039958839c6305cd4c33d17cfbdecd4f4ee74dc8110bfb000e42cabd803a84c6ba39037765d61ccb2bdf60522be87f
+EBUILD Sys-Syscall-0.250.0-r2.ebuild 532 BLAKE2B c5ebe7b59cd343585427f14aa34a60c94d36c003c47bcfb0a8bd5d3d856e8e8762d4892180c5854b162d3421f59bb2e99a1219683aa15b000b9d5533ac4e0265 SHA512 ab2921861fc8712d0494859d5bb5cc213b817abdc67700223c02ed951abe551a8c653d7364b647fc5f8a30f75c6577bbe8df805e74ba946edbceb16c4962b507
+MISC metadata.xml 497 BLAKE2B e7dfd5413f34e1c7b5c69b264f182e3ba94fbaca02af6d33e441c774abaa2e773c5fecc2d1ef6d279f9438cc1ee39cc049a7d5bd3d6157494a28b179073f8567 SHA512 a4d2df6449fecab3bbfb1a38c82c6395424ce17ccdfc899fa8b436101a5ca842e26e9580750a963cd5b50ba9e95dc015806e99993293e5dd368dc1202335920d
diff --git a/dev-perl/Sys-Syscall/Sys-Syscall-0.250.0-r2.ebuild b/dev-perl/Sys-Syscall/Sys-Syscall-0.250.0-r2.ebuild
new file mode 100644
index 000000000000..cae0a12536ec
--- /dev/null
+++ b/dev-perl/Sys-Syscall/Sys-Syscall-0.250.0-r2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=BRADFITZ
+MODULE_VERSION=0.25
+inherit perl-module
+
+DESCRIPTION="Access system calls that Perl doesn't normally provide access to"
+
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+SRC_TEST="do"
+
+src_prepare() {
+ # https://rt.cpan.org/Ticket/Display.html?id=118696
+ cp "${FILESDIR}/${PN}-${MODULE_VERSION}-INSTALL.SKIP" \
+ "${S}/INSTALL.SKIP" || die "Can't copy INSTALL.SKIP file"
+ perl-module_src_prepare
+}
diff --git a/dev-perl/Sys-Syscall/files/Sys-Syscall-0.25-INSTALL.SKIP b/dev-perl/Sys-Syscall/files/Sys-Syscall-0.25-INSTALL.SKIP
new file mode 100644
index 000000000000..4fd94be96e40
--- /dev/null
+++ b/dev-perl/Sys-Syscall/files/Sys-Syscall-0.25-INSTALL.SKIP
@@ -0,0 +1 @@
+README\.pod$
diff --git a/dev-perl/Sys-Syscall/metadata.xml b/dev-perl/Sys-Syscall/metadata.xml
new file mode 100644
index 000000000000..a76d44837dae
--- /dev/null
+++ b/dev-perl/Sys-Syscall/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <longdescription>Access system calls that Perl doesn't normally provide access to.</longdescription>
+ <upstream>
+ <remote-id type="cpan">Sys-Syscall</remote-id>
+ <remote-id type="cpan-module">Sys::Syscall</remote-id>
+ </upstream>
+</pkgmetadata>