summaryrefslogtreecommitdiff
path: root/dev-perl/Sys-Statistics-Linux
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Sys-Statistics-Linux
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Sys-Statistics-Linux')
-rw-r--r--dev-perl/Sys-Statistics-Linux/Manifest3
-rw-r--r--dev-perl/Sys-Statistics-Linux/Sys-Statistics-Linux-0.660.0-r1.ebuild36
-rw-r--r--dev-perl/Sys-Statistics-Linux/metadata.xml25
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-perl/Sys-Statistics-Linux/Manifest b/dev-perl/Sys-Statistics-Linux/Manifest
new file mode 100644
index 000000000000..eaf7541f4636
--- /dev/null
+++ b/dev-perl/Sys-Statistics-Linux/Manifest
@@ -0,0 +1,3 @@
+DIST Sys-Statistics-Linux-0.66.tar.gz 49987 BLAKE2B 1b0776dfc5693802366429b1c5f34bd2c19e270b0e2e4f606c58033eae9e112e7dd7e841d0bfb5e1e21e151cb28801fb5b40eb2975ebee1ee1b08be9c7bd03f1 SHA512 0387e7746d923860e5d9362f3259c19fc2e173cf6199aae11238a9bc0b588afe05026a876592845e0ac12f445cfb2c38ff7646fe9beed5807548179c7b2754b4
+EBUILD Sys-Statistics-Linux-0.660.0-r1.ebuild 614 BLAKE2B 5910b0eca09a04f5db2e2f8e6d9174cf319d01cfeb6da8446c08ccf4a0bde20e055557900dd521abd3f33cb2d242cc968dec0c73f3f7284af62fb1b19a717d0a SHA512 cace65a84215451a4e8f05204bea25e0c63f85ffb6d8ab350ef2b6151f0d939d1afd451477213cae8081e91c09fb527c7a1bc1fe4951cbb9c0817ea4b4a32688
+MISC metadata.xml 1448 BLAKE2B 11626695d31ebfd99d7a603c82d0d1de5c434a2e9aeac7ee3feb26af15ad30f94048765c03a018ddd41ebd1905042c283b1431fc7557eaddc1f36e44497ebd56 SHA512 9b7c4db52c8f5e8a2c793be13898c62918ec12657ef3b90581e9af5723625b88e8619b56e0af468ffc119578277001237647a5de96686e233dcad774831e3330
diff --git a/dev-perl/Sys-Statistics-Linux/Sys-Statistics-Linux-0.660.0-r1.ebuild b/dev-perl/Sys-Statistics-Linux/Sys-Statistics-Linux-0.660.0-r1.ebuild
new file mode 100644
index 000000000000..0f8afd93521b
--- /dev/null
+++ b/dev-perl/Sys-Statistics-Linux/Sys-Statistics-Linux-0.660.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=BLOONIX
+MODULE_VERSION=0.66
+inherit perl-module
+
+DESCRIPTION="Collect linux system statistics"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND="dev-perl/YAML-Syck"
+DEPEND="
+ dev-perl/Module-Build
+ test? (
+ virtual/perl-Test-Simple
+ )"
+
+SRC_TEST="do"
+
+src_install() {
+ perl-module_src_install
+
+ docompress -x /usr/share/doc/$PF/examples
+ insinto /usr/share/doc/$PF/examples
+ doins examples/*
+}
+
+src_test() {
+ perl_rm_files t/001-pod.t t/002-pod-coverage.t
+ perl-module_src_test
+}
diff --git a/dev-perl/Sys-Statistics-Linux/metadata.xml b/dev-perl/Sys-Statistics-Linux/metadata.xml
new file mode 100644
index 000000000000..10238bd69712
--- /dev/null
+++ b/dev-perl/Sys-Statistics-Linux/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Sys-Statistics-Linux</remote-id>
+ <remote-id type="cpan-module">Sys::Statistics::Linux</remote-id>
+ <remote-id type="cpan-module">Sys::Statistics::Linux::Compilation</remote-id>
+ <remote-id type="cpan-module">Sys::Statistics::Linux::CpuStats</remote-id>
+ <remote-id type="cpan-module">Sys::Statistics::Linux::DiskStats</remote-id>
+ <remote-id type="cpan-module">Sys::Statistics::Linux::DiskUsage</remote-id>
+ <remote-id type="cpan-module">Sys::Statistics::Linux::FileStats</remote-id>
+ <remote-id type="cpan-module">Sys::Statistics::Linux::LoadAVG</remote-id>
+ <remote-id type="cpan-module">Sys::Statistics::Linux::MemStats</remote-id>
+ <remote-id type="cpan-module">Sys::Statistics::Linux::NetStats</remote-id>
+ <remote-id type="cpan-module">Sys::Statistics::Linux::PgSwStats</remote-id>
+ <remote-id type="cpan-module">Sys::Statistics::Linux::ProcStats</remote-id>
+ <remote-id type="cpan-module">Sys::Statistics::Linux::Processes</remote-id>
+ <remote-id type="cpan-module">Sys::Statistics::Linux::SockStats</remote-id>
+ <remote-id type="cpan-module">Sys::Statistics::Linux::SysInfo</remote-id>
+ </upstream>
+</pkgmetadata>