summaryrefslogtreecommitdiff
path: root/dev-perl/Sub-Quote/Sub-Quote-2.6.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
commit129160ec854dca4c3fedb5bcfbcb56930371da0f (patch)
tree53bf797418ac5e9b99c41ca0382c87b82421e5de /dev-perl/Sub-Quote/Sub-Quote-2.6.6.ebuild
parent441d1370330332b7d78f238d2f5e13f7aed5e4e0 (diff)
gentoo new year resync : 01.01.2021
Diffstat (limited to 'dev-perl/Sub-Quote/Sub-Quote-2.6.6.ebuild')
-rw-r--r--dev-perl/Sub-Quote/Sub-Quote-2.6.6.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/Sub-Quote/Sub-Quote-2.6.6.ebuild b/dev-perl/Sub-Quote/Sub-Quote-2.6.6.ebuild
new file mode 100644
index 000000000000..62498814c856
--- /dev/null
+++ b/dev-perl/Sub-Quote/Sub-Quote-2.6.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=HAARG
+DIST_VERSION=2.006006
+inherit perl-module
+
+DESCRIPTION="Efficient generation of subroutines via string eval"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test minimal"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !<dev-perl/Moo-2.3.0
+ !minimal? (
+ >=dev-perl/Sub-Name-0.80.0
+ )
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=dev-perl/Test-Fatal-0.3.0
+ >=virtual/perl-Test-Simple-0.940.0
+ )
+"